Published 5月 31, 2018 by with 0 comment

CCNP-BSCI-v5.0 Lab 5-5: Configuring the Cisco IOS DHCP Server


本次練習是參考Cisco網路學院
CCNP1 Building Scalable Internetworks v5.0
Student Lab Manual
我將它轉成Dynamips的設定檔 並寫下自己的實驗紀錄

Dynamips的設定檔:
##################################################
#
# For CCNP1 Building Scalable Internetworks v5.0
# Lab 5_6_5
#
##################################################
autostart=false
[localhost:7200]
workingdir = /opt/dynamips/dynagen-0.10.1/UTS/CCNP1/Week04/workingconfig/
[[3640]]
#  Specify 3640 IOS image on Windows here:
#  image = C:\Program Files\Dynamips\images\c3640-jk9o3s-mz.123-14.T7.extracted.bin
#  Specify 3640 IOS image on Linux here:
 image = /opt/dynamips/images/c3640-jk.bin
 ram = 128
 disk0 = 0
 disk1 = 0
 # Choose an idlepc value from the below
 idlepc = 0x605ac7b8
 mmap = true
 ghostios = true
 confreg = 0x2102

###########################
#
# Define router instances 1
#
###########################
  
 [[Router R1]]
  model = 3640
  console = 2001
  slot0 = NM-4T
 [[Router R2]]
  model = 3640
  console = 2002
  slot0 = NM-4T
  slot1 = NM-1FE-TX
  S0/0 = R1 S0/0
 [[Router R3]]
  model = 3640
  console = 2003
  slot0 = NM-1FE-TX
 [[Router SW1]]
  model = 3640
  console = 2004
  slot0 = NM-16ESW
  F0/2 = R2 F1/0
  F0/3 = R3 F0/0
這Lab學習目標為
‧ Configure and verify the operation of the Cisco IOS DHCP server
‧ Configure an IP Helper address
‧ Review the EIGRP configuration
我的設定是
1. Assign IP Addresses
R1:
hostname R1
!
no ip domain lookup
!
interface Loopback1
 ip address 172.16.1.1 255.255.255.0
!        
interface Serial0/0
 ip address 172.16.12.1 255.255.255.0
 no shutdown
!
line con 0
 logging synchronous
!
end
R2:
hostname R2
!
no ip domain lookup
!
interface Loopback2
 ip address 172.16.2.1 255.255.255.0
!        
interface Serial0/0
 ip address 172.16.12.2 255.255.255.0
 no shutdown
!
interface FastEthernet1/0
 ip address 172.16.23.2 255.255.255.0
 no shutdown
!
line con 0
 logging synchronous
!
end
2. Configure EIGRP
R1-2:
router eigrp 1
 network 172.16.0.0
 no auto-summary
3. Configure a DHCP Pool
R2:
ip dhcp excluded-address 172.16.23.1 172.16.23.100
!
ip dhcp pool VLAN1-POOL
   network 172.16.23.0 255.255.255.0
   default-router 172.16.23.2
   domain-name Cisco.com
   lease 1 5 36
!
debug ip dhcp server events
!
debug ip dhcp server packets
R3:
interface FastEthernet0/0
 ip address dhcp
 no shutdown
!
debug ip packet detail

4. Verify DHCP Lease on Client
R3:
show ip interface brief
5. Verify DHCP Configuration on Server
R2:
show ip dhcp ?
6. DHCPRELEASE and DHCPRENEW
R3:
interface fastEthernet 0/0
 shutdown
 no shutdown
!
renew dhcp fastEthernet 0/0
7. Configure the IP Helper Address
R1:
interface Loopback1
 ip helper-address 172.16.2.1
!
show ip helper-address
!
ip forward-protocol udp 50000
8. Check Command
show ip interface brief
ping

R1 Configuration:
hostname R1
!
no ip domain lookup
!
interface Loopback1
 ip address 172.16.1.1 255.255.255.0
 ip helper-address 172.16.2.1
!
interface Serial0/0
 ip address 172.16.12.1 255.255.255.0
 no shutdown
!
router eigrp 1
 network 172.16.0.0
 no auto-summary
!
ip forward-protocol udp 50000
!
line con 0
 logging synchronous
!
end
R2 Configuration:
hostname R2
!
no ip domain lookup
!
ip dhcp excluded-address 172.16.23.1 172.16.23.100
!
ip dhcp pool VLAN1-POOL
   network 172.16.23.0 255.255.255.0
   default-router 172.16.23.2
   domain-name Cisco.com
   lease 1 5 36
!
interface Loopback2
 ip address 172.16.2.1 255.255.255.0
!
interface Serial0/0
 ip address 172.16.12.2 255.255.255.0
 no shutdown
!
interface FastEthernet1/0
 ip address 172.16.23.2 255.255.255.0
 duplex auto
 speed auto
!
router eigrp 1
 network 172.16.0.0
 no auto-summary
!
line con 0
 logging synchronous
!
end
R3 Configuration:
hostname R3
!
no ip domain lookup
!
interface FastEthernet0/0
 ip address dhcp
 no shutdown
!
line con 0
 logging synchronous
!
end
參考資料:
Cisco網路學院 http://www.cisco.com/web/learning/netacad/index.html
CCNP1 Building Scalable Internetworks v5.0
Student Lab Manual

最初發表 / 最後更新: 2008.04.22 / 2018.05.31

0 comments:

張貼留言