Published 5月 31, 2018 by with 0 comment

CCNP-BSCI-v5.0 Lab 6-4: BGP Route Reflectors and Route Filters


本次練習是參考Cisco網路學院
CCNP1 Building Scalable Internetworks v5.0
Student Lab Manual
我將它轉成Dynamips的設定檔 並寫下自己的實驗紀錄

Dynamips的設定檔:
##################################################
#
# For CCNP1 Building Scalable Internetworks v5.0
# Lab 6_7_1-2,4
#
##################################################
autostart=false
[localhost:7200]
workingdir = /opt/dynamips/dynagen-0.10.1/UTS/CCNP1/Week05/workingconfig/
[[3640]]
#  Specify 3640 IOS image on Windows here:
#  image = C:\Program Files\Dynamips\images\c3640-jk9o3s-mz.123-14.T7.extracted.bin
#  Specify 3640 IOS image on Linux here:
 image = /opt/dynamips/images/c3640-jk.bin
 ram = 128
 disk0 = 0
 disk1 = 0
 # Choose an idlepc value from the below
 idlepc = 0x605ac7b8
 mmap = true
 ghostios = true
 confreg = 0x2102

###########################
#
# Define router instances 1
#
###########################
  
 [[Router R1]]
  model = 3640
  console = 2001
  slot0 = NM-4T
 [[Router R2]]
  model = 3640
  console = 2002
  slot0 = NM-4T
  S0/0 = R1 S0/0
  S0/1 = R3 S0/1
 [[Router R3]]
  model = 3640
  console = 2003
  slot0 = NM-4T
這Lab學習目標為
In this lab, you will configure IBGP routers to use a route reflector and a simple route filter.
我的設定是
1. Configure RIPv2
Use RIPv2 as the IGP. Do not configure the 199.9.9.0 network under the RIP process.
SanJose1:
hostname SanJose1
!
no ip domain lookup
!
interface Serial0/0
 ip address 192.168.1.5 255.255.255.252
 no shutdown
!
router rip
 version 2
 network 192.168.1.0
 no auto-summary
!
line con 0
 exec-timeout 0 0
 logging synchronous
!
end
SanJose2:
hostname SanJose2
!
no ip domain lookup
!
interface Loopback0
 ip address 200.100.50.1 255.255.255.0
!        
interface Serial0/0
 ip address 192.168.1.6 255.255.255.252
 no shutdown
!
interface Serial0/1
 ip address 172.24.1.17 255.255.255.0
 no shutdown
!
router rip
 version 2
 network 172.24.0.0
 network 192.168.1.0
 network 200.100.50.0
 no auto-summary
!
line con 0
 exec-timeout 0 0
 logging synchronous
!
end
SanJose3:
hostname SanJose3
!
no ip domain lookup
!       
interface Serial0/1
 ip address 172.24.1.18 255.255.255.0
 no shutdown
!
router rip
 version 2
 network 172.24.0.0
 no auto-summary
!
line con 0
 exec-timeout 0 0
 logging synchronous
!
end
2. IBGP Peers and Route Reflectors
Configure the IBGP peers for BGP.
SanJose1:
router bgp 100
 neighbor 192.168.1.6 remote-as 100
SanJose2:
router bgp 100
 network 172.24.1.0 mask 255.255.255.0
 network 192.168.1.0 mask 255.255.255.252
 network 200.100.50.0
 neighbor 172.24.1.18 remote-as 100
 neighbor 192.168.1.5 remote-as 100
SanJose3:
router bgp 100
 neighbor 172.24.1.17 remote-as 100
3. Inject an External Route into BGP
configure SanJose3 to inject external routing information into BGP
SanJose3:
interface Loopback0
 ip address 199.9.9.1 255.255.255.0
!
router bgp 100
 network 199.9.9.0
SanJose2:
router bgp 100
 neighbor 172.24.1.18 route-reflector-client
 neighbor 192.168.1.5 route-reflector-client
4. Inject a Summary Address into BGP
Configure SanJose3 to inject a summary address into BGP.Configure a route filter to prevent SanJose2 from sending the 199.9.9.0/24 route to its other clients, in this case to SanJose1.
SanJose3:
router bgp 100
 aggregate-address 199.0.0.0 255.0.0.0
!
show ip bgp 199.0.0.0
!
Configure a route filter to prevent SanJose2 from sending the 199.9.9.0/24 route to its other clients, in this case to SanJose1.
SanJose2:
!
ip prefix-list Supernetonly seq 5 permit 199.0.0.0/8
ip prefix-list Supernetonly seq 10 permit 172.24.0.0/24
ip prefix-list Supernetonly seq 15 permit 200.100.50.0/24
!
router bgp 100
 neighbor 192.168.1.5 prefix-list Supernetonly out
SanJose1:
clear ip bgp *
!
show ip route
Final Configurations
SanJose1 Configuration:
hostname SanJose1
!
no ip domain lookup
!
interface Serial0/0
 ip address 192.168.1.5 255.255.255.252
 no shutdown
!
router rip
 version 2
 network 192.168.1.0
 no auto-summary
!
router bgp 100
 no synchronization
 neighbor 192.168.1.6 remote-as 100
 no auto-summary
!
line con 0
 exec-timeout 0 0
 logging synchronous
!
end
SanJose2 Configuration:
hostname SanJose2
!
no ip domain lookup
!
interface Loopback0
 ip address 200.100.50.1 255.255.255.0
!        
interface Serial0/0
 ip address 192.168.1.6 255.255.255.252
 no shutdown
!
interface Serial0/1
 ip address 172.24.1.17 255.255.255.0
 no shutdown
!
router rip
 version 2
 network 172.24.0.0
 network 192.168.1.0
 network 200.100.50.0
 no auto-summary
!
router bgp 100
 no synchronization
 network 172.24.1.0 mask 255.255.255.0
 network 192.168.1.0 mask 255.255.255.252
 network 200.100.50.0
 neighbor 172.24.1.18 remote-as 100
 neighbor 172.24.1.18 route-reflector-client
 neighbor 192.168.1.5 remote-as 100
 neighbor 192.168.1.5 route-reflector-client
 neighbor 192.168.1.5 prefix-list Supernetonly out
 no auto-summary
!
ip prefix-list Supernetonly seq 5 permit 199.0.0.0/8
ip prefix-list Supernetonly seq 10 permit 172.24.0.0/24
ip prefix-list Supernetonly seq 15 permit 200.100.50.0/24
!
line con 0
 exec-timeout 0 0
 logging synchronous
!
end  
SanJose3 Configuration:
hostname SanJose3
!
no ip domain lookup
!
interface Loopback0
 ip address 199.9.9.1 255.255.255.0
!
interface Serial0/1
 ip address 172.24.1.18 255.255.255.0
 no shutdown
!
router rip
 version 2
 network 172.24.0.0
 no auto-summary
!
router bgp 100
 no synchronization
 network 199.9.9.0
 aggregate-address 199.0.0.0 255.0.0.0
 neighbor 172.24.1.17 remote-as 100
 no auto-summary
!
line con 0
 exec-timeout 0 0
 logging synchronous
!
end
參考資料:
Cisco網路學院 http://www.cisco.com/web/learning/netacad/index.html
CCNP1 Building Scalable Internetworks v5.0
Student Lab Manual

最初發表 / 最後更新: 2008.04.30 / 2018.05.31

0 comments:

張貼留言