Published 5月 31, 2018 by with 0 comment

CCNP-BSCI-v5.0 Lab 5-4: Manipulating Administrative Distances







本次練習是參考Cisco網路學院
CCNP1 Building Scalable Internetworks v5.0
Student Lab Manual
我將它轉成Dynamips的設定檔 並寫下自己的實驗紀錄

Dynamips的設定檔:
##################################################
#
# For CCNP1 Building Scalable Internetworks v5.0
# Lab 5_4
#
##################################################
autostart=false
[localhost:7200]
workingdir = /opt/dynamips/dynagen-0.10.1/UTS/CCNP1/Week04/workingconfig/
[[3640]]
#  Specify 3640 IOS image on Windows here:
#  image = C:\Program Files\Dynamips\images\c3640-jk9o3s-mz.123-S14.T7.extracted.bin
#  Specify 3640 IOS image on Linux here:
 image = /opt/dynamips/images/c3640-jk.bin
 ram = 128
 disk0 = 0
 disk1 = 0
 # Choose an idlepc value from the below
 idlepc = 0x605ac7b8
 mmap = true
 ghostios = true
 confreg = 0x2102

###########################
#
# Define router instances 1
#
###########################
  
 [[Router R1]]
  model = 3640
  console = 2001
  slot0 = NM-1FE-TX
  slot1 = NM-4T
  S1/1 = R3 S1/0
 [[Router R2]]
  model = 3640
  console = 2002
  slot0 = NM-1FE-TX
  slot1 = NM-1FE-TX
 [[Router R3]]
  model = 3640
  console = 2003
  slot0 = NM-1FE-TX
  slot1 = NM-4T
 [[Router SW1]]
  model = 3640
  console = 2004
  slot0 = NM-16ESW
  F0/1 = R1 F0/0
  F0/3 = R2 F0/0
  F0/5 = R2 F1/0
  F0/7 = R3 F0/0
這Lab是Manipulating Administrative Distances設定練習
我的設定是
1. 先設定SW1 and R1-3每個介面的ip address
SW1
hostname SW1
!
no ip routing
!
no ip domain lookup
!
line con 0
 logging synchronous
!
end
R1:
hostname R1
!
no ip domain lookup
!
interface Loopback1
 ip address 172.16.1.1 255.255.255.0
!        
interface Loopback101
 ip address 192.168.101.1 255.255.255.0
!
interface FastEthernet0/0
 ip address 172.16.12.1 255.255.255.0
 no shutdown
!
interface Serial1/1
 bandwidth 64
 ip address 172.16.13.1 255.255.255.0
 no shutdown
!
line con 0
 logging synchronous
!
end
R2:
hostname R2
!
no ip domain lookup
!
interface Loopback2
 ip address 172.16.2.1 255.255.255.0
!        
interface Loopback102
 ip address 192.168.102.1 255.255.255.0
!
interface FastEthernet0/0
 ip address 172.16.12.2 255.255.255.0
 no shutdown
!
interface FastEthernet1/0
 ip address 172.16.23.2 255.255.255.0
 no shutdown
!
line con 0
 logging synchronous
!
end
R3:
hostname R3
!
no ip domain lookup
!
interface Loopback3
 ip address 172.16.3.1 255.255.255.0
!        
interface Loopback103
 ip address 192.168.103.1 255.255.255.0
!
interface FastEthernet0/0
 ip address 172.16.23.3 255.255.255.0
 no shutdown
!
interface Serial1/0
 bandwidth 64
 ip address 172.16.13.3 255.255.255.0
 no shutdown
!
line con 0
 logging synchronous
!
end
2. Configure RIPv2 (Check next hop on R1 for 172.16.3.1)
R1:
router rip
 version 2
 network 172.16.0.0
 network 192.168.101.0
 no auto-summary
R2:
router rip
 version 2
 network 172.16.0.0
 network 192.168.102.0
 no auto-summary
R3:
router rip
 version 2
 network 172.16.0.0
 network 192.168.103.0
 no auto-summary
3. Configure OSPF (Check next hop on R1 for 172.16.3.1)
R1:
router ospf 1
 network 172.16.0.0 0.0.255.255 area 0
 network 192.168.101.0 0.0.0.255 area 0
R2:
router ospf 1
 network 172.16.0.0 0.0.255.255 area 0
 network 192.168.102.0 0.0.0.255 area 0
R3:
router ospf 1
 network 172.16.0.0 0.0.255.255 area 0
 network 192.168.103.0 0.0.0.255 area 0
4. Modify a Routing Protocol's Distance
R1-3:
router rip
 distance 100
5. Modify distance Based on Route Source
R1-3:
router ospf 1
 distance 85 192.168.100.0 0.0.3.255
6. Modify distance Based on Access List
R1-3:
access-list 1 permit 172.16.0.0 0.0.255.255
!
router rip
 distance 65 0.0.0.0 255.255.255.255 1
7. Check Command
show ip rip database
show ip protocols
show ip ospf neighbor
ping

R1 Configuration:
hostname R1
!
no ip domain lookup
!
interface Loopback1
 ip address 172.16.1.1 255.255.255.0
 ip ospf network point-to-point
!
interface Loopback101
 ip address 192.168.101.1 255.255.255.0
 ip ospf network point-to-point
!
interface FastEthernet0/0
 ip address 172.16.12.1 255.255.255.0
 no shutdown
!
interface Serial1/1
 bandwidth 64
 ip address 172.16.13.1 255.255.255.0
 no shutdown
!
router ospf 1
 network 172.16.0.0 0.0.255.255 area 0
 network 192.168.101.0 0.0.0.255 area 0
 distance 85 192.168.100.0 0.0.3.255
!
router rip
 version 2
 network 172.16.0.0
 network 192.168.101.0
 distance 100
 distance 65 0.0.0.0 255.255.255.255 1
 no auto-summary
!
access-list 1 permit 172.16.0.0 0.0.255.255
!
line con 0
 logging synchronous
!
end
R2 Configuration:
hostname R2
!
no ip domain lookup
!
interface Loopback2
 ip address 172.16.2.1 255.255.255.0
 ip ospf network point-to-point
!
interface Loopback102
 ip address 192.168.102.1 255.255.255.0
 ip ospf network point-to-point
!
interface FastEthernet0/0
 ip address 172.16.12.2 255.255.255.0
 no shutdown
!
interface FastEthernet1/0
 ip address 172.16.23.2 255.255.255.0
 no shutdown
!
router ospf 1
 network 172.16.0.0 0.0.255.255 area 0
 network 192.168.102.0 0.0.0.255 area 0
 distance 85 192.168.100.0 0.0.3.255
!
router rip
 version 2
 network 172.16.0.0
 network 192.168.102.0
 distance 100
 distance 65 0.0.0.0 255.255.255.255 1
 no auto-summary
!
access-list 1 permit 172.16.0.0 0.0.255.255
!
line con 0
 logging synchronous
!
end
R3 Configuration:
hostname R3
!
no ip domain lookup
!
interface Loopback3
 ip address 172.16.3.1 255.255.255.0
 ip ospf network point-to-point
!
interface Loopback103
 ip address 192.168.103.1 255.255.255.0
 ip ospf network point-to-point
!
interface FastEthernet0/0
 ip address 172.16.23.3 255.255.255.0
 no shutdown
!
interface Serial1/0
 bandwidth 64
 ip address 172.16.13.3 255.255.255.0
 no shutdown
!
router ospf 1
 network 172.16.0.0 0.0.255.255 area 0
 network 192.168.103.0 0.0.0.255 area 0
 distance 85 192.168.100.0 0.0.3.255
!
router rip
 version 2
 network 172.16.0.0
 network 192.168.103.0
 distance 100
 distance 65 0.0.0.0 255.255.255.255 1
 no auto-summary
!
access-list 1 permit 172.16.0.0 0.0.255.255
!
line con 0
 logging synchronous
!
end

參考資料:
Cisco網路學院 http://www.cisco.com/web/learning/netacad/index.html
CCNP1 Building Scalable Internetworks v5.0
Student Lab Manual

最初發表 / 最後更新: 2008.04.04 / 2018.05.31

0 comments:

張貼留言