Published 5月 31, 2018 by with 0 comment

CCNP-BSCI-v5.0 Lab 7-2: Routing IP Multicast with PIM Dense Mode


本次練習是參考Cisco網路學院
CCNP1 Building Scalable Internetworks v5.0
Student Lab Manual
我將它轉成Dynamips的設定檔 並寫下自己的實驗紀錄

Dynamips的設定檔:
##################################################
#
# For CCNP1 Building Scalable Internetworks v5.0
# Lab 7_2-4
#
##################################################
autostart=false
[localhost:7200]
workingdir = /opt/dynamips/dynagen-0.10.1/UTS/CCNP1/Week06/workingconfig/
[[3640]]
#  Specify 3640 IOS image on Windows here:
#  image = C:\Program Files\Dynamips\images\c3640-jk9o3s-mz.123-S14.T7.extracted.bin
#  Specify 3640 IOS image on Linux here:
 image = /opt/dynamips/images/c3640-jk.bin
 ram = 128
 disk0 = 0
 disk1 = 0
 # Choose an idlepc value from the below
 idlepc = 0x605ac7b8
 mmap = true
 ghostios = true
 confreg = 0x2102

###########################
#
# Define router instances 1
#
###########################
  
 [[Router R1]]
  model = 3640
  console = 2001
  slot0 = NM-4T
  slot1 = NM-1FE-TX
  S0/1 = R3 S0/0
 [[Router R2]]
  model = 3640
  console = 2002
  slot0 = NM-4T
  slot1 = NM-1FE-TX
  S0/0 = R1 S0/0
  S0/1 = R3 S0/1
 [[Router R3]]
  model = 3640
  console = 2003
  slot0 = NM-4T
  slot1 = NM-1FE-TX
 [[Router SW1]]
  model = 3640
  console = 2004
  slot0 = NM-16ESW
  F0/3 = R1 F1/0
  F0/5 = R3 F1/0
 [[Router SW2]]
  model = 3640
  console = 2005
  slot0 = NM-16ESW
  F0/3 = R2 F1/0
這Lab學習目標為
• Implement IGMP
• Review configuration of EIGRP
• Implement and verify PIM-DM operation and adjacencies
• Verify IGMP operation of PIM-DM flooding and pruning
• Explore the multicast routing table
場景:
The multicast source is a host on VLAN 20. A remote network at each site represented by a loopback interface should receive the press feed of the CEO’s message.
我的設定是
1. Configure Addressing and Implement IGMP
R1:
hostname R1
!
no ip domain lookup
!
interface Loopback1
 ip address 192.168.1.1 255.255.255.0
!        
interface Serial0/0
 ip address 172.16.102.1 255.255.255.248
 no shut
!
interface Serial0/1
 ip address 172.16.103.1 255.255.255.248
 no shut
!
interface FastEthernet1/0
 ip address 172.16.13.1 255.255.255.0
 no shut
!        
line con 0
 exec-timeout 0 0
 logging synchronous
!
end
R2:
hostname R2
!
no ip domain lookup
!
interface Loopback2
 ip address 192.168.2.1 255.255.255.0
!        
interface Serial0/0
 ip address 172.16.102.2 255.255.255.248
 no shut
!
interface Serial0/1
 ip address 172.16.203.2 255.255.255.248
 no shut
!
interface FastEthernet1/0
 ip address 172.16.20.2 255.255.255.0
 no shut
!        
line con 0
 exec-timeout 0 0
 logging synchronous
!
end
R3:
hostname R3
!
no ip domain lookup
!
interface Loopback3
 ip address 192.168.3.1 255.255.255.0
!        
interface Serial0/0
 ip address 172.16.103.3 255.255.255.248
 no shut
!
interface Serial0/1
 ip address 172.16.203.3 255.255.255.248
 no shut
!
interface FastEthernet1/0
 ip address 172.16.13.3 255.255.255.0
 no shut
!        
line con 0
 exec-timeout 0 0
 logging synchronous
!
end
SW1:
vlan database
vtp domain cisco
vlan 13
exit
conf t
!
hostname SW1
!
no ip routing
!
no ip domain lookup
!
interface FastEthernet0/3
 switchport access vlan 13
!
interface FastEthernet0/5
 switchport access vlan 13
!
line con 0
 exec-timeout 0 0
 logging synchronous
!
end
SW2:(Use a switched virtual interface (SVI) on SW2 to simulate a multicast source on the VLAN 20 subnet. This will be used to generate a repeated multicast ping to simulate the multicast traffic while you set up the network.)
enable
vlan database
vtp domain class
vlan 20
exit
!
conf t
!
hostname SW2
!
no ip domain lookup
!
no ip routing
!
interface FastEthernet0/3
 switchport access vlan 20
!
interface Vlan20
 ip address 172.16.20.4 255.255.255.0
!
ip default-gateway 172.16.20.2
!
line con 0
 exec-timeout 0 0
 logging synchronous
!
end
Using IGMP, subscribe each of the loopback interfaces on the three routers to the multicast group 232.32.32.32.
R1:
interface loopback 1
 ip  igmp join-group 232.32.32.32
R2:
interface loopback 2
 ip  igmp join-group 232.32.32.32
R3:
interface loopback 3
 ip  igmp join-group 232.32.32.32
R1 & R2 & R3:
show ip igmp groups

2. Configure EIGRP
R1 & R2 & R3:
router eigrp 1
network 192.168.0.0 0.0.255.255
network 172.16.0.0
!!check PING OK!!

3. Implement PIM-DM
SW2:
ping 232.32.32.32
SW2#ping 232.32.32.32
Type escape sequence to abort.
Sending 1, 100-byte ICMP Echos to 232.32.32.32, timeout is 2 seconds:
.
SW2#
R1 & R2 & R3:
ip multicast-routing
R2:
interface Loopback2
 ip pim dense-mode
!
interface FastEthernet1/0
 ip pim dense-mode

SW2
SW2#ping 232.32.32.32
Type escape sequence to abort.
Sending 1, 100-byte ICMP Echos to 232.32.32.32, timeout is 2 seconds:
Reply to request 0 from 172.16.20.2, 20 ms
SW2#
R2:
show ip mroute
(172.16.20.4, 232.32.32.32), 00:00:03/00:02:58, flags: LT
  Incoming interface: FastEthernet1/0, RPF nbr 0.0.0.0
  Outgoing interface list:
    Loopback2, Forward/Dense, 00:00:03/00:00:00
R1:
interface Loopback1
 ip pim dense-mode
!
interface Serial0/0
 ip pim dense-mode
!
interface Serial0/1
 ip pim dense-mode
!  
interface FastEthernet1/0
 ip pim dense-mode
R2:
interface Serial0/0
 ip pim dense-mode
!
interface Serial0/1
 ip pim dense-mode
R3:
interface Loopback3
 ip pim dense-mode
!
interface Serial0/0
 ip pim dense-mode
!
interface Serial0/1
 ip pim dense-mode
!  
interface FastEthernet1/0
 ip pim dense-mode
SW2:
SW2#ping 232.32.32.32
Type escape sequence to abort.
Sending 1, 100-byte ICMP Echos to 232.32.32.32, timeout is 2 seconds:
Reply to request 0 from 172.16.20.2, 20 ms
Reply to request 0 from 172.16.203.3, 44 ms
Reply to request 0 from 172.16.102.1, 44 ms
SW2#

4. Verify PIM Adjacencies
R1 & R2 & R3:
show ip pim neighbors
show ip pim interface detail

5. Verify Multicast Routing Operation
R1 & R2 & R3:
mrinfo
show ip multicast interface
Generate a stream of multicast data to the group by issuing an extended ping from SW2 with a repeat count of 10.
SW2#ping
Protocol [ip]:
Target IP address: 232.32.32.32
Repeat count [1]: 10
Datagram size [100]:
Timeout in seconds [2]:
Extended commands [n]:
Sweep range of sizes [n]:
Type escape sequence to abort.
Sending 10, 100-byte ICMP Echos to 232.32.32.32, timeout is 2 seconds:
Reply to request 0 from 172.16.20.2, 20 ms
Reply to request 0 from 172.16.203.3, 44 ms
Reply to request 0 from 172.16.102.1, 44 ms
Reply to request 1 from 172.16.20.2, 4 ms
Reply to request 1 from 172.16.203.3, 28 ms
Reply to request 1 from 172.16.102.1, 16 ms
Reply to request 2 from 172.16.20.2, 4 ms
Reply to request 2 from 172.16.203.3, 12 ms
..
R1 & R2 & R3:
show ip mroute

6. Verify PIM-DM Flood-and-Prune Behavior
R1 & R2 & R3:
show ip route 172.16.20.4
R1:
debug ip pim
SW2:
SW2#ping       
Protocol [ip]:            
Target IP address: 232.32.32.32
Repeat count [1]: 10         
Datagram size [100]:
Timeout in seconds [2]:
Extended commands [n]:
Sweep range of sizes [n]:
Type escape sequence to abort.
Sending 10, 100-byte ICMP Echos to 232.32.32.32, timeout is 2 seconds:
Reply to request 0 from 172.16.20.2, 16 ms
Reply to request 0 from 172.16.203.3, 36 ms
Reply to request 0 from 172.16.102.1, 28 ms
Reply to request 1 from 172.16.20.2, 12 ms
Reply to request 1 from 172.16.203.3, 24 ms
...
Check R1 debug log

7. Explore the Multicast Routing Table
R1 & R2 & R3:
show ip mroute 172.16.20.4 232.32.32.32
show ip rpf 172.16.20.4

Final Configurations
R1:
hostname R1
!
no ip domain lookup
!
ip multicast-routing
!        
interface Loopback1
 ip address 192.168.1.1 255.255.255.0
 ip pim dense-mode
 ip igmp join-group 232.32.32.32
!
interface Serial0/0
 ip address 172.16.102.1 255.255.255.248
 ip pim dense-mode
 no shut
!
interface Serial0/1
 ip address 172.16.103.1 255.255.255.248
 ip pim dense-mode
 no shut
!
interface FastEthernet1/0
 ip address 172.16.13.1 255.255.255.0
 ip pim dense-mode
 n oshut
!
router eigrp 1
 network 172.16.0.0
 network 192.168.0.0 0.0.255.255
 auto-summary
!
line con 0
 exec-timeout 0 0
 logging synchronous
!
end
R2:
hostname R2
!
no ip domain lookup
!
ip multicast-routing
!
interface Loopback2
 ip address 192.168.2.1 255.255.255.0
 ip pim dense-mode
 ip igmp join-group 232.32.32.32
!
interface Serial0/0
 ip address 172.16.102.2 255.255.255.248
 ip pim dense-mode
 no shut
!
interface Serial0/1
 ip address 172.16.203.2 255.255.255.248
 ip pim dense-mode
 no shut
!
interface FastEthernet1/0
 ip address 172.16.20.2 255.255.255.0
 ip pim dense-mode
 no shut
!
router eigrp 1
 network 172.16.0.0
 network 192.168.0.0 0.0.255.255
 auto-summary
!
line con 0
 exec-timeout 0 0
 logging synchronous
!
end
R3:
hostname R3
!
no ip domain lookup
!
ip multicast-routing
!        
interface Loopback3
 ip address 192.168.3.1 255.255.255.0
 ip pim dense-mode
 ip igmp join-group 232.32.32.32
!
interface Serial0/0
 ip address 172.16.103.3 255.255.255.248
 ip pim dense-mode
 no shut
!
interface Serial0/1
 ip address 172.16.203.3 255.255.255.248
 ip pim dense-mode
 no shut
!  
interface FastEthernet1/0
 ip address 172.16.13.3 255.255.255.0
 ip pim dense-mode
no shut
!
router eigrp 1
 network 172.16.0.0
 network 192.168.0.0 0.0.255.255
 auto-summary
!
line con 0
 exec-timeout 0 0
 logging synchronous
!
end
SW1:
hostname SW1
!
no ip routing
!
no ip domain lookup
!
interface FastEthernet0/3
 switchport access vlan 13
!
interface FastEthernet0/5
 switchport access vlan 13
!
line con 0
 exec-timeout 0 0
 logging synchronous
!
end
SW2:
hostname SW2
!
no ip routing
!
no ip domain lookup
!
interface FastEthernet0/3
 switchport access vlan 20
!
interface Vlan20
 ip address 172.16.20.4 255.255.255.0
!
ip default-gateway 172.16.20.2
!
line con 0
 exec-timeout 0 0
 logging synchronous
!
end

參考資料:
Cisco網路學院 http://www.cisco.com/web/learning/netacad/index.html
CCNP1 Building Scalable Internetworks v5.0
Student Lab Manual

最初發表 / 最後更新: 2008.05.13 / 2018.05.31

0 comments:

張貼留言