Published 5月 31, 2018 by with 0 comment

CCNP-BSCI-v5.0 Lab 2-3: EIGRP summarization和Default network設定練習


本次練習是參考Cisco網路學院
CCNP1 Building Scalable Internetworks v5.0
Student Lab Manual
我將它轉成Dynamips的設定檔 並寫下自己的實驗紀錄

Dynamips的設定檔:
##################################################
#
# For CCNP1 Building Scalable Internetworks v5.0
# Lab 2-3
#
##################################################
autostart=false
[localhost:7200]
workingdir = /opt/dynamips/dynagen-0.10.1/UTS/CCNP1/Week01/workingconfig/
[[3640]]
#  Specify 3640 IOS image on Windows here:
#  image = C:\Program Files\Dynamips\images\c3640-jk9o3s-mz.123-14.T7.extracted.bin
#  Specify 3640 IOS image on Linux here:
 image = /opt/dynamips/images/c3640-jk.bin
 ram = 128
 disk0 = 0
 disk1 = 0
 # Choose an idlepc value from the below
 idlepc = 0x605ac7b8
 mmap = true
 ghostios = true
 confreg = 0x2102

###########################
#
# Define router instances 1
#
###########################
  
 [[Router R1]]
  model = 3640
  console = 2001
  autostart = false
  slot0 = NM-4T
# cnfg = /opt/dynamips/dynagen-0.10.1/UTS/CCNP1/Week01/initconfig/R1.txt
 [[Router R2]]
  model = 3640
  console = 2002
  autostart = false
  slot0 = NM-4T
  S0/0 = R1 S0/0
  S0/1 = R3 S0/1
# cnfg = /opt/dynamips/dynagen-0.10.1/UTS/CCNP1/Week01/initconfig/R2.txt
 [[Router R3]]
  model = 3640
  console = 2003
  autostart = false
  slot0 = NM-4T
# cnfg = /opt/dynamips/dynagen-0.10.1/UTS/CCNP1/Week01/initconfig/R3.txt
這Lab是EIGRP summarization和Default network設定練習
我的設定是
1. 先設定R1-3每個介面的ip address
hostname R1
!
no ip domain lookup
!
!
interface Loopback0
 ip address 172.31.1.1 255.255.255.252
!        
interface Serial0/0
 description R1-R2
 ip address 192.168.100.1 255.255.255.248
 no shutdown
!
line con 0
 logging synchronous
!
end
R2:
hostname R2
!
no ip domain lookup
!
interface Loopback1
 ip address 192.168.200.1 255.255.255.252
!        
interface Loopback5
 ip address 192.168.200.5 255.255.255.252
!
interface Loopback9
 ip address 192.168.200.9 255.255.255.252
!
interface Loopback13
 ip address 192.168.200.13 255.255.255.252
!
interface Loopback17
 ip address 192.168.200.17 255.255.255.252
!
interface Loopback21
 ip address 192.168.200.21 255.255.255.252
!
interface Loopback25
 ip address 192.168.200.25 255.255.255.252
!
interface Serial0/0
 description R2-R1
 ip address 192.168.100.2 255.255.255.248
 no shutdown
!        
interface Serial0/1
 description R2-R3
 ip address 10.1.1.2 255.255.255.248
 no shutdown
!
line con 0
 logging synchronous
!
end
R3:
hostname R3
!
no ip domain lookup
!
interface Loopback1
 ip address 192.168.1.1 255.255.254.0
!        
interface Loopback5
 ip address 192.168.5.5 255.255.254.0
!
interface Loopback9
 ip address 192.168.9.9 255.255.254.0
!
interface Loopback13
 ip address 192.168.13.13 255.255.254.0
!
interface Loopback17
 ip address 192.168.17.17 255.255.254.0
!
interface Loopback21
 ip address 192.168.21.21 255.255.254.0
!
interface Loopback25
 ip address 192.168.25.25 255.255.254.0
!
interface Loopback100
 ip address 10.1.3.1 255.255.255.252
!
interface Loopback172
 ip address 172.16.1.1 255.255.255.252
!
interface Serial0/1
 description R3-R2
 ip address 10.1.1.3 255.255.255.248
 no shutdwon
!
line con 0
 logging synchronous
!        
end

2. R1-3 run EIGRP, !!no auto-summary!!
R1:
router eigrp 1
 network 172.31.0.0
 network 192.168.100.0
 no auto-summary
R2:
router eigrp 1
 network 10.0.0.0
 network 192.168.100.0
 network 192.168.200.0
 no auto-summary
R3:
router eigrp 1
 network 10.0.0.0
 network 172.16.0.0
 network 192.168.0.0 0.0.31.255
 no auto-summary
3. R1-3 分別設定auto-summary 再檢查routing table的不同
R1-3:
router eigrp 1
 auto-summary
4. R3上 EIGRP 手動設定 Summarization 再檢查routing table的不同
R3:
interface Serial0/1
 ip summary-address eigrp 1 192.168.0.0 255.255.224.0 5
5. R1 上設定Default network advertisement 再檢查routing table的不同
R1:
ip default-network 172.31.0.0
6. 驗證指令
show ip eigrp neighbors
shpw ip eigrp topology
Show ip route summary
show ip route eigrp
ping

R1設定檔:
hostname R1
!
no ip domain lookup
!
interface Loopback0
 ip address 172.31.1.1 255.255.255.252
!        
interface Serial0/0
 description R1-R2
 ip address 192.168.100.1 255.255.255.248
!
router eigrp 1
 network 172.31.0.0
 network 192.168.100.0
 auto-summary
!
ip default-network 172.31.0.0
!
line con 0
 logging synchronous
!
end
R2設定檔:
hostname R2
!
no ip domain lookup
!
interface Loopback1
 ip address 192.168.200.1 255.255.255.252
!        
interface Loopback5
 ip address 192.168.200.5 255.255.255.252
!
interface Loopback9
 ip address 192.168.200.9 255.255.255.252
!
interface Loopback13
 ip address 192.168.200.13 255.255.255.252
!
interface Loopback17
 ip address 192.168.200.17 255.255.255.252
!
interface Loopback21
 ip address 192.168.200.21 255.255.255.252
!
interface Loopback25
 ip address 192.168.200.25 255.255.255.252
!
interface Serial0/0
 description R2-R1
 ip address 192.168.100.2 255.255.255.248
!        
interface Serial0/1
 description R2-R3
 ip address 10.1.1.2 255.255.255.248
!
router eigrp 1
 network 10.0.0.0
 network 192.168.100.0
 network 192.168.200.0
 auto-summary
!
no ip http secure-server
!
line con 0
 logging synchronous
!        
end
R3設定檔:
hostname R3
!
no ip domain lookup
!
interface Loopback1
 ip address 192.168.1.1 255.255.254.0
!        
interface Loopback5
 ip address 192.168.5.5 255.255.254.0
!
interface Loopback9
 ip address 192.168.9.9 255.255.254.0
!
interface Loopback13
 ip address 192.168.13.13 255.255.254.0
!
interface Loopback17
 ip address 192.168.17.17 255.255.254.0
!
interface Loopback21
 ip address 192.168.21.21 255.255.254.0
!
interface Loopback25
 ip address 192.168.25.25 255.255.254.0
!
interface Loopback100
 ip address 10.1.3.1 255.255.255.252
!
interface Loopback172
 ip address 172.16.1.1 255.255.255.252
!
interface Serial0/1
 description R3-R2
 ip address 10.1.1.3 255.255.255.248
 ip summary-address eigrp 1 192.168.0.0 255.255.224.0 5
!
router eigrp 1
 network 10.0.0.0
 network 172.16.0.0
 network 192.168.0.0 0.0.31.255
 auto-summary
!
line con 0
 logging synchronous
!
end
參考資料:
Cisco網路學院 http://www.cisco.com/web/learning/netacad/index.html
CCNP1 Building Scalable Internetworks v5.0
Student Lab Manual

最初發表 / 最後更新: 2008.03.08 / 218.05.31

0 comments:

張貼留言