Published 5月 31, 2018 by with 0 comment

CCNP-BSCI-v5.0 Lab 2-4-a: 基本EIGRP在Frame Relay (Hub and Spoke)的設定練習



本次練習是參考Cisco網路學院
CCNP1 Building Scalable Internetworks v5.0
Student Lab Manual
我將它轉成Dynamips的設定檔 並寫下自己的實驗紀錄

Dynamips的設定檔:
##################################################
#
# For CCNP1 Building Scalable Internetworks v5.0
# Lab 2-4a
#
##################################################
autostart=false
[localhost:7200]
workingdir = /opt/dynamips/dynagen-0.10.1/UTS/CCNP1/Week01/workingconfig/
[[3640]]
#  Specify 3640 IOS image on Windows here:
#  image = C:\Program Files\Dynamips\images\c3640-jk9o3s-mz.123-14.T7.extracted.bin
#  Specify 3640 IOS image on Linux here:
 image = /opt/dynamips/images/c3640-jk.bin
 ram = 128
 disk0 = 0
 disk1 = 0
 # Choose an idlepc value from the below
 idlepc = 0x605ac7b8
 mmap = true
 ghostios = true
 confreg = 0x2102

###########################
#
# Define router instances 1
#
###########################
  
 [[Router HQ]]
  model = 3640
  console = 2001
  autostart = false
  slot0 = NM-4T
  S0/0 = FRSW 1
# cnfg = /opt/dynamips/dynagen-0.10.1/UTS/CCNP1/Week01/initconfig/HQ.txt
 [[Router East]]
  model = 3640
  console = 2002
  autostart = false
  slot0 = NM-4T
  S0/0 = FRSW 2
# cnfg = /opt/dynamips/dynagen-0.10.1/UTS/CCNP1/Week01/initconfig/East.txt
 [[Router West]]
  model = 3640
  console = 2003
  autostart = false
  slot0 = NM-4T
  S0/0 = FRSW 3
# cnfg = /opt/dynamips/dynagen-0.10.1/UTS/CCNP1/Week01/initconfig/West.txt
 [[FRSW FRSW]]
  # HQ to FRSW
  1:102 = 2:201
  1:103 = 3:301
這Lab只是基本EIGRP在Frame Relay (Hub and Spoke)的設定練習
我的設定是
1. 先設定HQ, East, West Looopback interface的ip address
HQ:
hostname HQ
!
no ip domain lookup
!
interface Loopback1
 ip address 10.1.1.1 255.255.224.0
!        
interface Loopback33
 ip address 10.1.33.33 255.255.224.0
!        
interface Loopback65
 ip address 10.1.65.65 255.255.224.0
!        
interface Loopback97
 ip address 10.1.97.97 255.255.224.0
!        
interface Loopback129
 ip address 10.1.129.129 255.255.224.0
!        
interface Loopback161
 ip address 10.1.161.161 255.255.224.0
!
line con 0
 logging synchronous
!
end
East:
hostname East
!
no ip domain lookup
!
!
interface Loopback1
 ip address 10.2.1.1 255.255.224.0
!        
interface Loopback33
 ip address 10.2.33.33 255.255.224.0
!
interface Loopback65
 ip address 10.2.65.65 255.255.224.0
!
interface Loopback97
 ip address 10.2.97.97 255.255.224.0
!
interface Loopback129
 ip address 10.2.129.129 255.255.224.0
!
interface Loopback161
 ip address 10.2.161.161 255.255.224.0
!
line con 0
 logging synchronous
!
end
West:
hostname West
!
no ip domain lookup
!
interface Loopback1
 ip address 10.3.1.1 255.255.224.0
!        
interface Loopback33
 ip address 10.3.33.33 255.255.224.0
!
interface Loopback65
 ip address 10.3.65.65 255.255.224.0
!
interface Loopback97
 ip address 10.3.97.97 255.255.224.0
!
interface Loopback129
 ip address 10.3.129.129 255.255.224.0
!
interface Loopback161
 ip address 10.3.161.161 255.255.224.0
!
line con 0
 logging synchronous
!
end

2. 設定Frame Relay interface
HQ:
interface Serial0/0
 bandwidth 128
 ip address 172.16.124.1 255.255.255.248
 encapsulation frame-relay
 frame-relay map ip 172.16.124.1 102
 frame-relay map ip 172.16.124.2 102 broadcast
 frame-relay map ip 172.16.124.3 103 broadcast
 no frame-relay inverse-arp
 no shutdown  
East:
interface Serial0/0
 bandwidth 64
 ip address 172.16.124.2 255.255.255.248
 encapsulation frame-relay
 frame-relay map ip 172.16.124.1 201 broadcast
 frame-relay map ip 172.16.124.2 201
 frame-relay map ip 172.16.124.3 201 broadcast
 no frame-relay inverse-arp
 no shutdown
West:
interface Serial0/0
 bandwidth 64
 ip address 172.16.124.3 255.255.255.248
 encapsulation frame-relay
 frame-relay map ip 172.16.124.1 301 broadcast
 frame-relay map ip 172.16.124.2 301 broadcast
 frame-relay map ip 172.16.124.3 301
 no frame-relay inverse-arp
3. 設定EIGRP
HQ:
router eigrp 1
 network 10.0.0.0
 network 172.16.0.0
 no auto-summary
East:
router eigrp 1
 network 10.0.0.0
 network 172.16.0.0
 no auto-summary
West:
router eigrp 1
 network 10.0.0.0
 network 172.16.0.0
 no auto-summary
4. 會發現East & West的路由表 都少了對方的Loopback interface資訊
East&Wast:
show ip eigrp topology
show ip route
為什麼?? 因為HQ的Split-horzion, #no ip split-horizon eigrp 1 就ok了
HQ:
interface Serial0/0
 no ip split-horizon eigrp 1
5. Using Non-broadcast EIGRP Mode
HQ:
router eigrp 1
 neighbor 172.16.124.2 Serial0/0
 neighbor 172.16.124.3 Serial0/0
East:
router eigrp 1
 neighbor 172.16.124.1 Serial0/0
West:
router eigrp 1
 neighbor 172.16.124.1 Serial0/0
6. Implementing EIGEP Manual Summarization
HQ:
interface Serial0/0
 ip summary-address eigrp 1 10.1.0.0 255.255.0.0 5
East:
interface Serial0/0
 ip summary-address eigrp 1 10.2.0.0 255.255.0.0 5
West:
interface Serial0/0
 ip summary-address eigrp 1 10.3.0.0 255.255.0.0 5
7. 驗證指令
show frame-relay pvc
show ip eigrp neighbors
show ip route eigrp
ping

HQ設定檔:
hostname HQ
!
no ip domain lookup
!
interface Loopback1
 ip address 10.1.1.1 255.255.224.0
!        
interface Loopback33
 ip address 10.1.33.33 255.255.224.0
!
interface Loopback65
 ip address 10.1.65.65 255.255.224.0
!
interface Loopback97
 ip address 10.1.97.97 255.255.224.0
!
interface Loopback129
 ip address 10.1.129.129 255.255.224.0
!
interface Loopback161
 ip address 10.1.161.161 255.255.224.0
!
interface Serial0/0
 bandwidth 128
 ip address 172.16.124.1 255.255.255.248
 encapsulation frame-relay
 no ip split-horizon eigrp 1
 ip summary-address eigrp 1 10.1.0.0 255.255.0.0 5
 serial restart-delay 0
 frame-relay map ip 172.16.124.1 102
 frame-relay map ip 172.16.124.2 102 broadcast
 frame-relay map ip 172.16.124.3 103 broadcast
 no frame-relay inverse-arp
!
router eigrp 1
 network 10.0.0.0
 network 172.16.0.0
 no auto-summary
 neighbor 172.16.124.2 Serial0/0
 neighbor 172.16.124.3 Serial0/0
!
line con 0
 logging synchronous
!
end
East設定檔:
hostname East
!
no ip domain lookup
!
interface Loopback1
 ip address 10.2.1.1 255.255.224.0
!        
interface Loopback33
 ip address 10.2.33.33 255.255.224.0
!
interface Loopback65
 ip address 10.2.65.65 255.255.224.0
!
interface Loopback97
 ip address 10.2.97.97 255.255.224.0
!
interface Loopback129
 ip address 10.2.129.129 255.255.224.0
!
interface Loopback161
 ip address 10.2.161.161 255.255.224.0
!
interface Serial0/0
 bandwidth 64
 ip address 172.16.124.2 255.255.255.248
 encapsulation frame-relay
 ip summary-address eigrp 1 10.2.0.0 255.255.0.0 5
 serial restart-delay 0
 frame-relay map ip 172.16.124.1 201 broadcast
 frame-relay map ip 172.16.124.2 201
 frame-relay map ip 172.16.124.3 201 broadcast
 no frame-relay inverse-arp
!
router eigrp 1
 network 10.0.0.0
 network 172.16.0.0
 no auto-summary
 neighbor 172.16.124.1 Serial0/0
!
line con 0
 logging synchronous
!
end
West設定檔:
hostname West
!
no ip domain lookup
!
interface Loopback1
 ip address 10.3.1.1 255.255.224.0
!        
interface Loopback33
 ip address 10.3.33.33 255.255.224.0
!
interface Loopback65
 ip address 10.3.65.65 255.255.224.0
!
interface Loopback97
 ip address 10.3.97.97 255.255.224.0
!
interface Loopback129
 ip address 10.3.129.129 255.255.224.0
!
interface Loopback161
 ip address 10.3.161.161 255.255.224.0
!
interface Serial0/0
 bandwidth 64
 ip address 172.16.124.3 255.255.255.248
 encapsulation frame-relay
 ip summary-address eigrp 1 10.3.0.0 255.255.0.0 5
 serial restart-delay 0
 frame-relay map ip 172.16.124.1 301 broadcast
 frame-relay map ip 172.16.124.2 301 broadcast
 frame-relay map ip 172.16.124.3 301
 no frame-relay inverse-arp
!
router eigrp 1
 network 10.0.0.0
 network 172.16.0.0
 no auto-summary
 neighbor 172.16.124.1 Serial0/0
!
line con 0
 logging synchronous
!
end
參考資料:
Cisco網路學院 http://www.cisco.com/web/learning/netacad/index.html
CCNP1 Building Scalable Internetworks v5.0
Student Lab Manual

最初發表 / 最後更新: 2008.03.09 / 2018.05.31

0 comments:

張貼留言