Published 5月 31, 2018 by with 0 comment

CCNP-BSCI-v5.0 Lab 5-2: Redistribution Between EIGRP and OSPF


本次練習是參考Cisco網路學院
CCNP1 Building Scalable Internetworks v5.0
Student Lab Manual
我將它轉成Dynamips的設定檔 並寫下自己的實驗紀錄

Dynamips的設定檔:
##################################################
#
# For CCNP1 Building Scalable Internetworks v5.0
# Lab 5_1-2
#
##################################################
autostart=false
[localhost:7200]
workingdir = /opt/dynamips/dynagen-0.10.1/UTS/CCNP1/Week04/workingconfig/
[[3640]]
#  Specify 3640 IOS image on Windows here:
#  image = C:\Program Files\Dynamips\images\c3640-jk9o3s-mz.123-14.T7.extracted.bin
#  Specify 3640 IOS image on Linux here:
 image = /opt/dynamips/images/c3640-jk.bin
 ram = 128
 disk0 = 0
 disk1 = 0
 # Choose an idlepc value from the below
 idlepc = 0x605ac7b8
 mmap = true
 ghostios = true
 confreg = 0x2102

###########################
#
# Define router instances 1
#
###########################
  
 [[Router R1]]
  model = 3640
  console = 2001
  slot0 = NM-4T
 [[Router R2]]
  model = 3640
  console = 2002
  slot0 = NM-4T
  S0/0 = R1 S0/0
  S0/1 = R3 S0/1
 [[Router R3]]
  model = 3640
  console = 2003
  slot0 = NM-4T
這Lab是Redistribution Between EIGRP and OSPF設定練習
我的設定是
1. 先設定R1-3每個介面的ip address
R1:
hostname R1
!
no ip domain lookup
!
interface Loopback0
 ip address 172.16.1.1 255.255.255.0
!        
interface Loopback48
 ip address 192.168.48.1 255.255.255.0
!
interface Loopback49
 ip address 192.168.49.1 255.255.255.0
!
interface Loopback50
 ip address 192.168.50.1 255.255.255.0
!
interface Loopback51
 ip address 192.168.51.1 255.255.255.0
!
interface Loopback70
 ip address 192.168.70.1 255.255.255.0
!
interface Serial0/0
 ip address 172.16.12.1 255.255.255.0
 no shutdown
!
line con 0
 logging synchronous
!
end
R2:
hostname R2
!
no ip domain lookup
!
interface Loopback0
 ip address 172.16.2.1 255.255.255.0
!        
interface Loopback100
 ip address 172.16.100.1 255.255.255.0
!        
interface Serial0/0
 ip address 172.16.12.2 255.255.255.0
 no shutdown
!        
interface Serial0/1
 ip address 172.16.23.2 255.255.255.0      
 no shutdown
!
line con 0
 logging synchronous
!
end
R3:
hostname R3
!
no ip domain lookup
!
interface Loopback0
 ip address 172.16.3.1 255.255.255.0
!        
interface Loopback8
 ip address 192.168.8.1 255.255.255.0
!
interface Loopback9
 ip address 192.168.9.1 255.255.255.0
!
interface Loopback10
 ip address 192.168.10.1 255.255.255.0
!
interface Loopback11
 ip address 192.168.11.1 255.255.255.0
!
interface Loopback20
 ip address 192.168.20.1 255.255.255.0
!
interface Loopback25
 ip address 192.168.25.1 255.255.255.0
!
interface Loopback30
 ip address 192.168.30.1 255.255.255.0
!
interface Loopback35
 ip address 192.168.35.1 255.255.255.0
!
interface Loopback40
 ip address 192.168.40.1 255.255.255.0
!
interface Loopback40
 ip address 192.168.40.1 255.255.255.0
!
interface Serial0/1
 ip address 172.16.23.3 255.255.255.0
 no shutdown
!
line con 0
 logging synchronous
!
end

2. Configure EIGRP and OSPF
R1:
interface Serial0/0
 bandwidth 64
!
router eigrp 1
 network 172.16.0.0
 network 192.168.0.0 255.255.0.0
 no auto-summary
R2:
interface Serial0/0
 bandwidth 64
!
router eigrp 1
 network 172.16.0.0
 no auto-summary
!
router ospf 1
 network 172.16.23.0 0.0.0.255 area 0
R3:
router ospf 1
 network 172.16.0.0 0.0.255.255 area 0
 network 192.168.20.0 0.0.0.255 area 0
 network 192.168.25.0 0.0.0.255 area 0
 network 192.168.30.0 0.0.0.255 area 0
 network 192.168.35.0 0.0.0.255 area 0
 network 192.168.40.0 0.0.0.255 area 0
 passive-interface default
 no passive-interface Serial0/1
3. Configure Passive Interface in EIGRP
R2:
router eigrp 1
 passive-interface Serial0/1
4. Manually Summarize with EIGRP (Lo48 - 49)
R1:
interface Serial0/0
 ip summary-address eigrp 1 192.168.48.0 255.255.254.0 5
5. Additional OSPF Configuration
R2:
router ospf 1
 network 172.16.100.0 0.0.0.255 area 10
!
interface Loopback0
 ip ospf network point-to-point
!
interface Loopback100
 ip ospf network point-to-point
R3:
router ospf 1
 network 192.168.8.0 0.0.3.255 area 20
!
interface Loopback0
 ip ospf network point-to-point
!
interface Loopback8
 ip ospf network point-to-point
!
interface Loopback9
 ip ospf network point-to-point
!
interface Loopback10
 ip ospf network point-to-point
!
interface Loopback11
 ip ospf network point-to-point
!
interface Loopback20
 ip ospf network point-to-point
!
interface Loopback25
 ip ospf network point-to-point
!
interface Loopback30
 ip ospf network point-to-point
!
interface Loopback35
 ip ospf network point-to-point
!
interface Loopback40
 ip ospf network point-to-point
!
6. Summarize OSPF Area at the ABR (Area 20)
R3:
router ospf 1
 area 20 range 192.168.8.0 255.255.252.0
7. Mutually Redistribute Between OSPF and EIGRP
R2:
router eigrp 1
 redistribute ospf 1 metric 64 100 255 1 1500
!
router ospf 1
 redistribute eigrp 1 subnets
8. Filter redistribution with Route Maps (R3: Lo25 & Lo30)
R2:
access-list 1 permit 192.168.25.0
access-list 1 permit 192.168.30.0
!
route-map SELECTED-DENY deny 10
 match ip address 1
!
route-map SELECTED-DENY permit 20
!
router eigrp 1
 redistribute ospf 1 metric 64 100 255 1 1500 route-map SELECTED-DENY
9. Summarize External Routes into OSPF at the ASBR
R2:
router ospf 1
 summary-address 192.168.48.0 255.255.252.0
10. Modifying EIGRP Distances
R1:
router eigrp 1
 distance eigrp 95 165
11. Modifying OSPF Distances
R3:
router ospf 1
 distance ospf intra-area 105 inter-area 115 external 175
12. Check Command
show ip eigrp neighbors
show ip eigrp interfaces
show ip route ospf
ping

R1 Configuration:
hostname R1
!
no ip domain lookup
!
interface Loopback0
 ip address 172.16.1.1 255.255.255.0
!        
interface Loopback48
 ip address 192.168.48.1 255.255.255.0
!
interface Loopback49
 ip address 192.168.49.1 255.255.255.0
!
interface Loopback50
 ip address 192.168.50.1 255.255.255.0
!
interface Loopback51
 ip address 192.168.51.1 255.255.255.0
!
interface Loopback70
 ip address 192.168.70.1 255.255.255.0
!
interface Serial0/0
 bandwidth 64
 ip address 172.16.12.1 255.255.255.0
 ip summary-address eigrp 1 192.168.48.0 255.255.254.0 5
 no shutdown
!
router eigrp 1
 network 172.16.0.0
 network 192.168.0.0 0.0.255.255
 distance eigrp 95 165
 no auto-summary
!
line con 0
 logging synchronous
!
end
R2 Configuration:
hostname R2
!
no ip domain lookup
!
interface Loopback0
 ip address 172.16.2.1 255.255.255.0
 ip ospf network point-to-point
!
interface Loopback100
 ip address 172.16.100.1 255.255.255.0
 ip ospf network point-to-point
!
interface Serial0/0
 bandwidth 64
 ip address 172.16.12.2 255.255.255.0
 no shutdown
!
interface Serial0/1
 ip address 172.16.23.2 255.255.255.0
 no shutdown
!
router eigrp 1
 redistribute ospf 1 metric 64 100 255 1 1500 route-map SELECTED-DENY
 passive-interface Serial0/1
 network 172.16.0.0
 no auto-summary
!
router ospf 1
 summary-address 192.168.48.0 255.255.252.0
 redistribute eigrp 1 subnets
 network 172.16.23.0 0.0.0.255 area 0
 network 172.16.100.0 0.0.0.255 area 10
!
access-list 1 permit 192.168.25.0
access-list 1 permit 192.168.30.0
!
route-map SELECTED-DENY deny 10
 match ip address 1
!
route-map SELECTED-DENY permit 20
!
line con 0
 logging synchronous
!        
end
R3 Configuration:
hostname R3
!
no ip domain lookup
!
interface Loopback0
 ip address 172.16.3.1 255.255.255.0
 ip ospf network point-to-point
!
interface Loopback8
 ip address 192.168.8.1 255.255.255.0
 ip ospf network point-to-point
!
interface Loopback9
 ip address 192.168.9.1 255.255.255.0
 ip ospf network point-to-point
!
interface Loopback10
 ip address 192.168.10.1 255.255.255.0
 ip ospf network point-to-point
!
interface Loopback11
 ip address 192.168.11.1 255.255.255.0
 ip ospf network point-to-point
!
interface Loopback20
 ip address 192.168.20.1 255.255.255.0
 ip ospf network point-to-point
!
interface Loopback25
 ip address 192.168.25.1 255.255.255.0
 ip ospf network point-to-point
!
interface Loopback30
 ip address 192.168.30.1 255.255.255.0
 ip ospf network point-to-point
!
interface Loopback35
 ip address 192.168.35.1 255.255.255.0
 ip ospf network point-to-point
!
interface Loopback40
 ip address 192.168.40.1 255.255.255.0
 ip ospf network point-to-point
!
interface Serial0/1
 ip address 172.16.23.3 255.255.255.0
 no shutdown
!
router ospf 1
 area 20 range 192.168.8.0 255.255.252.0
 passive-interface default
 no passive-interface Serial0/1
 network 172.16.0.0 0.0.255.255 area 0
 network 192.168.8.0 0.0.3.255 area 20
 network 192.168.20.0 0.0.0.255 area 0
 network 192.168.25.0 0.0.0.255 area 0
 network 192.168.30.0 0.0.0.255 area 0
 network 192.168.35.0 0.0.0.255 area 0
 network 192.168.40.0 0.0.0.255 area 0
 distance ospf intra-area 105 inter-area 115 external 175
!
line con 0
 logging synchronous
!
end
參考資料:
Cisco網路學院 http://www.cisco.com/web/learning/netacad/index.html
CCNP1 Building Scalable Internetworks v5.0
Student Lab Manual

最初發表 / 最後更新: 2008.04.03 / 2018.05.31

0 comments:

張貼留言