Published 5月 31, 2018 by with 0 comment

CCNP-BSCI-v5.0 Lab 4-2: Multi-Area integrated IS-IS設定練習







本次練習是參考Cisco網路學院
CCNP1 Building Scalable Internetworks v5.0
Student Lab Manual
我將它轉成Dynamips的設定檔 並寫下自己的實驗紀錄

Dynamips的設定檔:
##################################################
#
# For CCNP1 Building Scalable Internetworks v5.0
# Lab 4_2
#
##################################################
autostart=false
[localhost:7200]
workingdir = /opt/dynamips/dynagen-0.10.1/UTS/CCNP1/Week03/workingconfig/
[[3640]]
#  Specify 3640 IOS image on Windows here:
#  image = C:Program FilesDynamipsimagesc3640-jk9o3s-mz.123-14.T7.extracted.bin
#  Specify 3640 IOS image on Linux here:
 image = /opt/dynamips/images/c3640-jk.bin
 ram = 128
 disk0 = 0
 disk1 = 0
#  Choose an idlepc value from the below
 idlepc = 0x605ac7b8
 mmap = true
 ghostios = true
 confreg = 0x2102

###########################
#
# Define router instances 1
#
###########################
  
 [[Router R1]]
  model = 3640
  console = 2001
  slot0 = NM-1FE-TX
  slot1 = NM-4T
  Fa0/0 = SW1 Fa0/1
  S1/0 = R3 S1/0
 [[Router R2]]
  model = 3640
  console = 2002
  slot0 = NM-1FE-TX
  Fa0/0 = SW1 Fa0/3
 [[Router R3]]
  model = 3640
  console = 2003
  slot1 = NM-4T
[[Router SW1]]
  model = 3640
  console = 2004
  slot0 = NM-16ESW
這Lab是Multi-Area integrated IS-IS設定練習
我的設定是
1. R1-2恢復Lab4_1原先的設定 R1&R3加入Interface的ip 設定
R1:
hostname R1
!
no ip domain lookup
!
interface Loopback0
 ip address 192.168.10.1 255.255.255.0
 ip router isis
!
interface FastEthernet0/0
 description R1-SW1
 ip address 172.16.0.1 255.255.255.0
 ip router isis
 isis password cisco level-2
 isis priority 100
 isis hello-interval 5
!
interface Serial1/0
 ip address 10.0.0.2 255.255.255.252
 no shutdown
!
router isis
 net 49.0001.1111.1111.1111.00
 is-type level-2-only
 domain-password cisco
!
line con 0
 logging synchronous
!
end
R2:
hostname R2
!
no ip domain lookup
!
interface Loopback0
 ip address 192.168.20.1 255.255.255.0
 ip router isis
!
interface FastEthernet0/0
 description R2-SW1
 ip address 172.16.0.2 255.255.255.0
 ip router isis
 isis password cisco level-2
!
router isis
 net 49.0001.2222.2222.2222.00
 is-type level-2-only
 domain-password cisco
!
line con 0
 logging synchronous
!
end
R3:
hostname R3
!
no ip domain lookup
!
interface Loopback0
 ip address 192.168.30.1 255.255.255.0
!        
interface Serial1/0
 ip address 10.0.0.1 255.255.255.252
 no shutdown
!
line con 0
 logging synchronous
!
end

2. Verify IS-IS initial Operation
R1-2:
clear isis *
show clns neighbors
show isis database

3. Configuration IS-IS Area 2
R1:
interface Serial1/0
 ip router isis
R3:
router isis
 net 49.0002.3333.3333.3333.00
!
interface Loopback0
 ip router isis
!
interface Serial1/0
 ip router isis

4. Verify IS-IS Multi-Area Operation
R3:
show clns neighbors
show isis database
show ip route
R1:
ping 192.168.30.1 .....Fail

5. Configure IS-IS Domain Authentication
R3:
router isis
 domain-password cisco
6. Reconfigure IS-IS Area 1
R1:
router isis
 is-type level-1-2
!
interface FastEthernet0/0
 no isis password cisco
 isis password cisco level-1
!
clear isis *
R2:
router isis
 is-type level-1
!
interface FastEthernet0/0
 no isis password cisco
 isis password cisco level-1
!
Clear isis *

7. Reconfigure R3 IS-IS Operation
R3:
router isis
 is-type level-2-only
8. 驗證指令
show ip protocols
show clns protocol
show clns neighbors
show clns interface
show clns route
show isis route
show isis database
show isis topology
Clear isis *
ping

R1設定檔:
hostname R1
!
no ip domain lookup
!
interface Loopback0
 ip address 192.168.10.1 255.255.255.0
 ip router isis
!
interface FastEthernet0/0
 description R1-SW1
 ip address 172.16.0.1 255.255.255.0
 ip router isis
 isis password cisco level-1
 isis priority 100
 isis hello-interval 5
!
interface Serial1/0
 ip address 10.0.0.2 255.255.255.252
 ip router isis
!
router isis
 net 49.0001.1111.1111.1111.00
 domain-password cisco
!
line con 0
 logging synchronous
!
end
R2設定檔:
hostname R2
!
no ip domain lookup
!
interface Loopback0
 ip address 192.168.20.1 255.255.255.0
 ip router isis
!
interface FastEthernet0/0
 description R2-SW1
 ip address 172.16.0.2 255.255.255.0
 ip router isis
 isis password cisco level-1
!
router isis
 net 49.0001.2222.2222.2222.00
 is-type level-1
 domain-password cisco
!
line con 0
 logging synchronous
!
end
R3設定檔:
hostname R3
!
no ip domain lookup
!
interface Loopback0
 ip address 192.168.30.1 255.255.255.0
 ip router isis
!
interface Serial1/0
 ip address 10.0.0.1 255.255.255.252
 ip router isis
!
router isis
 net 49.0002.3333.3333.3333.00
 is-type level-2-only
 domain-password cisco
!
line con 0
 logging synchronous
!
end
SW1設定檔:
hostname SW1
!
no ip domain lookup
!
line con 0
 logging synchronous
!
end

參考資料:
Cisco網路學院 http://www.cisco.com/web/learning/netacad/index.html
CCNP1 Building Scalable Internetworks v5.0
Student Lab Manual

最初發表 / 最後更新: 2008.03.24 / 2018.05.21

0 comments:

張貼留言