Published 5月 31, 2018 by with 0 comment

CCNP-BSCI-v5.0 Lab 5-1: Redistribution Between RIP and OSPF







本次練習是參考Cisco網路學院
CCNP1 Building Scalable Internetworks v5.0
Student Lab Manual
我將它轉成Dynamips的設定檔 並寫下自己的實驗紀錄

Dynamips的設定檔:
##################################################
#
# For CCNP1 Building Scalable Internetworks v5.0
# Lab 5_1-2
#
##################################################
autostart=false
[localhost:7200]
workingdir = /opt/dynamips/dynagen-0.10.1/UTS/CCNP1/Week04/workingconfig/
[[3640]]
#  Specify 3640 IOS image on Windows here:
#  image = C:\Program Files\Dynamips\images\c3640-jk9o3s-mz.123-14.T7.extracted.bin
#  Specify 3640 IOS image on Linux here:
 image = /opt/dynamips/images/c3640-jk.bin
 ram = 128
 disk0 = 0
 disk1 = 0
 # Choose an idlepc value from the below
 idlepc = 0x605ac7b8
 mmap = true
 ghostios = true
 confreg = 0x2102

###########################
#
# Define router instances 1
#
###########################
  
 [[Router R1]]
  model = 3640
  console = 2001
  slot0 = NM-4T
 [[Router R2]]
  model = 3640
  console = 2002
  slot0 = NM-4T
  S0/0 = R1 S0/0
  S0/1 = R3 S0/1
 [[Router R3]]
  model = 3640
  console = 2003
  slot0 = NM-4T
這Lab是Redistribution Between RIP and OSPF設定練習
我的設定是
1. 先設定R1-3每個介面的ip address
R1:
hostname R1
!
no ip domain lookup
!
interface Loopback0
 ip address 172.16.1.1 255.255.255.0
!        
interface Loopback48
 ip address 192.168.48.1 255.255.255.0
!
interface Loopback49
 ip address 192.168.49.1 255.255.255.0
!
interface Loopback50
 ip address 192.168.50.1 255.255.255.0
!
interface Loopback51
 ip address 192.168.51.1 255.255.255.0
!
interface Loopback70
 ip address 192.168.70.1 255.255.255.0
!
interface Serial0/0
 ip address 172.16.12.1 255.255.255.0
 no shutdown
!
line con 0
 logging synchronous
!
end
R2:
hostname R2
!
no ip domain lookup
!
interface Loopback0
 ip address 172.16.2.1 255.255.255.0
!        
interface Serial0/0
 ip address 172.16.12.2 255.255.255.0
 no shutdown
!        
interface Serial0/1
 ip address 172.16.23.2 255.255.255.0      
 no shutdown
!
line con 0
 logging synchronous
!
end
R3:
hostname R3
!
no ip domain lookup
!
interface Loopback0
 ip address 172.16.3.1 255.255.255.0
!        
interface Loopback20
 ip address 192.168.20.1 255.255.255.0
!
interface Loopback25
 ip address 192.168.25.1 255.255.255.0
!
interface Loopback30
 ip address 192.168.30.1 255.255.255.0
!
interface Loopback35
 ip address 192.168.35.1 255.255.255.0
!
interface Loopback40
 ip address 192.168.40.1 255.255.255.0
!
interface Serial0/1
 ip address 172.16.23.3 255.255.255.0
 no shutdown
!
line con 0
 logging synchronous
!
end

2. Configure RIPv2
R1:
router rip
 version 2
 network 172.16.0.0
 network 192.168.48.0
 network 192.168.49.0
 network 192.168.50.0
 network 192.168.51.0
 network 192.168.70.0
 no auto-summary
R2:
router rip
 version 2
 network 172.16.0.0
 no auto-summary
3. Configure Passive Interface in RIP
R1:
router rip
 passive-interface default
 no passive-interface Serial0/0
R2:
router rip
 passive-interface default
 no passive-interface Serial0/0
4. Summarize a Supernet with RIP
R1:
ip route 192.168.48.0 255.255.252.0 Null0
!
router rip
 redistribute static
5. Suppress Routes Using Prefix LIsts
R1:
ip prefix-list RIP-OUT seq 5 permit 192.168.48.0/22
ip prefix-list RIP-OUT seq 10 deny 192.168.48.0/22 le 24
ip prefix-list RIP-OUT seq 15 permit 0.0.0.0/0 le 32
!
router rip
 distribute-list prefix RIP-OUT out Serial0/0
6. Configure OSPF
R2:
router ospf 1
 network 172.16.23.0 0.0.0.255 area 0
R3:
router ospf 1
 network 172.16.0.0 0.0.255.255 area 0
 network 192.168.0.0 0.0.255.255 area 0
7. Configure Passive Interface in OSPF
R3:
router ospf 1
 passive-interface default
 no passive-interface Serial0/1
8. Allow One-way Redistribution (OSPF redistribute into RIP)
R2:
router rip
 redistribute ospf 1 metric 4
!
router ospf 1
 default-information originate always
9. Redistribute Between Two Routing Protocols
R2:
router ospf 1
 no default-information originate always
 redistribute rip subnets
10. Set a Default Seed Metric
R2:
router ospf 1
 default-metric 10000
11. Change the OSPF External Network Type
R2:
router ospf 1
 redistribute rip metric-type 1 subnets
12. Check Command
show ip rip database
show ip protocols
ping

R1 Configuration:
hostname R1
!
no ip domain lookup
!
interface Loopback0
 ip address 172.16.1.1 255.255.255.0
!        
interface Loopback48
 ip address 192.168.48.1 255.255.255.0
!
interface Loopback49
 ip address 192.168.49.1 255.255.255.0
!
interface Loopback50
 ip address 192.168.50.1 255.255.255.0
!
interface Loopback51
 ip address 192.168.51.1 255.255.255.0
!
interface Loopback70
 ip address 192.168.70.1 255.255.255.0
!
interface Serial0/0
 ip address 172.16.12.1 255.255.255.0
 no shutdown
!
router rip
 version 2
 redistribute static
 passive-interface default
 no passive-interface Serial0/0
 network 172.16.0.0
 network 192.168.48.0
 network 192.168.49.0
 network 192.168.50.0
 network 192.168.51.0
 network 192.168.70.0
 distribute-list prefix RIP-OUT out Serial0/0
 no auto-summary
!
ip route 192.168.48.0 255.255.252.0 Null0
!
ip prefix-list RIP-OUT seq 5 permit 192.168.48.0/22
ip prefix-list RIP-OUT seq 10 deny 192.168.48.0/22 le 24
ip prefix-list RIP-OUT seq 15 permit 0.0.0.0/0 le 32
!
line con 0
 logging synchronous
!
end
R2 Configuration:
hostname R2
!
no ip domain lookup
!
interface Loopback0
 ip address 172.16.2.1 255.255.255.0
!        
interface Serial0/0
 ip address 172.16.12.2 255.255.255.0
 no shutdown
!
router ospf 1
 redistribute rip metric-type 1 subnets
 network 172.16.23.0 0.0.0.255 area 0
 default-metric 10000
!
router rip
 version 2
 redistribute ospf 1 metric 4
 passive-interface default
 no passive-interface Serial0/0
 network 172.16.0.0
 no auto-summary
!
line con 0
 logging synchronous
!
end

R3 Configuration:
hostname R3
!
no ip domain lookup
!
interface Loopback0
 ip address 172.16.3.1 255.255.255.0
!        
interface Loopback20
 ip address 192.168.20.1 255.255.255.0
!
interface Loopback25
 ip address 192.168.25.1 255.255.255.0
!
interface Loopback30
 ip address 192.168.30.1 255.255.255.0
!
interface Loopback35
 ip address 192.168.35.1 255.255.255.0
!
interface Loopback40
 ip address 192.168.40.1 255.255.255.0
!
interface Serial0/1
 ip address 172.16.23.3 255.255.255.0
 no shutdown
!
router ospf 1
 passive-interface default
 no passive-interface Serial0/1
 network 172.16.0.0 0.0.255.255 area 0
 network 192.168.0.0 0.0.255.255 area 0
!
line con 0
 logging synchronous
!
end
參考資料:
Cisco網路學院 http://www.cisco.com/web/learning/netacad/index.html
CCNP1 Building Scalable Internetworks v5.0
Student Lab Manual

最初發表 / 最後更新: 2008.04.03 / 2018.05.31

0 comments:

張貼留言