Published 5月 31, 2018 by with 0 comment

CCNP-BSCI-v5.0 Lab 2-1: 基本EIGRP設定


本次練習是參考Cisco網路學院
CCNP1 Building Scalable Internetworks v5.0
Student Lab Manual
我將它轉成Dynamips的設定檔 並寫下自己的實驗紀錄


Dynamips的設定檔:

##################################################
#
# For CCNP1 Building Scalable Internetworks v5.0
# Lab 2-1
#
##################################################

autostart=false
[localhost:7200]
workingdir = /opt/dynamips/dynagen-0.10.1/UTS/CCNP1/Week01/workingconfig/

[[3640]]
#  Specify 3640 IOS image on Windows here:
#  image = C:\Program Files\Dynamips\images\c3640-jk9o3s-mz.123-14.T7.extracted.bin
#  Specify 3640 IOS image on Linux here:
 image = /opt/dynamips/images/c3640-jk.bin
 ram = 128
 disk0 = 0
 disk1 = 0
 # Choose an idlepc value from the below
 idlepc = 0x605ac7b8
 mmap = true
 ghostios = true
 confreg = 0x2102

###########################
#
# Define router instances 1
#
###########################
 
 [[Router R1]]
  model = 3640
  console = 2001
  autostart = false
  slot0 = NM-1FE-TX
  slot1 = NM-4T
  S1/0 = R2 S1/0
# cnfg = /opt/dynamips/dynagen-0.10.1/UTS/CCNP1/Week01/initconfig/R1.txt

 [[Router R2]]
  model = 3640
  console = 2002
  autostart = false
  slot0 = NM-1FE-TX
  slot1 = NM-4T
# cnfg = /opt/dynamips/dynagen-0.10.1/UTS/CCNP1/Week01/initconfig/R2.txt

 [[Router R3]]
  model = 3640
  console = 2003
  autostart = false
  slot0 = NM-1FE-TX
# cnfg = /opt/dynamips/dynagen-0.10.1/UTS/CCNP1/Week01/initconfig/R3.txt

 [[Router SW1]]
  model = 3640
  console = 2004
  autostart = false
  slot0 = NM-16ESW
  F0/1 = R1 F0/0
  F0/3 = R2 F0/0
  F0/5 = R3 F0/0
# cnfg = /opt/dynamips/dynagen-0.10.1/UTS/CCNP1/Week01/initconfig/SW1.txt

這Lab只是基本EIGRP設定練習

我的設定是
1. 先設定R1-3每個介面的ip address
R1:
hostname R1
!
no ip domain lookup
!
interface Loopback1
 ip address 10.1.1.1 255.255.255.0
!       
interface FastEthernet0/0
 description R1-SW1
 ip address 10.1.100.1 255.255.255.0
 no shutdown
!       
interface Serial1/0
 description R1-R2
 ip address 10.1.200.1 255.255.255.0
 no shutdown
!
line con 0
 logging synchronous
!
end

R2:
hostname R2
!
no ip domain lookup
!
interface Loopback2
 ip address 10.1.2.1 255.255.255.0
!       
interface FastEthernet0/0
 description R2-SW1
 ip address 10.1.100.2 255.255.255.0
 no shutdown
!
interface Serial1/0
 description R2-R1
 ip address 10.1.200.2 255.255.255.0
 no shutdown
!
line con 0
 logging synchronous
!
end

R3:
hostname R3
!
no ip domain lookup
!
interface Loopback1
 ip address 192.168.100.1 255.255.255.252
!       
interface Loopback3
 ip address 10.1.3.1 255.255.255.0
!
interface Loopback15
 ip address 192.168.100.5 255.255.255.252
!
interface FastEthernet0/0
 description R3-SW1
 ip address 10.1.100.3 255.255.255.0
 no shutdown
!
line con 0
 logging synchronous
!
end


2. 設定整個10.0.0.0網段的EIGRP
R1:
router eigrp 1
 network 10.0.0.0

R2:
router eigrp 1
 network 10.0.0.0

R3:
router eigrp 1
 network 10.0.0.0

3. R3上設定Loopback1跑EIGRP 但Loopback15不跑EIGRP
R3:
router eigrp 1
 network 192.168.100.0 0.0.0.3

4. 會發現R1-2的路由表 關於R3的Loopback1 資訊並不正確
R1-2:
D    192.168.100.0/24 [90/156160] via 10.1.100.3, 00:00:08, FastEthernet0/0
為什麼??因為Cisco預設ERIGRP會auto-summary
R3: no auto-summary 就OK了

5. 驗證指令
show ip eigrp neighbors
show ip route eigrp
ping


R1設定檔:
hostname R1
!
no ip domain lookup
!
interface Loopback1
 ip address 10.1.1.1 255.255.255.0
!       
interface FastEthernet0/0
 description R1-SW1
 ip address 10.1.100.1 255.255.255.0
!
interface Serial1/0
 description R1-R2
 ip address 10.1.200.1 255.255.255.0
!
router eigrp 1
 network 10.0.0.0
!
line con 0
 logging synchronous
!
end

R2設定檔:
hostname R2
!
no ip domain lookup
!
interface Loopback2
 ip address 10.1.2.1 255.255.255.0
!       
interface FastEthernet0/0
 description R2-SW1
 ip address 10.1.100.2 255.255.255.0
!
interface Serial1/0
 description R2-R1
 ip address 10.1.200.2 255.255.255.0
!
router eigrp 1
 network 10.0.0.0
!
line con 0
 logging synchronous
!
end

R3設定檔:
hostname R3
!
no ip domain lookup
!
interface Loopback1
 ip address 192.168.100.1 255.255.255.252
!       
interface Loopback3
 ip address 10.1.3.1 255.255.255.0
!
interface Loopback15
 ip address 192.168.100.5 255.255.255.252
!
interface FastEthernet0/0
 description R3-SW1
 ip address 10.1.100.3 255.255.255.0
!
router eigrp 1
 network 10.0.0.0
 network 192.168.100.0 0.0.0.3
!
line con 0
 logging synchronous
!
!
end

參考資料:
Cisco網路學院 http://www.cisco.com/web/learning/netacad/index.html
CCNP1 Building Scalable Internetworks v5.0
Student Lab Manual


最初發表 / 最後更新: 2008.03.08 / 2018.05.31

0 comments:

張貼留言