Published 5月 31, 2018 by with 0 comment

CCNP-BSCI-v5.0 Lab 3-1: 基本OSPF設定練習


本次練習是參考Cisco網路學院
CCNP1 Building Scalable Internetworks v5.0
Student Lab Manual
我將它轉成Dynamips的設定檔 並寫下自己的實驗紀錄


Dynamips的設定檔:

##################################################
#
# For CCNP1 Building Scalable Internetworks v5.0
# Lab 3-1
#
##################################################

autostart=false
[localhost:7200]
workingdir = /opt/dynamips/dynagen-0.10.1/UTS/CCNP1/Week02/workingconfig/

[[3640]]
#  Specify 3640 IOS image on Windows here:
#  image = C:\Program Files\Dynamips\images\c3640-jk9o3s-mz.123-14.T7.extracted.bin
#  Specify 3640 IOS image on Linux here:
 image = /opt/dynamips/images/c3640-jk.bin
 ram = 128
 disk0 = 0
 disk1 = 0
 # Choose an idlepc value from the below
 idlepc = 0x605ac7b8
 mmap = true
 ghostios = true
 confreg = 0x2102

###########################
#
# Define router instances 1
#
###########################
 
 [[Router R1]]
  model = 3640
  console = 2001
  autostart = false
  slot0 = NM-1FE-TX
  slot1 = NM-4T
  S1/0 = R2 S1/0

 [[Router R2]]
  model = 3640
  console = 2002
  autostart = false
  slot0 = NM-1FE-TX
  slot1 = NM-4T

 [[Router R3]]
  model = 3640
  console = 2003
  autostart = false
  slot0 = NM-1FE-TX

 [[Router SW1]]
  model = 3640
  console = 2004
  autostart = false
  slot0 = NM-16ESW
  F0/1 = R1 F0/0
  F0/3 = R2 F0/0
  F0/5 = R3 F0/0

這Lab只是基本OSPF設定練習

我的設定是
1. 先設定R1-3每個介面的ip address
R1:
hostname R1
!
no ip domain lookup
!
interface Loopback1
 ip address 10.1.1.1 255.255.255.0
!       
interface FastEthernet0/0
 ip address 10.1.200.1 255.255.255.0
 no shutdown
!
interface Serial1/0
 ip address 10.1.100.1 255.255.255.0
 no shutdown
!
line con 0
 logging synchronous
!
end

R2:
hostname R2
!
no ip domain lookup
!
interface Loopback2
 ip address 10.1.2.1 255.255.255.0
!       
interface FastEthernet0/0
 ip address 10.1.200.2 255.255.255.0
 no shutdown
!
interface Serial1/0
 ip address 10.1.100.2 255.255.255.0
 no shutdown
!
line con 0
 logging synchronous
!
end

R3:
hostname R3
!
no ip domain lookup
!
interface Loopback3
 ip address 10.1.3.1 255.255.255.0
!       
interface FastEthernet0/0
 ip address 10.1.200.3 255.255.255.0
 no shutdown
!
line con 0
 logging synchronous
!
end


2. 設定整個10.1.100.0 & 10.1.200.0網段的OSPF
R1:
router ospf 1
network 10.1.100.1 0.0.0.0 area 0
network 10.1.200.0 0.0.0.255 area 0

R2:
router ospf 1
network 10.1.100.0 0.0.0.255 area 0
network 10.1.200.0 0.0.0.255 area 0

R3:
router ospf 1
network 10.1.200.0 0.0.0.255 area 0


3. Loopback interface跑OSPF
R1:
router ospf 1
network 10.1.1.0 0.0.0.255 area 0

R2:
router ospf 1
network 10.1.2.0 0.0.0.255 area 0

R3:
router ospf 1
network 10.1.3.0 0.0.0.255 area 0


4. R1-3改變OSPF link cost
R1-3:
interface fastEthernet 0/0
ip ospf cost 50


5. 驗證指令
show ip ospf neighbor
show ip ospf interface
ping


R1設定檔:
hostname R1
!
no ip domain lookup
!
interface Loopback1
 ip address 10.1.1.1 255.255.255.0
!       
interface FastEthernet0/0
 ip address 10.1.200.1 255.255.255.0
 ip ospf cost 50
 duplex auto
 speed auto
!
interface Serial1/0
 ip address 10.1.100.1 255.255.255.0
!
router ospf 1
 network 10.1.1.0 0.0.0.255 area 0
 network 10.1.100.1 0.0.0.0 area 0
 network 10.1.200.0 0.0.0.255 area 0
!
line con 0
 logging synchronous
!
end

R2設定檔:
hostname R2
!
no ip domain lookup
!
interface Loopback2
 ip address 10.1.2.1 255.255.255.0
!       
interface FastEthernet0/0
 ip address 10.1.200.2 255.255.255.0
 ip ospf cost 50
 duplex auto
 speed auto
!
interface Serial1/0
 ip address 10.1.100.2 255.255.255.0
!
router ospf 1
 network 10.1.2.0 0.0.0.255 area 0
 network 10.1.100.0 0.0.0.255 area 0
 network 10.1.200.0 0.0.0.255 area 0
!
line con 0
 logging synchronous
!
end

R3設定檔:
hostname R3
!
no ip domain lookup
!
interface Loopback3
 ip address 10.1.3.1 255.255.255.0
!       
interface FastEthernet0/0
 ip address 10.1.200.3 255.255.255.0
 ip ospf cost 50
 duplex auto
 speed auto
!
router ospf 1
 network 10.1.3.0 0.0.0.255 area 0
 network 10.1.200.0 0.0.0.255 area 0
!
line con 0
 logging synchronous
!
end


參考資料:
Cisco網路學院 http://www.cisco.com/web/learning/netacad/index.html
CCNP1 Building Scalable Internetworks v5.0
Student Lab Manual


最初發表 / 最後更新: 2008.03.21 / 2018.05.31

0 comments:

張貼留言