Published 5月 31, 2018 by with 0 comment

CCNP-BSCI-v5.0 Lab 3-4-a: OSPF Over Frame Relay的設定練習


本次練習是參考Cisco網路學院
CCNP1 Building Scalable Internetworks v5.0
Student Lab Manual
我將它轉成Dynamips的設定檔 並寫下自己的實驗紀錄

Dynamips的設定檔:
##################################################
#
# For CCNP1 Building Scalable Internetworks v5.0
# Lab 3_4a
#
##################################################
autostart=false
[localhost:7200]
workingdir = /opt/dynamips/dynagen-0.10.1/UTS/CCNP1/Week02/workingconfig/
[[3640]]
#  Specify 3640 IOS image on Windows here:
#  image = C:\Program Files\Dynamips\images\c3640-jk9o3s-mz.123-14.T7.extracted.bin
#  Specify 3640 IOS image on Linux here:
 image = /opt/dynamips/images/c3640-jk.bin
 ram = 128
 disk0 = 0
 disk1 = 0
 # Choose an idlepc value from the below
 idlepc = 0x605ac7b8
 mmap = true
 ghostios = true
 confreg = 0x2102

###########################
#
# Define router instances 1
#
###########################
  
 [[Router HQ]]
  model = 3640
  console = 2001
  autostart = false
  slot1 = NM-4T
  S1/0 = FRSW 1
 [[Router East]]
  model = 3640
  console = 2002
  autostart = false
  slot0 = NM-1FE-TX
  slot1 = NM-4T
  Fa0/0 = SW1 Fa0/0
  S1/0 = FRSW 2
 [[Router West]]
  model = 3640
  console = 2003
  autostart = false
  slot0 = NM-1FE-TX
  slot1 = NM-4T
  Fa0/0 = SW1 Fa0/1
  S1/0 = FRSW 3
 [[Router SW1]]
  model = 3640
  console = 2004
  autostart = false
  slot0 = NM-16ESW
[[FRSW FRSW]]
  # HQ to FRSW
  1:102 = 2:201
  1:103 = 3:301
這Lab是OSPF Over Frame Relay(FR)的設定練習
我的設定是
1. 先設定HQ, East, West 的interface
HQ:
hostname HQ
!
no ip domain lookup
!
interface Loopback1
 ip address 10.1.1.1 255.255.255.0
!
interface Serial1/0
 ip address 10.1.123.1 255.255.255.0
 encapsulation frame-relay
 frame-relay map ip 10.1.123.1 102
 frame-relay map ip 10.1.123.2 102 broadcast
 frame-relay map ip 10.1.123.3 103 broadcast
 no frame-relay inverse-arp
 no shutdown
!        
line con 0
 logging synchronous
!
end
East:
hostname East
!
no ip domain lookup
!
interface Loopback2
 ip address 10.1.2.1 255.255.255.0
!
interface FastEthernet0/0
 ip address 10.1.23.2 255.255.255.0
 no shutdown
!
interface Serial1/0
 ip address 10.1.123.2 255.255.255.0
 encapsulation frame-relay
 frame-relay map ip 10.1.123.1 201 broadcast
 frame-relay map ip 10.1.123.2 201
 frame-relay map ip 10.1.123.3 201 broadcast
 no frame-relay inverse-arp
 no shutdown
!       
line con 0
 logging synchronous
!
end
West:
hostname West
!
no ip domain lookup
!
interface Loopback3
 ip address 10.1.3.1 255.255.255.0
!        
interface FastEthernet0/0
 ip address 10.1.23.3 255.255.255.0
 no shutdown
!
interface Serial1/0
 ip address 10.1.123.3 255.255.255.0
 encapsulation frame-relay
 frame-relay map ip 10.1.123.1 301 broadcast
 frame-relay map ip 10.1.123.2 301 broadcast
 frame-relay map ip 10.1.123.3 301
 no frame-relay inverse-arp
 no shutdown
!
line con 0
 logging synchronous
!
end

2. 設定NBMA OSPF
HQ:
router ospf 1
 network 10.1.1.0 0.0.0.255 area 0
 network 10.1.123.0 0.0.0.255 area 0
!
interface Loopback1
 ip ospf network point-to-point
East:
router ospf 1
 network 10.1.2.0 0.0.0.255 area 0
 network 10.1.123.0 0.0.0.255 area 0
!
interface Loopback2
 ip ospf network point-to-point
Wast:
router ospf 1
 network 10.1.3.0 0.0.0.255 area 0
 network 10.1.123.0 0.0.0.255 area 0
!
interface Loopback3
 ip ospf network point-to-point
會發現OSPF沒有建立起鄰接關係
HQ&East&Wast:
show ip ospf neighbor
show ip ospf database
show ip ospf interface serial 1/0
為什麼??因為Network Type NON_BROADCAST 需要手動指定鄰接關係
HQ:
router ospf 1
 neighbor 10.1.123.2
 neighbor 10.1.123.3
再將HQ成為DR 可節省FR的頻寬
East&Wast:
interface Serial1/0
 ip ospf priority 0

3. Changing the Network Type to Point-to-Multipoint
先恢復上一步
HQ:
router ospf 1
 no neighbor 10.1.123.2
 no neighbor 10.1.123.3
East&Wast:
interface Serial1/0
 no ip ospf priority 0
改變Network Type 為 Point-to-Multipoint
HQ&East&Wast:
interface serial 1/0
 ip ospf network point-to-multipoint

4. Changing OSPF Timers
East&Wast:
router ospf 1
 network 10.1.23.0 0.0.0.255 area 0
!
interface fastEthernet 0/0
 ip ospf hello-interval 5
 ip ospf dead-interval 15

5. 驗證指令
show fram-relay pvc
show ip ospf neighbor 
show ip route ospf
show ip ospf interface
ping

HQ設定檔:
hostname HQ
!
no ip domain lookup
!
interface Loopback1
 ip address 10.1.1.1 255.255.255.0
 ip ospf network point-to-point
!
interface Serial1/0
 ip address 10.1.123.1 255.255.255.0
 encapsulation frame-relay
 ip ospf network point-to-multipoint
 frame-relay map ip 10.1.123.1 102
 frame-relay map ip 10.1.123.2 102 broadcast
 frame-relay map ip 10.1.123.3 103 broadcast
 no frame-relay inverse-arp
!
router ospf 1
 network 10.1.1.0 0.0.0.255 area 0
 network 10.1.123.0 0.0.0.255 area 0
!
line con 0
 logging synchronous
!
end
East設定檔:
hostname East
!
no ip domain lookup
!
interface Loopback2
 ip address 10.1.2.1 255.255.255.0
 ip ospf network point-to-point
!
interface FastEthernet0/0
 ip address 10.1.23.2 255.255.255.0
 ip ospf hello-interval 5
 ip ospf dead-interval 15
!
interface Serial1/0
 ip address 10.1.123.2 255.255.255.0
 encapsulation frame-relay
 ip ospf network point-to-multipoint
 frame-relay map ip 10.1.123.1 201 broadcast
 frame-relay map ip 10.1.123.2 201
 frame-relay map ip 10.1.123.3 201 broadcast
 no frame-relay inverse-arp
!
router ospf 1
 network 10.1.2.0 0.0.0.255 area 0
 network 10.1.23.0 0.0.0.255 area 0
 network 10.1.123.0 0.0.0.255 area 0
!
line con 0
 logging synchronous
!
end
West設定檔:
hostname West
!
no ip domain lookup
!
interface Loopback3
 ip address 10.1.3.1 255.255.255.0
 ip ospf network point-to-point
!
interface FastEthernet0/0
 ip address 10.1.23.3 255.255.255.0
 ip ospf hello-interval 5
 ip ospf dead-interval 15
!
interface Serial1/0
 ip address 10.1.123.3 255.255.255.0
 encapsulation frame-relay
 ip ospf network point-to-multipoint
 frame-relay map ip 10.1.123.1 301 broadcast
 frame-relay map ip 10.1.123.2 301 broadcast
 frame-relay map ip 10.1.123.3 301
 no frame-relay inverse-arp
!
router ospf 1
 network 10.1.3.0 0.0.0.255 area 0
 network 10.1.23.0 0.0.0.255 area 0
 network 10.1.123.0 0.0.0.255 area 0
!
line con 0
 logging synchronous
!
end
參考資料:
Cisco網路學院 http://www.cisco.com/web/learning/netacad/index.html
CCNP1 Building Scalable Internetworks v5.0
Student Lab Manual

最初發表 / 最後更新: 2008.03.23 / 2018.05.31

0 comments:

張貼留言