本次練習是參考Cisco網路學院
CCNP1 Building Scalable Internetworks v5.0
Student Lab Manual
我將它轉成Dynamips的設定檔 並寫下自己的實驗紀錄
Dynamips的設定檔:
##################################################
#
# For CCNP1 Building Scalable Internetworks v5.0
# Lab 3_2-3
#
##################################################
autostart=false
[localhost:7200]
workingdir = /opt/dynamips/dynagen-0.10.1/UTS/CCNP1/Week02/workingconfig/
[[3640]]
# Specify 3640 IOS image on Windows here:
# image = C:\Program Files\Dynamips\images\c3640-jk9o3s-mz.123-14.T7.extracted.bin
# Specify 3640 IOS image on Linux here:
image = /opt/dynamips/images/c3640-jk.bin
ram = 128
disk0 = 0
disk1 = 0
# Choose an idlepc value from the below
idlepc = 0x605ac7b8
mmap = true
ghostios = true
confreg = 0x2102
###########################
#
# Define router instances 1
#
###########################
[[Router R1]]
model = 3640
console = 2001
autostart = false
slot0 = NM-4T
[[Router R2]]
model = 3640
console = 2002
autostart = false
slot0 = NM-4T
S0/0 = R1 S0/0
S0/1 = R3 S0/1
[[Router R3]]
model = 3640
console = 2003
autostart = false
slot0 = NM-4T
這Lab是Vitual Links and Area Summarization的OSPF設定練習
我的設定是
1. 先設定R1-3每個介面的ip address
R1:
hostname R1
!
no ip domain lookup
!
interface Loopback1
ip address 10.1.1.1 255.255.255.0
!
interface Serial0/0
ip address 10.1.12.1 255.255.255.0
no shutdown
!
line con 0
logging synchronous
!
end
R2:
hostname R2
!
no ip domain lookup
!
interface Loopback2
ip address 10.1.2.1 255.255.255.0
!
interface Serial0/0
ip address 10.1.12.2 255.255.255.0
no shutdown
!
interface Serial0/1
ip address 10.1.23.2 255.255.255.0
no shutdown
!
line con 0
logging synchronous
!
end
R3:
hostname R3
!
no ip domain lookup
!
interface Loopback3
ip address 10.1.3.1 255.255.255.0
!
interface Loopback100
ip address 192.168.100.1 255.255.255.0
!!
interface Loopback101
ip address 192.168.101.1 255.255.255.0
!!
interface Loopback102
ip address 192.168.102.1 255.255.255.0
!
interface Loopback103
ip address 192.168.103.1 255.255.255.0
!
interface Serial0/1
ip address 10.1.23.3 255.255.255.0
no shutdown
!
line con 0
logging synchronous
!
end
2. 設定R1-2 run OSPF Area 0
R1:
router ospf 1
network 10.1.1.0 0.0.0.255 area 0
network 10.1.12.0 0.0.0.255 area 0
!
interface Loopback1
ip ospf network point-to-point
R2:
router ospf 1
network 10.1.2.0 0.0.0.255 area 0
network 10.1.12.0 0.0.0.255 area 0
!
interface Loopback2
ip ospf network point-to-point
3. R2-3 跑OSPF Area 23
R2:
router ospf 1
network 10.1.23.0 0.0.0.255 area 23
R3:
router ospf 1
network 10.1.3.0 0.0.0.255 area 23
network 10.1.23.0 0.0.0.255 area 23
!
interface Loopback3
ip ospf network point-to-point
4. Area 23 跑Stub area
R2-3:
router ospf 1
area 23 stub
(Area 23的Router都要設 area 23 stub)
5. 建立Virtual Links
R3:
router ospf 1
network 192.168.100.0 0.0.3.255 area 100
!
interface loopback 100
ip ospf network point-to-point
!
interface loopback 101
ip ospf network point-to-point
!
interface loopback 102
ip ospf network point-to-point
!
interface loopback 103
ip ospf network point-to-point
!
router ospf 1
area 23 virtual-link 10.1.2.1
R2:
router ospf 1
area 23 virtual-link 192.168.103.1
6. Area 100 Summarizing
R3:
router ospf 1
area 100 range 192.168.100.0 255.255.252.0
7. 建立一個Default Route 在 OSPF
R1:
router ospf 1
default-information originate always
8. 驗證指令
show ip ospf neighbor
show ip ospf interface
show ip ospf database
ping
R1設定檔:
hostname R1
!
no ip domain lookup
!
interface Loopback1
ip address 10.1.1.1 255.255.255.0
ip ospf network point-to-point
!
interface Serial0/0
ip address 10.1.12.1 255.255.255.0
!
router ospf 1
network 10.1.1.0 0.0.0.255 area 0
network 10.1.12.0 0.0.0.255 area 0
default-information originate always
!
line con 0
logging synchronous
!
end
R2設定檔:
hostname R2
!
no ip domain lookup
!
interface Loopback2
ip address 10.1.2.1 255.255.255.0
ip ospf network point-to-point
!
interface Serial0/0
ip address 10.1.12.2 255.255.255.0
!
interface Serial0/1
ip address 10.1.23.2 255.255.255.0
!
router ospf 1
area 23 virtual-link 192.168.103.1
network 10.1.2.0 0.0.0.255 area 0
network 10.1.12.0 0.0.0.255 area 0
network 10.1.23.0 0.0.0.255 area 23
!
line con 0
logging synchronous
!
end
R3設定檔:
hostname R3
!
no ip domain lookup
!
interface Loopback3
ip address 10.1.3.1 255.255.255.0
ip ospf network point-to-point
!
interface Loopback100
ip address 192.168.100.1 255.255.255.0
ip ospf network point-to-point
!
interface Loopback101
ip address 192.168.101.1 255.255.255.0
ip ospf network point-to-point
!
interface Loopback102
ip address 192.168.102.1 255.255.255.0
ip ospf network point-to-point
!
interface Loopback103
ip address 192.168.103.1 255.255.255.0
ip ospf network point-to-point
!
interface Serial0/1
ip address 10.1.23.3 255.255.255.0
!
router ospf 1
area 23 virtual-link 10.1.2.1
area 100 range 192.168.100.0 255.255.252.0
network 10.1.3.0 0.0.0.255 area 23
network 10.1.23.0 0.0.0.255 area 23
network 192.168.100.0 0.0.3.255 area 100
!
line con 0
logging synchronous
!
end
參考資料:
Cisco網路學院 http://www.cisco.com/web/learning/netacad/index.html
CCNP1 Building Scalable Internetworks v5.0
Student Lab Manual
最初發表 / 最後更新: 2008.03.23 / 2018.05.31
0 comments:
張貼留言