Published 5月 28, 2018 by with 21 comments

CCNA3 Lab 6-4-1: 基本Inter-VLAN Routing設定練習

CCNA Lab

本次練習是參考Cisco網路學院
CCNA Exploration 4.0 LAN Switching and Wireless
Student Lab Manual
我將它轉成Dynamips的設定檔 並寫下自己的實驗紀錄

Dynamips的設定檔:
##################################################
#
# For CCNA Exploration 4.0 LAN and Switching and Wireless
# Lab 6.4.1-3
#
##################################################
autostart=false
[localhost:7200]
workingdir = /opt/dynamips/dynagen-0.10.1/UTS/CCNA3/Week03/workingconfig/
[[3640]]
#  Specify 3640 IOS image on Windows here:
#  image = C:\Program Files\Dynamips\images\c3640-jk9o3s-mz.123-14.T7.extracted.bin
#  Specify 3640 IOS image on Linux here:
 image = /opt/dynamips/images/c3640-jk.bin
 ram = 128
 disk0 = 0
 disk1 = 0
 # Choose an idlepc value from the below
 idlepc = 0x605ac7b8
 mmap = true
 ghostios = true
 confreg = 0x2102

###########################
#
# Define router instances 1
#
###########################
 [[Router R1]]
  model = 3640
  console = 2001
  autostart = false
  slot0 = NM-1FE-TX
  slot1 = NM-1FE-TX
  Fa0/0 = Server F0/0
  Fa1/0 = SW1 F0/5
  
 [[Router SW1]]
  model = 3640
  console = 2002
  autostart = false
  slot0 = NM-16ESW
  F0/1 = SW2 F0/2
  F0/2 = SW2 F0/1
  F0/3 = SW3 F0/3
  F0/4 = SW3 F0/4
 [[Router SW2]]
  model = 3640
  console = 2003
  autostart = false
  slot0 = NM-16ESW
  F0/11 = PC1 F0/0
  F0/12 = PC2 F0/0
  F0/13 = PC3 F0/0
 [[Router SW3]]
  model = 3640
  console = 2004
  autostart = false
  slot0 = NM-16ESW
  F0/1 = SW2 F0/3
  F0/2 = SW2 F0/4
 [[Router Server]]
  model = 3640
  console = 2005
  autostart = false
  slot0 = NM-1FE-TX
 [[Router PC1]]
  model = 3640
  console = 2006
  autostart = false
  slot0 = NM-1FE-TX
 [[Router PC2]]
  model = 3640
  console = 2007
  autostart = false
  slot0 = NM-1FE-TX
 [[Router PC3]]
  model = 3640
  console = 2008
  autostart = false
  slot0 = NM-1FE-TX
這Lab是基本Inter-VLAN Routing設定練習
需要設定VLAN
需要設定VTP
最後是設定Inter-VLAN Routing

我的設定是
1. 先設定PC1-3,Server
hostname *
!
no ip domain lookup
!
interface FastEthernet0/0
 ip address 172.17.*.* 255.255.255.0
 no shutdown
!
ip route 0.0.0.0 0.0.0.0 172.17.*.1
!
line con 0
 logging synchronous
!
end
2. 設定Switch1-3的VTP mode
S1-3:
VTP Domain: Lab6
VTP Password: cisco
S1:
VTP mode: Server
S2-3
VTP mode: Client
Switch1:
vlan database
vtp domain Lab6
vtp server
vtp password cisco
exit
Switch2 & 3:
vlan database
vtp domain Lab6
vtp client
vtp password cisco
exit
3. Switch1-3 設定Trunk跟native VLAN 在Trunking port
Switch1:
interface range fastEthernet 0/1 - 5
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 99
 switchport mode trunk
Switch2 & 3:
interface range fastEthernet 0/1 - 4
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 99
 switchport mode trunk
4. Switch1上設定VLAN
vlan database
vlan 10 name Staff
vlan 20 name Students
vlan 30 name Guest
vlan 99 name management
exit
show vlan-switch
會發現VLAN的設定 已經套在Switch2 & 3上
5. Switch2手動設定VLAN Port
Switch2:
interface fastEthernet 0/11
switchport mode access
switchport access vlan 10
no shutdown
!
interface fastEthernet 0/12
switchport mode access
switchport access vlan 20
no shutdown
!
interface fastEthernet 0/13
switchport access vlan 30
no shutdown
6. Switch1-3 設定VLAN interface
Switch1-3:
interface vlan 99
ip address 172.17.99.1* 255.255.255.0
no shutdown
!
ip default-gateway 172.17.99.1
7. R1的基本設定與設定Trunk interface
Router1:
hostname R1
!
no ip domain lookup
!
interface fastEthernet 0/0
 ip address 172.17.50.1 255.255.255.0
 no shutdown
!        
interface fastEthernet 1/0
 no ip address
 no shutdown
!
interface fastEthernet 1/0.1
 encapsulation dot1Q 1
 ip address 172.17.1.1 255.255.255.0
 no shutdown
!        
interface fastEthernet 1/0.10
 encapsulation dot1Q 10
 ip address 172.17.10.1 255.255.255.0
!
interface fastEthernet 1/0.20
 encapsulation dot1Q 20
 ip address 172.17.20.1 255.255.255.0
!
interface fastEthernet 1/0.30
 encapsulation dot1Q 30
 ip address 172.17.30.1 255.255.255.0
!
interface fastEthernet 1/0.99
 encapsulation dot1Q 99 native
 ip address 172.17.99.1 255.255.255.0
!
line con 0
 logging synchronous

8. 驗證指令
show ip route
show vlan-switch
show interfaces trunk
最後PC1-3, SW1-3, Server, R1互ping 有通 結束

Router1設定檔:
hostname R1
!
no ip domain lookup
!
interface FastEthernet0/0
 ip address 172.17.50.1 255.255.255.0
 speed auto
 full-duplex
!
interface FastEthernet1/0
 no ip address
 speed auto
 full-duplex
!
interface FastEthernet1/0.1
 encapsulation dot1Q 1
 ip address 172.17.1.1 255.255.255.0
!
interface FastEthernet1/0.10
 encapsulation dot1Q 10
 ip address 172.17.10.1 255.255.255.0
!
interface FastEthernet1/0.20
 encapsulation dot1Q 20
 ip address 172.17.20.1 255.255.255.0
!
interface FastEthernet1/0.30
 encapsulation dot1Q 30
 ip address 172.17.30.1 255.255.255.0
!        
interface FastEthernet1/0.99
 encapsulation dot1Q 99 native
 ip address 172.17.99.1 255.255.255.0
!
line con 0
 logging synchronous
!
end
Switch1設定檔:
hostname SW1
!
no ip domain lookup
!
interface FastEthernet0/1
 switchport trunk native vlan 99
 switchport mode trunk
!
interface FastEthernet0/2
 switchport trunk native vlan 99
 switchport mode trunk
!
interface FastEthernet0/3
 switchport trunk native vlan 99
 switchport mode trunk
!
interface FastEthernet0/4
 switchport trunk native vlan 99
 switchport mode trunk
!
interface FastEthernet0/5
 switchport trunk native vlan 99
 switchport mode trunk
!
interface Vlan99
 ip address 172.17.99.11 255.255.255.0
!
ip default-gateway 172.17.99.1
!
line con 0
 logging synchronous
!
end
Switch2設定檔:
hostname SW2
!
no ip domain lookup
!
interface FastEthernet0/1
 switchport trunk native vlan 99
 switchport mode trunk
!
interface FastEthernet0/2
 switchport trunk native vlan 99
 switchport mode trunk
!
interface FastEthernet0/3
 switchport trunk native vlan 99
 switchport mode trunk
!
interface FastEthernet0/4
 switchport trunk native vlan 99
 switchport mode trunk
!
interface Vlan99
 ip address 172.17.99.12 255.255.255.0
!        
ip default-gateway 172.17.99.1
!
line con 0
 logging synchronous
!
end
Switch3設定檔:
hostname SW3
!
no ip domain lookup
!
interface FastEthernet0/1
 switchport trunk native vlan 99
 switchport mode trunk
!
interface FastEthernet0/2
 switchport trunk native vlan 99
 switchport mode trunk
!
interface FastEthernet0/3
 switchport trunk native vlan 99
 switchport mode trunk
!
interface FastEthernet0/4
 switchport trunk native vlan 99
 switchport mode trunk
!
interface Vlan99
 ip address 172.17.99.13 255.255.255.0
!
ip default-gateway 172.17.99.1
!
line con 0
 logging synchronous
!        
end
Server設定檔:
hostname Server
!
no ip domain lookup
!
interface FastEthernet0/0
 ip address 172.17.50.254 255.255.255.0
 duplex auto
 speed auto
!
ip route 0.0.0.0 0.0.0.0 172.17.50.1
!
line con 0
 logging synchronous
!
end
PC1設定檔:
hostname PC1
!
no ip domain lookup
!
interface FastEthernet0/0
 ip address 172.17.10.21 255.255.255.0
 duplex auto
 speed auto
!
ip route 0.0.0.0 0.0.0.0 172.17.10.1
!
line con 0
 logging synchronous
!
end
PC2設定檔:
hostname PC2
!
no ip domain lookup
!
interface FastEthernet0/0
 ip address 172.17.20.22 255.255.255.0
 duplex auto
 speed auto
!
ip route 0.0.0.0 0.0.0.0 172.17.20.1
!
line con 0
 logging synchronous
!
end
PC3設定檔:
hostname PC3
!
no ip domain lookup
!
interface FastEthernet0/0
 ip address 172.17.30.23 255.255.255.0
 duplex auto
 speed auto
!
ip route 0.0.0.0 0.0.0.0 172.17.30.1
!
line con 0
 logging synchronous
!
end

參考資料:
Cisco網路學院 http://www.cisco.com/web/learning/netacad/index.html
CCNA Exploration 4.0 LAN Switching and Wireless
Student Lab Manual

最初發表 / 最後更新: 2008.03.21 / 2018.05.28

21 則留言:

  1. I think this is one of the so much vital info for me. And i am glad reading your article. But wanna observation on some general things, The web site style is wonderful, the articles is truly nice : D. Just right activity, cheers

    回覆刪除
  2. Howdy just wanted to give you a quick heads up. The text in your content seem to be running off the screen in Opera. I'm not sure if this is a format issue or something to do with browser compatibility but I thought I'd post to let you know. The layout look great though! Hope you get the problem solved soon. Kudos

    回覆刪除
  3. I'm really enjoying the design and layout of your website. It's a very easy on the eyes which makes it much more enjoyable for me to come here and visit more often. Did you hire out a developer to create your theme? Outstanding work!

    回覆刪除
  4. Magnificent web site. Plenty of useful info here. I'm sending it to a few buddies ans additionally sharing in delicious. And of course, thank you in your sweat!

    回覆刪除
  5. Hey! I know this is kinda off topic but I was wondering if you knew where I could find a captcha plugin for my comment form? I'm using the same blog platform as yours and I'm having problems finding one? Thanks a lot!

    回覆刪除
  6. Hi! I've been following your weblog for a long time now and finally got the bravery to go ahead and give you a shout out from Austin Texas! Just wanted to mention keep up the fantastic job!

    回覆刪除
  7. Heya i'm for the first time here. I came across this board and I find It really useful & it helped me out much. I hope to give something back and aid others like you helped me.

    回覆刪除
  8. Admiring the dedication you put into your website and detailed information you offer. It's good to come across a blog every once in a while that isn't the same old rehashed information. Excellent read! I've saved your site and I'm including your RSS feeds to my Google account.

    回覆刪除
  9. Link exchange is nothing else except it is only placing the other person's web site link on your page at proper place and other person will also do similar for you.

    回覆刪除
  10. I quite like reading through a post that can make people think. Also, thank you for allowing me to comment!

    回覆刪除
  11. What i do not realize is in truth how you're not actually a lot more neatly-appreciated than you might be now. You're very intelligent. You realize therefore considerably relating to this topic, made me personally believe it from a lot of numerous angles. Its like men and women are not involved until it's something to do with Lady gaga! Your personal stuffs nice. All the time maintain it up!

    回覆刪除
  12. I enjoy, lead to I discovered exactly what I used to be having a look for. You've ended my four day lengthy hunt! God Bless you man. Have a nice day. Bye

    回覆刪除
  13. Greetings! I know this is kind of off topic but I was wondering if you knew where I could locate a captcha plugin for my comment form? I'm using the same blog platform as yours and I'm having problems finding one? Thanks a lot!

    回覆刪除
  14. Your style is really unique compared to other people I've read stuff from. Thank you for posting when you've got the opportunity, Guess I'll just book mark this page.

    回覆刪除
  15. Whats up this is kinda of off topic but I was wondering if blogs use WYSIWYG editors or if you have to manually code with HTML. I'm starting a blog soon but have no coding know-how so I wanted to get advice from someone with experience. Any help would be enormously appreciated!

    回覆刪除
  16. Pretty! This was an extremely wonderful post. Thank you for providing this info.

    回覆刪除
  17. After exploring a handful of the blog posts on your website, I seriously appreciate your way of blogging. I saved as a favorite it to my bookmark website list and will be checking back in the near future. Take a look at my website as well and tell me how you feel.

    回覆刪除
  18. Greetings! Very helpful advice in this particular article! It's the little changes that produce the most significant changes. Many thanks for sharing!

    回覆刪除
  19. Good web site you have got here.. It's difficult to find high-quality writing like yours nowadays. I truly appreciate individuals like you! Take care!!

    回覆刪除
  20. A fascinating discussion is worth comment. I think that you need to write more about this issue, it may not be a taboo subject but typically people do not speak about these subjects. To the next! All the best!!

    回覆刪除
  21. Excellent blog here! Also your website loads up very fast! What host are you using? Can I get your affiliate link to your host? I wish my web site loaded up as fast as yours lol

    回覆刪除