Published 6月 07, 2018 by with 0 comment

CCNP-BCMSN-v5.0 Lab 2-1: Catalyst 2960 and 3560 Series Static VLANS, VLAN Trunking, and VTP Domain and Modes


!!!I used real Cisco 3550 switch *4 to do this lab. I did not use Dynamips to do this lab.!!!

Objective:
Set up a VTP domain, create and maintain VLANs, and use Inter-Switch Link
(ISL) and 802.1Q trunking on Cisco Catalyst 2960 and 3560 series Ethernet
switches using command-line interface (CLI) mode.



Scenario:
Prepare a Catalyst 2960 or 3560 switch to be used in a lab.


Basic Configuration:
DLS1 & DLS2:
enable
configure terminal
!
no ip domain lookup
!
vtp mode transparent
!
line console 0
 logging synchronous
 exec-timeout 0 0
!
interface range FastEthernet 0/1 -24
 shutdown
 exit
!
interface range gigabitEthernet 0/1 - 2
 shutdown
 exit
!
hostname DSL(1,2)

ALS1 & ALS2:
enable
configure terminal
!
no ip domain lookup
!
vtp mode transparent
!
line console 0
 logging synchronous
 exec-timeout 0 0
!
interface range FastEthernet 0/1 -24
 shutdown
 exit
!
interface range gigabitEthernet 0/1 - 2
 shutdown
 exit
!
no ip routing
!
hostname ASL(1,2)


Step 1
Start by deleting the vlan.dat file, erasing the startup config, and reloading all your switches.
All Switch:
Clearing all Switches


Step 2
By default, VLAN 1 is used as the management VLAN.
DLS1:
DSL1(config)#interface vlan 1
DSL1(config-if)#ip address 10.1.1.101 255.255.255.0
DSL1(config-if)#no shutdown

DLS2:
DSL2(config)#interface vlan 1
DSL2(config-if)#ip address 10.1.1.102 255.255.255.0
DSL2(config-if)#no shutdown

ALS1:
ASL1(config)#interface vlan 1
ASL1(config-if)#ip address 10.1.1.103 255.255.255.0
ASL1(config-if)#no shutdown

ALS2:
ASL2(config)#interface vlan 1
ASL2(config-if)#ip address 10.1.1.104 255.255.255.0
ASL2(config-if)#no shutdown


Step 3
Use the show vlan command from privileged mode on any switch.
All Switch:
All Switch#show vlan

DSL1#show vlan

VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Fa0/1, Fa0/2, Fa0/3, Fa0/4
                                                Fa0/5, Fa0/6, Fa0/7, Fa0/8
                                                Fa0/9, Fa0/10, Fa0/11, Fa0/12
                                                Fa0/13, Fa0/14, Fa0/15, Fa0/16
                                                Fa0/17, Fa0/18, Fa0/19, Fa0/20
                                                Fa0/21, Fa0/22, Fa0/23, Fa0/24
                                                Gi0/1, Gi0/2
1002 fddi-default                     act/unsup
1003 token-ring-default               act/unsup
1004 fddinet-default                  act/unsup
1005 trnet-default                    act/unsup

VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
1    enet  100001     1500  -      -      -        -    -        0      0 
1002 fddi  101002     1500  -      -      -        -    -        0      0 
1003 tr    101003     1500  -      -      -        -    -        0      0 
1004 fdnet 101004     1500  -      -      -        ieee -        0      0 
1005 trnet 101005     1500  -      -      -        ibm  -        0      0 

Remote SPAN VLANs
------------------------------------------------------------------------------


Primary Secondary Type              Ports
------- --------- ----------------- ------------------------------------------

DSL1#


Step 4
A switch can be in only one VTP domain with the same VTP domain name.
All Switch:
All Switch#show vtp status

DSL1#show vtp status
VTP Version                     : running VTP1 (VTP2 capable)
Configuration Revision          : 0
Maximum VLANs supported locally : 1005
Number of existing VLANs        : 5
VTP Operating Mode              : Transparent
VTP Domain Name                 :
VTP Pruning Mode                : Disabled
VTP V2 Mode                     : Disabled
VTP Traps Generation            : Disabled
MD5 digest                      : 0x57 0xCD 0x40 0x65 0x63 0x59 0x47 0xBD
Configuration last modified by 0.0.0.0 at 0-0-00 00:00:00
DSL1#


Step 5
Set up the switches so that the DL switches are in VTP server mode, and the AL
switches are in VTP client mode.
DSL1(config)#vtp mode server

DSL2(config)#vtp mode server

ASL1(config)#vtp mode client

ASL2(config)#vtp mode client

Change the VTP domain name on DLS1 to SWLAB using the vtp domain command.
DSL1(config)#vtp domain SWLAB


All Switch:
All Switch#show vtp status

ASL1#show vtp status
VTP Version                     : running VTP1 (VTP2 capable)
Configuration Revision          : 0
Maximum VLANs supported locally : 1005
Number of existing VLANs        : 5
VTP Operating Mode              : Client
VTP Domain Name                 :
VTP Pruning Mode                : Disabled
VTP V2 Mode                     : Disabled
VTP Traps Generation            : Disabled
MD5 digest                      : 0x57 0xCD 0x40 0x65 0x63 0x59 0x47 0xBD
Configuration last modified by 0.0.0.0 at 0-0-00 00:00:00
ASL1#


Step 6
The "show interfaces fastEthernet 0/1 switchport" command lists the configured
 mode of each port in detail.
DSL1#show interfaces fastEthernet 0/1 switchport
Name: Fa0/1
Switchport: Enabled
Administrative Mode: dynamic desirable
Operational Mode: down
Administrative Trunking Encapsulation: negotiate
Negotiation of Trunking: On
Access Mode VLAN: 1 (default)
Trunking Native Mode VLAN: 1 (default)
Administrative Native VLAN tagging: enabled
Voice VLAN: none
Administrative private-vlan host-association: none
Administrative private-vlan mapping: none
Administrative private-vlan trunk native VLAN: none
Administrative private-vlan trunk Native VLAN tagging: enabled
Administrative private-vlan trunk encapsulation: dot1q
Administrative private-vlan trunk normal VLANs: none
Administrative private-vlan trunk associations: none
Administrative private-vlan trunk mappings: none
Operational private-vlan: none
Trunking VLANs Enabled: ALL
Pruning VLANs Enabled: 2-1001
Capture Mode Disabled
Capture VLANs Allowed: ALL
Protected: false
Unknown unicast blocked: disabled
Unknown multicast blocked: disabled
Appliance trust: none
DSL1#

Use the "interface range" command to configure all trunk ports at once for trunking.
DLS1:
DSL1(config)#interface  range fastEthernet 0/7 - 10
DSL1(config-if-range)#switchport trunk encapsulation dot1q
DSL1(config-if-range)#switchport mode trunk
DSL1(config-if-range)#no shutdown
DSL1(config-if-range)#interface range fastEthernet 0/11 - 12
DSL1(config-if-range)#switchport trunk encapsulation isl
DSL1(config-if-range)#switchport mode trunk
DSL1(config-if-range)#no shutdown

DSL2:
DSL2(config)#interface  range fastEthernet 0/7 - 10
DSL2(config-if-range)#switchport trunk encapsulation dot1q
DSL2(config-if-range)#switchport mode trunk
DSL1(config-if-range)#no shutdown
DSL2(config-if-range)#interface range fastEthernet 0/11 - 12
DSL2(config-if-range)#switchport trunk encapsulation isl
DSL2(config-if-range)#switchport mode trunk
DSL1(config-if-range)#no shutdown

ALS1:
ASL1(config)#interface range fastEthernet 0/7 - 12
ASL1(config-if-range)#switchport trunk encapsulation dot1q
ASL1(config-if-range)#switchport mode trunk
ASL1(config-if-range)#no shutdown

ALS2:
ASL2(config)#interface range fastEthernet 0/7 - 12
ASL2(config-if-range)#switchport trunk encapsulation dot1q
ASL2(config-if-range)#switchport mode trunk
ASL2(config-if-range)#no shutdown
ASL2(config-if-range)#


Step 7
Verify the trunking configuration of each switch using the following commands.
All Switch:
DSL1#show interfaces trunk

Port        Mode             Encapsulation  Status        Native vlan
Fa0/7       on               802.1q         trunking      1
Fa0/8       on               802.1q         trunking      1
Fa0/9       on               802.1q         trunking      1
Fa0/10      on               802.1q         trunking      1
Fa0/11      on               isl            trunking      1
Fa0/12      on               isl            trunking      1

Port        Vlans allowed on trunk
Fa0/7       1-4094
Fa0/8       1-4094
Fa0/9       1-4094
Fa0/10      1-4094
Fa0/11      1-4094
Fa0/12      1-4094

Port        Vlans allowed and active in management domain
Fa0/7       1
Fa0/8       1
Fa0/9       1
Fa0/10      1
Fa0/11      1
        
Port        Vlans allowed and active in management domain
Fa0/12      1

Port        Vlans in spanning tree forwarding state and not pruned
Fa0/7       1
Fa0/8       1
Fa0/9       1
Fa0/10      1
Fa0/11      1
Fa0/12      1
DSL1#

DSL1(config)#vlan 100
DSL1(config-vlan)#exit
DSL1(config)#vlan 110
DSL1(config-vlan)#exit
DSL1(config)#vlan 120
DSL1(config-vlan)#exit
DSL1(config)#

Step 8
The Fast Ethernet ports connected to the hosts on the network can be set up as
static access because they are not to be used as trunk ports.
DSL1(config)#interface fastEthernet 0/6
DSL1(config-if)#switchport mode access
DSL1(config-if)#switchport access vlan 100

DSL2(config)#interface fastEthernet 0/6
DSL2(config-if)#switchport mode access
DSL2(config-if)#switchport access vlan 110
DSL2(config-if)#no shutdown

ASL1(config)#interface fastEthernet 0/6
ASL1(config-if)#switchport mode access
ASL1(config-if)#switchport access vlan 120

ASL2(config)#interface fastEthernet 0/6
ASL2(config-if)#switchport mode access
ASL2(config-if)#switchport access vlan 120


All Switch:
All Switch#show vlan

Step 9
Naming VLANs can help network administrators identify the functionality of those VLANs.
DLS1:
SL1(config)#vlan 100
DSL1(config-vlan)#name Server-Farm-1
DSL1(config-vlan)#vlan 110
DSL1(config-vlan)#name Server-Farm-2
DSL1(config-vlan)#vlan 120
DSL1(config-vlan)#name Net-Eng

All Switch:
All Switch#show vlan


Final Configurations
DLS1:
hostname DSL1
!
no ip domain-lookup
!
interface FastEthernet0/6
 switchport access vlan 100
 switchport mode access
!
interface FastEthernet0/7
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface FastEthernet0/8
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface FastEthernet0/9
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface FastEthernet0/10
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface FastEthernet0/11
 switchport trunk encapsulation isl
 switchport mode trunk
!
interface FastEthernet0/12
 switchport trunk encapsulation isl
 switchport mode trunk
!
interface Vlan1
 ip address 10.1.1.101 255.255.255.0
 no shutdown
!
line con 0
 exec-timeout 0 0
 logging synchronous
!
end

DLS2:
hostname DSL2
!
no ip domain-lookup
!
interface FastEthernet0/6
 switchport access vlan 110
 switchport mode access
!
interface FastEthernet0/7
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface FastEthernet0/8
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface FastEthernet0/9
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface FastEthernet0/10
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface FastEthernet0/11
 switchport trunk encapsulation isl
 switchport mode trunk
!
interface FastEthernet0/12
 switchport trunk encapsulation isl
 switchport mode trunk
!
interface Vlan1
 ip address 10.1.1.102 255.255.255.0
 no shutdown
!
line con 0
 exec-timeout 0 0
 logging synchronous
!
end

ALS1:
hostname ASL1
!
no ip domain-lookup
!
no ip routing
!
interface FastEthernet0/6
 switchport access vlan 120
 switchport mode access
!
interface FastEthernet0/7
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface FastEthernet0/8
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface FastEthernet0/9
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface FastEthernet0/10
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface FastEthernet0/11
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface FastEthernet0/12
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface Vlan1
 ip address 10.1.1.103 255.255.255.0
 no shutdown
!
line con 0
 exec-timeout 0 0
 logging synchronous
!
end

ALS2:
hostname ASL2
!
no ip domain-lookup
!
no ip routing
!
interface FastEthernet0/6
 switchport access vlan 120
 switchport mode access
!
interface FastEthernet0/7
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface FastEthernet0/8
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface FastEthernet0/9
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface FastEthernet0/10
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface FastEthernet0/11
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface FastEthernet0/12
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface Vlan1
 ip address 10.1.1.104 255.255.255.0
 no shutdown
!
line con 0
 exec-timeout 0 0
 logging synchronous
!
end


Reference:
Cisco Networking Academy
http://www.cisco.com/web/learning/netacad/index.html

CCNP Version 5.0: Building Multilayer Switched Networks
Student Lab Manual


最初發表 / 最後更新: 2008.10.04 / 2018.06.07

0 comments:

張貼留言