Published 6月 12, 2018 by with 0 comment

CCNP-BCMSN-v5.0 Lab 3-5: Configuring Etherchannel



!!!I used real Cisco 3550 switch *4 to do this lab. I did not use Dynamips to do this lab.!!!


Objective:
The purpose of this lab is to configure and observe Etherchannel.

Scenario:
Etherchannel allows up to eight redundant links to be bundled together
into one logical link.


Basic Configuration:
DLS(1.2) & ALS(1,2):
enable
configure terminal
!
no ip domain lookup
!
line console 0
 logging synchronous
 exec-timeout 0 0
!
hostname


Step 1
Start by deleting the vlan.dat file, erasing the startup config, and reloading all your switches.
Configure ports f0/7 through f0/12 to be trunks.
All Switches:
Clearing all Switches

ALLSwitches(config)#interface range fastEthernet 0/7 - 12
ALLSwitches(config-if-range)#switchport trunk encapsulation dot1q
ALLSwitches(config-if-range)#switchport mode trunk


Step 2
The first Etherchannel we create for this lab is aggregating ports f0/11 and
f0/12 between ALS1 and ALS2.
ASL1(config)#interface range fastEthernet 0/11 - 12
ASL1(config-if-range)#channel-group 1 mode desirable
ASL1(config-if-range)#exit
ASL1(config)#interface port-channel 1
ASL1(config-if)#switchport trunk encapsulation dot1q
ASL1(config-if)#switchport mode trunk

ASL2(config)#interface range fastEthernet 0/11 - 12
ASL2(config-if-range)#channel-group 1 mode desirable
ASL2(config-if-range)#exit
ASL2(config)#interface port-channel 1
ASL2(config-if)#switchport trunk encapsulation dot1q
ASL2(config-if)#switchport mode trunk

ASL1#show etherchannel summary
Flags:  D - down        P - bundled in port-channel
        I - stand-alone s - suspended
        H - Hot-standby (LACP only)
        R - Layer3      S - Layer2
        U - in use      f - failed to allocate aggregator

        M - not in use, minimum links not met
        u - unsuitable for bundling
        w - waiting to be aggregated
        d - default port


Number of channel-groups in use: 1
Number of aggregators:           1

Group  Port-channel  Protocol    Ports
------+-------------+-----------+-----------------------------------------------
1      Po1(SU)         PAgP      Fa0/11(P)   Fa0/12(P) 

ASL1#
ASL1#show interfaces trunk

Port        Mode             Encapsulation  Status        Native vlan
Fa0/7       on               802.1q         trunking      1
Fa0/8       on               802.1q         trunking      1
Fa0/9       on               802.1q         trunking      1
Fa0/10      on               802.1q         trunking      1
Po1         on               802.1q         trunking      1



ASL1#show spanning-tree

VLAN0001
  Spanning tree enabled protocol ieee
  Root ID    Priority    32769
             Address     000e.d7a6.9c80
             Cost        19
             Port        7 (FastEthernet0/7)
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    32769  (priority 32768 sys-id-ext 1)
             Address     000e.d7a6.c500
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time 300

Interface           Role Sts Cost      Prio.Nbr Type
------------------- ---- --- --------- -------- --------------------------------
Fa0/7               Root FWD 19        128.7    P2p
Fa0/8               Altn BLK 19        128.8    P2p
Fa0/9               Altn BLK 19        128.9    P2p
Fa0/10              Altn BLK 19        128.10   P2p
Po1                 Desg FWD 12        128.65   P2p

ASL1#

ASL2#show etherchannel summary
Flags:  D - down        P - bundled in port-channel
        I - stand-alone s - suspended
        H - Hot-standby (LACP only)
        R - Layer3      S - Layer2
        U - in use      f - failed to allocate aggregator

        M - not in use, minimum links not met
        u - unsuitable for bundling
        w - waiting to be aggregated
        d - default port


Number of channel-groups in use: 1
Number of aggregators:           1

Group  Port-channel  Protocol    Ports
------+-------------+-----------+-----------------------------------------------
1      Po1(SU)         PAgP      Fa0/11(P)   Fa0/12(P) 

ASL2#


Step 3
Configure the link between DLS1 and ALS1 on ports f0/7 and f0/8
to be a LACP Etherchannel.
DSL1(config)#interface range fastEthernet 0/7 - 8
DSL1(config-if-range)#channel-group 3 mode active
DSL1(config-if-range)#exit
DSL1(config)#interface port-channel 3
DSL1(config-if)#switchport trunk encapsulation dot1q
DSL1(config-if)#switchport mode trunk

ASL1(config)#interface range fastEthernet 0/7 - 8
ASL1(config-if-range)#channel-group 3 mode active
ASL1(config-if-range)#exit
ASL1(config)#interface port-channel 3
ASL1(config-if)#switchport trunk encapsulation dot1q
ASL1(config-if)#switchport mode trunk

ASL1#show etherchannel summary
ASL1#show spanning-tree
ASL1#show interfaces trunk   


Step 4
We can also configure Etherchannels as Layer 3 (routed) connections
on switches that can support it. Since DLS1 and DLS2 are both multilayer
switches, they can support routed ports.
DSL1(config)#interface range fastEthernet 0/11 - 12
DSL1(config-if-range)#no switchport
DSL1(config-if-range)#channel-group 2 mode desirable
DSL1(config-if-range)#exit
DSL1(config)#interface port-channel 2
DSL1(config-if)#no switchport
DSL1(config-if)#ip address 10.0.0.1 255.255.255.0

DSL2(config)#interface range fastEthernet 0/11 - 12
DSL2(config-if-range)#no switchport
DSL2(config-if-range)#channel-group 1 mode desirable
DSL2(config-if-range)#exit
DSL2(config)#interface port-channel 1
DSL2(config-if)#no switchport
DSL2(config-if)#ip address 10.0.0.2 255.255.255.0

DSL1#ping 10.0.0.2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.0.0.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/3/4 ms
DSL1#

DSL1#show etherchannel summary
Flags:  D - down        P - bundled in port-channel
        I - stand-alone s - suspended
        H - Hot-standby (LACP only)
        R - Layer3      S - Layer2
        U - in use      f - failed to allocate aggregator

        M - not in use, minimum links not met
        u - unsuitable for bundling
        w - waiting to be aggregated
        d - default port


Number of channel-groups in use: 2
Number of aggregators:           2

Group  Port-channel  Protocol    Ports
------+-------------+-----------+-----------------------------------------------
2      Po2(RU)         PAgP      Fa0/11(P)   Fa0/12(P) 
3      Po3(SU)         LACP      Fa0/7(P)    Fa0/8(P)  

DSL1#


Step 5
The switches can use different methods to load balance traffic going
through a port channel.
DSL1#show etherchannel load-balance
EtherChannel Load-Balancing Configuration:
        src-mac

EtherChannel Load-Balancing Addresses Used Per-Protocol:
Non-IP: Source MAC address
  IPv4: Source MAC address

DSL1#

For this scenario, we configure ALS1 to load balance by destination MAC address.
ASL1(config)#port-channel load-balance dst-mac.

ASL1#show etherchannel load-balance
EtherChannel Load-Balancing Configuration:
        dst-mac

EtherChannel Load-Balancing Addresses Used Per-Protocol:
Non-IP: Destination MAC address
  IPv4: Destination MAC address

ASL1#


Final Configurations
DLS1:
hostname DSL1
!
no ip domain-lookup
!
interface Port-channel2
 no switchport
 ip address 10.0.0.1 255.255.255.0
!
interface Port-channel3
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface FastEthernet0/7
 switchport trunk encapsulation dot1q
 switchport mode trunk
 channel-group 3 mode active
!
interface FastEthernet0/8
 switchport trunk encapsulation dot1q
 switchport mode trunk
 channel-group 3 mode active
!
interface FastEthernet0/9
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface FastEthernet0/10
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface FastEthernet0/11
 no switchport
 no ip address
 channel-group 2 mode desirable
!
interface FastEthernet0/12
 no switchport
 no ip address
 channel-group 2 mode desirable
!
line con 0
 exec-timeout 0 0
 logging synchronous
!
end

DSL1#

DLS2:
hostname DSL2
!
no ip domain-lookup
!
interface Port-channel1
 no switchport
 ip address 10.0.0.2 255.255.255.0
!
interface FastEthernet0/7
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface FastEthernet0/8
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface FastEthernet0/9
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface FastEthernet0/10
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface FastEthernet0/11
 no switchport
 no ip address
 channel-group 1 mode desirable
!       
interface FastEthernet0/12
 no switchport
 no ip address
 channel-group 1 mode desirable
!
line con 0
 exec-timeout 0 0
 logging synchronous
!
end

ASL1:
hostname ASL1
!
no ip domain-lookup
!
port-channel load-balance dst-mac
!
interface Port-channel1
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface Port-channel3
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface FastEthernet0/7
 switchport trunk encapsulation dot1q
 switchport mode trunk
 channel-group 3 mode active
!
interface FastEthernet0/8
 switchport trunk encapsulation dot1q
 switchport mode trunk
 channel-group 3 mode active
!
interface FastEthernet0/9
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface FastEthernet0/10
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface FastEthernet0/11
 switchport trunk encapsulation dot1q
 switchport mode trunk
 channel-group 1 mode desirable
!
interface FastEthernet0/12
 switchport trunk encapsulation dot1q
 switchport mode trunk
 channel-group 1 mode desirable
!
line con 0
 exec-timeout 0 0
 logging synchronous
!
end


ALS2:
hostname ASL2
!
no ip domain-lookup
!
interface Port-channel1
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface FastEthernet0/7
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface FastEthernet0/8
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface FastEthernet0/9
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface FastEthernet0/10
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface FastEthernet0/11
 switchport trunk encapsulation dot1q
 switchport mode trunk
 channel-group 1 mode desirable
!
line con 0
 exec-timeout 0 0
 logging synchronous
!
end


Reference:
Cisco Networking Academy
http://www.cisco.com/web/learning/netacad/index.html

CCNP Version 5.0: Building Multilayer Switched Networks
Student Lab Manual


最初發表 / 最後更新: 2008.10.09 / 2018.06.12

0 comments:

張貼留言