!!!I use real Cisco 3550 switch *4 to do this lab. I do not use Dynamips to do this lab.!!!
Objective:
The purpose of this lab is to observe what happens when the default spanning tree behavior is modified.
Scenario:
In this lab, you will see what happens when the default spanning tree behavior is modified.
Basic Configuration:
DLS(1-2) & ALS(1-2):
enable
configure terminal
!
no ip domain lookup
!
line console 0
logging synchronous
exec-timeout 0 0
!
hostname
Step 1
Start by deleting the vlan.dat file, erasing the startup config, and reloading all your switches.
All Switch:
Clearing all Switches
Step 2
Use the "show spanning-tree" command to check how your nonconfigured
switches created a spanning tree. Verify which switch became
the root bridge. In the topology used in this lab, DLS1 is the root bridge.
DLS1:
DSL1#show spanning-tree
VLAN0001
Spanning tree enabled protocol ieee
Root ID Priority 32769
Address 000e.d7a6.9c80
This bridge is the root
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Bridge ID Priority 32769 (priority 32768 sys-id-ext 1)
Address 000e.d7a6.9c80
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Aging Time 300
Interface Role Sts Cost Prio.Nbr Type
------------------- ---- --- --------- -------- --------------------------------
Fa0/7 Desg FWD 19 128.7 P2p
Fa0/8 Desg FWD 19 128.8 P2p
Fa0/9 Desg FWD 19 128.9 P2p
Fa0/10 Desg FWD 19 128.10 P2p
Fa0/11 Desg FWD 19 128.11 P2p
Fa0/12 Desg FWD 19 128.12 P2p
DSL1#s
DLS2:
DSL2#show spanning-tree
VLAN0001
Spanning tree enabled protocol ieee
Root ID Priority 32769
Address 000e.d7a6.9c80
Cost 19
Port 11 (FastEthernet0/11)
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Bridge ID Priority 32769 (priority 32768 sys-id-ext 1)
Address 000e.d7a6.ab00
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Aging Time 300
Interface Role Sts Cost Prio.Nbr Type
------------------- ---- --- --------- -------- --------------------------------
Fa0/7 Desg FWD 19 128.7 P2p
Fa0/8 Desg FWD 19 128.8 P2p
Fa0/9 Desg FWD 19 128.9 P2p
Fa0/10 Desg FWD 19 128.10 P2p
Fa0/11 Root FWD 19 128.11 P2p
Fa0/12 Altn BLK 19 128.12 P2p
DSL2#
ALS1:
ASL1#show spanning-tree
VLAN0001
Spanning tree enabled protocol ieee
Root ID Priority 32769
Address 000e.d7a6.9c80
Cost 19
Port 7 (FastEthernet0/7)
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Bridge ID Priority 32769 (priority 32768 sys-id-ext 1)
Address 000e.d7a6.c500
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Aging Time 300
Interface Role Sts Cost Prio.Nbr Type
------------------- ---- --- --------- -------- --------------------------------
Fa0/7 Root FWD 19 128.7 P2p
Fa0/8 Altn BLK 19 128.8 P2p
Fa0/9 Altn BLK 19 128.9 P2p
Fa0/10 Altn BLK 19 128.10 P2p
Fa0/11 Desg FWD 19 128.11 P2p
Fa0/12 Desg FWD 19 128.12 P2p
ASL1#
ALS2:
ASL2#show spanning-tree
VLAN0001
Spanning tree enabled protocol ieee
Root ID Priority 32769
Address 000e.d7a6.9c80
Cost 19
Port 9 (FastEthernet0/9)
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Bridge ID Priority 32769 (priority 32768 sys-id-ext 1)
Address 000e.d7d4.7500
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Aging Time 300
Interface Role Sts Cost Prio.Nbr Type
------------------- ---- --- --------- -------- --------------------------------
Fa0/7 Altn BLK 19 128.7 P2p
Fa0/8 Altn BLK 19 128.8 P2p
Fa0/9 Root FWD 19 128.9 P2p
Fa0/10 Altn BLK 19 128.10 P2p
Fa0/11 Altn BLK 19 128.11 P2p
Fa0/12 Altn BLK 19 128.12 P2p
ASL2#
Step 3
Because DLS1 is the root switch in this topology, we
change DLS2 to the primary root and ALS1 to the secondary.
First, debug DLS1:
DSL1:
DSL1#debug spanning-tree events
Then change DLS2 to the primary root:
DSL2(config)#spanning-tree vlan 1 root primary
Then change ALS1 to the secondary root:
ASL1(config)#spanning-tree vlan 1 root secondary
You can see the topology changes on the switch that you enabled
debugging on.
DSL1#debug spanning-tree events
Spanning Tree event debugging is on
*Mar 1 00:10:12.519: STP: VLAN0001 heard root 24577-000e.d7a6.ab00 on Fa0/11
*Mar 1 00:10:12.519: supersedes 32769-000e.d7a6.9c80
*Mar 1 00:10:12.519: STP: VLAN0001 new root is 24577, 000e.d7a6.ab00 on port Fa0/11, cost 19
*Mar 1 00:10:12.523: STP: VLAN0001 sent Topology Change Notice on Fa0/11
*Mar 1 00:10:12.523: STP: VLAN0001 Fa0/12 -> blocking
*Mar 1 00:10:56.523: STP: VLAN0001 sent Topology Change Notice on Fa0/11
*Mar 1 00:10:56.523: STP: VLAN0001 Fa0/7 -> blocking
*Mar 1 00:10:56.523: STP: VLAN0001 Fa0/8 -> blocking
DSL1#
DSL2#show running-config | include spanning-tree vlan 1
spanning-tree vlan 1 priority 24576
ASL1#show running-config | include spanning-tree vlan 1
spanning-tree vlan 1 priority 28672
DSL1#show spanning-tree
VLAN0001
Spanning tree enabled protocol ieee
Root ID Priority 24577
Address 000e.d7a6.ab00
Cost 19
Port 11 (FastEthernet0/11)
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Bridge ID Priority 32769 (priority 32768 sys-id-ext 1)
Address 000e.d7a6.9c80
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Aging Time 300
Interface Role Sts Cost Prio.Nbr Type
------------------- ---- --- --------- -------- --------------------------------
Fa0/7 Altn BLK 19 128.7 P2p
Fa0/8 Altn BLK 19 128.8 P2p
Fa0/9 Desg FWD 19 128.9 P2p
Fa0/10 Desg FWD 19 128.10 P2p
Fa0/11 Root FWD 19 128.11 P2p
Fa0/12 Altn BLK 19 128.12 P2p
Step 4
On the link between DLS1 and DLS2, the default forwarding port is
f0/11 because it is lower, and the default blocking port is
f0/12 because it is higher. The two ports have equal costs because they
are the same speed. We will look into modifying this later.
DLS1:
DSL1#show spanning-tree
VLAN0001
Spanning tree enabled protocol ieee
Root ID Priority 24577
Address 000e.d7a6.ab00
Cost 19
Port 11 (FastEthernet0/11)
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Bridge ID Priority 32769 (priority 32768 sys-id-ext 1)
Address 000e.d7a6.9c80
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Aging Time 300
Interface Role Sts Cost Prio.Nbr Type
------------------- ---- --- --------- -------- --------------------------------
Fa0/7 Altn BLK 19 128.7 P2p
Fa0/8 Altn BLK 19 128.8 P2p
Fa0/9 Desg FWD 19 128.9 P2p
Fa0/10 Desg FWD 19 128.10 P2p
Fa0/11 Root FWD 19 128.11 P2p
Fa0/12 Altn BLK 19 128.12 P2p
DSL1#
Port priorities range from 0 to 240, in increments of 16. The default priority
is 128, and a lower priority is preferred
DSL2(config)#interface fastEthernet 0/12
DSL2(config-if)#spanning-tree port-priority 112
DSL2#show spanning-tree
VLAN0001
Spanning tree enabled protocol ieee
Root ID Priority 24577
Address 000e.d7a6.ab00
This bridge is the root
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Bridge ID Priority 24577 (priority 24576 sys-id-ext 1)
Address 000e.d7a6.ab00
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Aging Time 300
Interface Role Sts Cost Prio.Nbr Type
------------------- ---- --- --------- -------- --------------------------------
Fa0/7 Desg FWD 19 128.7 P2p
Fa0/8 Desg FWD 19 128.8 P2p
Fa0/9 Desg FWD 19 128.9 P2p
Fa0/10 Desg FWD 19 128.10 P2p
Fa0/11 Desg FWD 19 128.11 P2p
Fa0/12 Desg FWD 19 112.12 P2p
DSL2#
DSL1#show spanning-tree
VLAN0001
Spanning tree enabled protocol ieee
Root ID Priority 24577
Address 000e.d7a6.ab00
Cost 19
Port 12 (FastEthernet0/12)
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Bridge ID Priority 32769 (priority 32768 sys-id-ext 1)
Address 000e.d7a6.9c80
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Aging Time 300
Interface Role Sts Cost Prio.Nbr Type
------------------- ---- --- --------- -------- --------------------------------
Fa0/7 Altn BLK 19 128.7 P2p
Fa0/8 Altn BLK 19 128.8 P2p
Fa0/9 Desg FWD 19 128.9 P2p
Fa0/10 Desg FWD 19 128.10 P2p
Fa0/11 Altn BLK 19 128.11 P2p
Fa0/12 Root FWD 19 128.12 P2p
DSL1#
Step 5
Portfast allows you to bypass the normal phases of spanning tree
and move a port to the forwarding state as soon as it is turned on.
ASL1(config)#interface fastEthernet 0/6
ASL1(config-if)#switchport mode access
ASL1(config-if)#spanning-tree portfast
%Warning: portfast should only be enabled on ports connected to a single
host. Connecting hubs, concentrators, switches, bridges, etc... to this
interface when portfast is enabled, can cause temporary bridging loops.
Use with CAUTION
%Portfast has been configured on FastEthernet0/6 but will only
have effect when the interface is in a non-trunking mode.
ASL1(config-if)#
Step 6
For this scenario, I am changing the cost of ports f0/11 and 12 on ALS1 and ALS2.
ASL1#show spanning-tree
VLAN0001
Spanning tree enabled protocol ieee
Root ID Priority 24577
Address 000e.d7a6.ab00
Cost 19
Port 9 (FastEthernet0/9)
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Bridge ID Priority 28673 (priority 28672 sys-id-ext 1)
Address 000e.d7a6.c500
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Aging Time 300
Interface Role Sts Cost Prio.Nbr Type
------------------- ---- --- --------- -------- --------------------------------
Fa0/7 Desg FWD 19 128.7 P2p
Fa0/8 Desg FWD 19 128.8 P2p
Fa0/9 Root FWD 19 128.9 P2p
Fa0/10 Altn BLK 19 128.10 P2p
Fa0/11 Desg FWD 19 128.11 P2p
Fa0/12 Desg FWD 19 128.12 P2p
ASL1#
ASL2#show spanning-tree
VLAN0001
Spanning tree enabled protocol ieee
Root ID Priority 24577
Address 000e.d7a6.ab00
Cost 19
Port 7 (FastEthernet0/7)
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Bridge ID Priority 32769 (priority 32768 sys-id-ext 1)
Address 000e.d7d4.7500
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Aging Time 300
Interface Role Sts Cost Prio.Nbr Type
------------------- ---- --- --------- -------- --------------------------------
Fa0/7 Root FWD 19 128.7 P2p
Fa0/8 Altn BLK 19 128.8 P2p
Fa0/9 Altn BLK 19 128.9 P2p
Fa0/10 Altn BLK 19 128.10 P2p
Fa0/11 Altn BLK 19 128.11 P2p
Fa0/12 Altn BLK 19 128.12 P2p
ASL2#
Now, change the port cost to 10 on both ALS1 and ALS2:
ASL1(config)#interface range fastEthernet 0/11 - 12
ASL1(config-if-range)#spanning-tree cost 10
ASL2(config)#interface range fastEthernet 0/11 - 12
ASL2(config-if-range)#spanning-tree cost 10
ASL1#show spanning-tree
VLAN0001
Spanning tree enabled protocol ieee
Root ID Priority 24577
Address 000e.d7a6.ab00
Cost 19
Port 9 (FastEthernet0/9)
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Bridge ID Priority 28673 (priority 28672 sys-id-ext 1)
Address 000e.d7a6.c500
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Aging Time 300
Interface Role Sts Cost Prio.Nbr Type
------------------- ---- --- --------- -------- --------------------------------
Fa0/7 Desg FWD 19 128.7 P2p
Fa0/8 Desg FWD 19 128.8 P2p
Fa0/9 Root FWD 19 128.9 P2p
Fa0/10 Altn BLK 19 128.10 P2p
Fa0/11 Desg FWD 10 128.11 P2p
Fa0/12 Desg FWD 10 128.12 P2p
ASL1#
ASL2#show spanning-tree
VLAN0001
Spanning tree enabled protocol ieee
Root ID Priority 24577
Address 000e.d7a6.ab00
Cost 19
Port 7 (FastEthernet0/7)
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Bridge ID Priority 32769 (priority 32768 sys-id-ext 1)
Address 000e.d7d4.7500
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Aging Time 300
Interface Role Sts Cost Prio.Nbr Type
------------------- ---- --- --------- -------- --------------------------------
Fa0/7 Root FWD 19 128.7 P2p
Fa0/8 Altn BLK 19 128.8 P2p
Fa0/9 Altn BLK 19 128.9 P2p
Fa0/10 Altn BLK 19 128.10 P2p
Fa0/11 Altn BLK 10 128.11 P2p
Fa0/12 Altn BLK 10 128.12 P2p
ASL2#
Final Configurations
DLS1:
hostname DSL1
!
no ip domain-lookup
!
line con 0
exec-timeout 0 0
logging synchronous
!
end
DLS2:
hostname DSL2
!
no ip domain-lookup
!
spanning-tree vlan 1 priority 24576
!
line con 0
exec-timeout 0 0
logging synchronous
!
end
ALS1:
hostname ASL1
!
no ip domain-lookup
!
spanning-tree vlan 1 priority 28672
!
interface FastEthernet0/6
switchport mode access
spanning-tree portfast
!
interface FastEthernet0/11
spanning-tree cost 10
!
interface FastEthernet0/12
spanning-tree cost 10
!
line con 0
exec-timeout 0 0
logging synchronous
!
end
ALS2:
hostname ASL2
!
no ip domain-lookup
!
interface FastEthernet0/11
spanning-tree cost 10
!
interface FastEthernet0/12
spanning-tree cost 10
!
line con 0
exec-timeout 0 0
logging synchronous
!
end
Reference:
Cisco Networking Academy
http://www.cisco.com/web/learning/netacad/index.html
CCNP Version 5.0: Building Multilayer Switched Networks
Student Lab Manual
最初發表 / 最後更新: 2008.10.06 / 2018.06.07
0 comments:
張貼留言