Published 6月 14, 2018 by with 0 comment

CCNP-ONT-v5.0 Lab 4.4: Comparing Queuing Strategies


Lab4-4.net file for Dynamips:

##################################################
#
# CCNP Version 5.0: Optimizing Converged Cisco Networks
# Lab 4.4 Comparing Queuing Strategies
# By Happy Peter  http://blog.xuite.net/juilin77/happy
#
##################################################

autostart=false
[localhost:7200]
workingdir = /opt/dynamips/dynagen-0.11.0/UTS/CCNP4/lab4-4/workingconfig/

[[2621]]
 # Specify 2621 IOS image on Linux here:
 image = /opt/dynamips/images/C2600-TS.BIN
 ram = 128
 # Choose an idlepc value from the below
 idlepc = 0x803f37cc
 mmap = true
 ghostios = true
 confreg = 0x2102

[[3725]]
# Specify 3725 IOS image on Linux here:
 image = /opt/dynamips/images/c3725-ad.bin
 ram = 256
 idlepc = 0x60bf8d58
 mmap = true
 ghostios = true
 confreg = 0x2102

###########################
#
# Define router instances 1
#
###########################

 [[Router R1]]
  model = 3725
  console = 2001
  slot1 = NM-4T
  s1/0 = R2 s1/0

 [[Router R2]]
  model = 3725
  console = 2002
  slot1 = NM-4T

 [[Router TGN]]
  # tgn: 407554012371
  model = 2621
  console = 2003
  f0/0 = R1 f0/0
  f0/1 = R2 f0/0



Learning Objectives
‧ Implement FIFO, WFQ, CQ, and PQ queuing strategies
‧ Compare queuing strategies using the NQR tool


Preparation:

TGN(config)#interface fastEthernet 0/0
TGN(config-if)#ip address 172.16.10.4 255.255.255.0
TGN(config-if)#no shutdown

TGN(config)#interface fastEthernet 0/1
TGN(config-if)#ip address 172.16.20.4 255.255.255.0
TGN(config-if)#no shutdown

TGN to start generating traffic.
TGN#nqr

Loading these configurations:
fastethernet0/0
add tcp
send 1000
rate 60
length random 200 to 1000
l2-dest $R1_MAC$
l3-src 172.16.10.4
l3-dest 172.16.20.4
l4-dest 23
fastethernet0/1 capture
add clone-of 1
l4-dest 21
add clone-of 1
l4-dest 119
add clone-of 1
l4-dest 22
add clone-of 1
l4-dest 6000


Step 1: Configure the Physical Interfaces and Configure EIGRP AS 1

R1(config)#interface fastEthernet 0/0
R1(config-if)#ip address 172.16.10.1 255.255.255.0
R1(config-if)#speed 100
R1(config-if)#duplex full
R1(config-if)#no shutdown

R1(config)#interface serial 1/0
R1(config-if)#ip address 172.16.12.1 255.255.255.0
R1(config-if)#bandwidth 800
R1(config-if)#clock rate 806400
R1(config-if)#no shutdown

R2(config)#interface serial 1/0
R2(config-if)#ip address 172.16.12.2 255.255.255.0
R2(config-if)#bandwidth 800
R2(config-if)#no shutdown

R2(config)#interface fastEthernet 0/0
R2(config-if)#ip address 172.16.20.2 255.255.255.0
R2(config-if)#speed 100
R2(config-if)#duplex full
R2(config-if)#no shutdown

R1(config)#router eigrp 1
R1(config-router)#network 172.16.0.0 
R1(config-router)#no auto-summary

R2(config)#router eigrp 1
R2(config-router)#network 172.16.0.0
R2(config-router)#no auto-summary


Step 2: Create NQR Configuration for Testing Purposes
On R4, issue the nqr command in privileged EXEC mode to enter NQR configuration mode.

TGN#nqr
TGN(NQR:OFF,Fa0/0:6/6)#fastethernet0/0
TGN(NQR:OFF,Fa0/0:6/6)#add tcp
TGN(NQR:OFF,Fa0/0:7/7)#send 1000
TGN(NQR:OFF,Fa0/0:7/7)#rate 60
TGN(NQR:OFF,Fa0/0:7/7)#length random 200 to 1000
TGN(NQR:OFF,Fa0/0:7/7)#l2-dest c200.1b8b.0000
TGN(NQR:OFF,Fa0/0:7/7)#l3-src 172.16.10.4
TGN(NQR:OFF,Fa0/0:7/7)#l3-dest 172.16.20.4
TGN(NQR:OFF,Fa0/0:7/7)#l4-dest 23
TGN(NQR:OFF,Fa0/0:7/7)#fastethernet0/1 capture
TGN(NQR:OFF,Fa0/0:7/7)#add clone-of 1
TGN(NQR:OFF,Fa0/0:8/8)#l4-dest 21
TGN(NQR:OFF,Fa0/0:8/8)#add clone-of 1
TGN(NQR:OFF,Fa0/0:9/9)#l4-dest 119
TGN(NQR:OFF,Fa0/0:9/9)#add clone-of 1
TGN(NQR:OFF,Fa0/0:10/10)#l4-dest 22
TGN(NQR:OFF,Fa0/0:10/10)#add clone-of 1
TGN(NQR:OFF,Fa0/0:11/11)#l4-dest 6000
TGN(NQR:OFF,Fa0/0:11/11)#

To begin NQR testing, issue either the start send command in NQR configuration mode or the nqr start send command from privileged EXEC mode. Time will pass, and then the router will inform you when all packets have been sent. There is no need to stop the streams since they will stop on their own.

!!!! Before starting send the traffic, restart the R2 F0/0 every time. The R2 F0/0 will be automaticed shutdown.!!!!
R2(config)#interface fastEthernet 0/0
R2(config-if)#shutdown
R2(config-if)#no shutdown

TGN(NQR:OFF,Fa0/0:11/11)#start send
TGN(NQR:SEND,Fa0/0:11/11)#

   Send process complete.

TGN(NQR:WAIT,Fa0/0:11/11)#
TGN(NQR:OFF,Fa0/0:11/11)#

Finally, issue the show pkt-seq-drop-stats, show delay, and show jitter NQR commands to display drop/resequencing, delay, and jitter statistics, respectively.

TGN(NQR:OFF,Fa0/0:5/5)#show pkt-seq-drop-stats

Summary of packet sequence/drop stats of traffic streams
    ts#   template interface      sent     recvd   dropped   out-of-seq  max-seq
    1     TCP      Fa0/0          1000        18       982            0       18
    2     TCP      Fa0/0          1000        17       983            0       17
    3     TCP      Fa0/0          1000        17       983            0       17
    4     TCP      Fa0/0          1000        17       983            0       17
    5     TCP      Fa0/0          1000        18       982            0       18

TGN(NQR:OFF,Fa0/0:5/5)#show delay-stats      

Summary of delay-stats of traffic streams
   ts#    template interface    min-delay    max-delay    avg-delay  stdev-delay
    1     TCP      Fa0/0         0.000000     0.091999     0.043999     0.028383
    2     TCP      Fa0/0         0.000000     0.099999     0.048469     0.030327
    3     TCP      Fa0/0         0.011999     0.095999     0.049410     0.027529
    4     TCP      Fa0/0         0.000000     0.095999     0.055057     0.031353
    5     TCP      Fa0/0         0.007999     0.099999     0.047554     0.030521

TGN(NQR:OFF,Fa0/0:5/5)#show jitter-stats     

Summary of jitter-stats of traffic streams
   ts#    template interface   min-jitter   max-jitter   avg-jitter stdev-jitter
    1     TCP      Fa0/0         0.003500     0.082667     0.022617     0.022755
    2     TCP      Fa0/0         0.003999     0.094667     0.024290     0.024464
    3     TCP      Fa0/0         0.002666     0.081334     0.022936     0.020945
    4     TCP      Fa0/0         0.000000     0.084000     0.027945     0.021480
    5     TCP      Fa0/0         0.000000     0.089000     0.023963     0.023775

TGN(NQR:OFF,Fa0/0:5/5)#


Step 3: Test FIFO Queuing
This lab will compare four different queuing types. The first type is the most basic, FIFO queuing.
Configure FIFO queuing on the serial interface on R1. Recall that disabling all other queuing strategies on an interface will enable FIFO queuing.

R1(config)#interface serial 1/0
R1(config-if)#no fair-queue


Step 4: Test Weighted Fair Queuing
Enable WFQ on the serial interface. Run the NQR streams again using nqr start send and compare the results of the show commands.
R2(config)#interface fastEthernet 0/0
R2(config-if)#shutdown
R2(config-if)#no shutdown

TGN(NQR:OFF,Fa0/0:5/5)#start send

TGN(NQR:OFF,Fa0/0:5/5)#show pkt-seq-drop-stats

Summary of packet sequence/drop stats of traffic streams
    ts#   template interface      sent     recvd   dropped   out-of-seq  max-seq
    1     TCP      Fa0/0          1000        19       981            0       19
    2     TCP      Fa0/0          1000        18       982            0       18
    3     TCP      Fa0/0          1000        19       981            1       18
    4     TCP      Fa0/0          1000        19       981            0       19
    5     TCP      Fa0/0          1000        19       981            0       19

TGN(NQR:OFF,Fa0/0:5/5)#show delay-stats      

Summary of delay-stats of traffic streams
   ts#    template interface    min-delay    max-delay    avg-delay  stdev-delay
    1     TCP      Fa0/0         0.000000     5.243959     0.283575     0.064091
    2     TCP      Fa0/0         0.000000     0.015999     0.007999     0.004752
    3     TCP      Fa0/0         0.003999    15.379881     0.819782     0.047799
    4     TCP      Fa0/0         0.000000     0.019999     0.007999     0.004422
    5     TCP      Fa0/0         0.000000     5.243959     0.285049     0.057108

TGN(NQR:OFF,Fa0/0:5/5)#show jitter-stats     

Summary of jitter-stats of traffic streams
   ts#    template interface   min-jitter   max-jitter   avg-jitter stdev-jitter
    1     TCP      Fa0/0         0.000000     5.235960     0.293696     0.030529
    2     TCP      Fa0/0         0.000250     0.012000     0.004603     0.002957
    3     TCP      Fa0/0         0.000000    15.368994     0.858182     0.046622
    4     TCP      Fa0/0         0.000235     0.012000     0.004261     0.002841
    5     TCP      Fa0/0         0.000000     5.234405     0.294862     0.059610

TGN(NQR:OFF,Fa0/0:5/5)#


Step 5: Test Custom Queuing
Configure custom queuing (CQ) on R1’s serial interface. Place each traffic stream in its own queue but do not customize any parameters of it. (The port numbers configured for the NQR streams are TCP ports 23, 21, 119, 22, and 6000).
R2(config)#interface fastEthernet 0/0
R2(config-if)#shutdown
R2(config-if)#no shutdown

R1(config)#queue-list 7 protocol ip 1 tcp 23
R1(config)#queue-list 7 protocol ip 2 tcp 21 
R1(config)#queue-list 7 protocol ip 3 tcp 119
R1(config)#queue-list 7 protocol ip 4 tcp 22
R1(config)#queue-list 7 protocol ip 5 tcp 6000
R1(config)#queue-list 7 default 6

R1(config)#interface serial 1/0
R1(config-if)#custom-queue-list 7

TGN(NQR:OFF,Fa0/0:5/5)#start send            
TGN(NQR:SEND,Fa0/0:5/5)#

   Send process complete.

TGN(NQR:WAIT,Fa0/0:5/5)#
TGN(NQR:OFF,Fa0/0:5/5)#show pkt-seq-drop-stats

Summary of packet sequence/drop stats of traffic streams
    ts#   template interface      sent     recvd   dropped   out-of-seq  max-seq
    1     TCP      Fa0/0          1000        17       983            1       17
    2     TCP      Fa0/0          1000        16       984            1       16
    3     TCP      Fa0/0          1000        16       984            1       16
    4     TCP      Fa0/0          1000        17       983            1       17
    5     TCP      Fa0/0          1000        18       982            1       18

TGN(NQR:OFF,Fa0/0:5/5)#show delay-stats      

Summary of delay-stats of traffic streams
   ts#    template interface    min-delay    max-delay    avg-delay  stdev-delay
    1     TCP      Fa0/0         0.007999     0.035999     0.019057     0.008891
    2     TCP      Fa0/0         0.007999     0.035999     0.023249     0.009602
    3     TCP      Fa0/0         0.007999     0.039999     0.022999     0.009633
    4     TCP      Fa0/0         0.007999     0.035999     0.019763     0.010046
    5     TCP      Fa0/0         0.007999     0.695994     0.059776     0.061766

TGN(NQR:OFF,Fa0/0:5/5)#show jitter-stats     

Summary of jitter-stats of traffic streams
   ts#    template interface   min-jitter   max-jitter   avg-jitter stdev-jitter
    1     TCP      Fa0/0         0.001333     0.018400     0.008301     0.004926
    2     TCP      Fa0/0         0.000400     0.023000     0.008252     0.006530
    3     TCP      Fa0/0         0.001000     0.021000     0.007921     0.006886
    4     TCP      Fa0/0         0.003000     0.024000     0.009045     0.006003
    5     TCP      Fa0/0         0.000363     0.673643     0.047359     0.017565

TGN(NQR:OFF,Fa0/0:5/5)#


Step 6: Test Priority Queuing
Configure priority queuing (PQ) on R1 on the serial interface facing R2. Assign one of the application protocols in use to the high priority queue, one to the medium queue, one to the normal queue, and make the low priority queue the default queue. Run the NQR streams and compare results as you did before.

R2(config)#interface fastEthernet 0/0
R2(config-if)#shutdown
R2(config-if)#no shutdown

R1(config)#priority-list 5 protocol ip high tcp 23
R1(config)#priority-list 5 protocol ip medium tcp 21
R1(config)#priority-list 5 protocol ip normal tcp 119
R1(config)#priority-list 5 default low

R1(config)#interface serial 1/0
R1(config-if)#no custom-queue-list 7
R1(config-if)#priority-group 5    

TGN(NQR:OFF,Fa0/0:5/5)#start send            
TGN(NQR:SEND,Fa0/0:5/5)#

   Send process complete.

TGN(NQR:WAIT,Fa0/0:5/5)#
TGN(NQR:OFF,Fa0/0:5/5)#show pkt-seq-drop-stats

Summary of packet sequence/drop stats of traffic streams
    ts#   template interface      sent     recvd   dropped   out-of-seq  max-seq
    1     TCP      Fa0/0          1000        16       984            1       16
    2     TCP      Fa0/0          1000        16       984            1       16
    3     TCP      Fa0/0          1000        16       984            1       16
    4     TCP      Fa0/0          1000        16       984            1       16
    5     TCP      Fa0/0          1000        18       982            1       18

TGN(NQR:OFF,Fa0/0:5/5)#show delay-stats      

Summary of delay-stats of traffic streams
   ts#    template interface    min-delay    max-delay    avg-delay  stdev-delay
    1     TCP      Fa0/0         0.011999     0.051999     0.028249     0.010272
    2     TCP      Fa0/0         0.011999     0.055999     0.026249     0.012390
    3     TCP      Fa0/0         0.015999     0.055999     0.029499     0.011673
    4     TCP      Fa0/0         0.011999     0.055999     0.027249     0.011885
    5     TCP      Fa0/0         0.011999    14.379889     0.824659     0.051143

TGN(NQR:OFF,Fa0/0:5/5)#show jitter-stats     

Summary of jitter-stats of traffic streams
   ts#    template interface   min-jitter   max-jitter   avg-jitter stdev-jitter
    1     TCP      Fa0/0         0.000000     0.029091     0.007833     0.007816
    2     TCP      Fa0/0         0.001333     0.037600     0.008600     0.010115
    3     TCP      Fa0/0         0.001600     0.033600     0.009304     0.008420
    4     TCP      Fa0/0         0.000800     0.034546     0.009280     0.008776
    5     TCP      Fa0/0         0.000000    14.352596     0.852336     0.064523

TGN(NQR:OFF,Fa0/0:5/5)#


Final Configurations:
R1:
hostname R1
!
no ip domain lookup
!
interface FastEthernet0/0
 ip address 172.16.10.1 255.255.255.0
 speed 100
 full-duplex
 no shutdown
!
interface Serial1/0
 bandwidth 800
 ip address 172.16.12.1 255.255.255.0
 priority-group 5
 clock rate 806400
 no shutdown
!
router eigrp 1
 network 172.16.0.0
 no auto-summary
!       
queue-list 7 protocol ip 1 tcp telnet
queue-list 7 protocol ip 2 tcp ftp
queue-list 7 protocol ip 3 tcp nntp
queue-list 7 protocol ip 4 tcp 22
queue-list 7 protocol ip 5 tcp 6000
queue-list 7 default 6
priority-list 5 protocol ip high tcp telnet
priority-list 5 protocol ip medium tcp ftp
priority-list 5 protocol ip normal tcp nntp
priority-list 5 default low
!
line con 0
 logging synchronous
!
line vty 0 4
 login
!
end

R2:
hostname R2
!
no ip domain lookup
!
interface FastEthernet0/0
 ip address 172.16.20.2 255.255.255.0
 speed 100
 full-duplex
 no shutdown
!
interface Serial1/0
 bandwidth 800
 ip address 172.16.12.2 255.255.255.0
 no shutdown
!
router eigrp 1
 network 172.16.0.0
 no auto-summary
!
line con 0
 logging synchronous
!
line vty 0 4
 login
!
end

TGN:
hostname TGN
!
no ip domain lookup
!
interface FastEthernet0/0
 ip address 172.16.10.4 255.255.255.0
 duplex auto
 speed auto
 no shutdown
!
interface FastEthernet0/1
 ip address 172.16.20.4 255.255.255.0
 duplex auto
 speed auto
 no shutdown
!
line con 0
 exec-timeout 0 0
 logging synchronous
!
line vty 0 4
 login
!
!
end


Reference:
Cisco Networking Academy
http://www.cisco.com/web/learning/netacad/index.html

CCNP Version 5.0: Optimizing Converged Cisco Networks
Student Lab Manual


最初發表 / 最後更新: 2009.04.12 / 2018.06.14

0 comments:

張貼留言