Published 6月 14, 2018 by with 0 comment

CCNP-ONT-v5.0 Lab 4.3: TCP Header Compression


Lab4-3.net file for Dynamips:

##################################################
#
# CCNP Version 5.0: Optimizing Converged Cisco Networks
# Lab 4.3 TCP Header Compression
# By Happy Peter  http://blog.xuite.net/juilin77/happy
#
##################################################

autostart=false
[localhost:7200]
workingdir = /opt/dynamips/dynagen-0.11.0/UTS/CCNP4/lab4-3/workingconfig/

[[3725]]
# Specify 3725 IOS image on Linux here:
 image = /opt/dynamips/images/c3725-ad.bin
 ram = 256
 idlepc = 0x60bf8d58
 mmap = true
 ghostios = true
 confreg = 0x2102

###########################
#
# Define router instances 1
#
###########################

 [[Router R1]]
  model = 3725
  console = 2001
  slot1 = NM-4T
  s1/0 = R2 s1/0

 [[Router R2]]
  model = 3725
  console = 2002
  slot1 = NM-4T



Learning Objectives
‧ Configure TCP header compression
‧ Verify TCP header compression


Step 1: Configure Addressing

R1(config)#interface serial 1/0
R1(config-if)#ip address 172.16.12.1 255.255.255.0
R1(config-if)#clock rate 64000
R1(config-if)#no shutdown

R2(config)#interface serial 1/0
R2(config-if)#ip address 172.16.12.2 255.255.255.0
R2(config-if)#no shutdown


Step 2: Enable Telnet Access on R2

R2(config)#enable secret cisco
R2(config)#line vty 0 4
R2(config-line)#logging synchronous
R2(config-line)#password cisco


Step 3: Enable TCP Header Compression

R1(config)#interface serial 1/0
R1(config-if)#ip tcp header-compression

R2(config)#interface serial 1/0
R2(config-if)#ip tcp header-compression


Step 4: Verify TCP Header Compression

R1#show ip tcp header-compression
TCP/IP header compression statistics:
  Interface Serial1/0 (compression on, VJ)
    Rcvd:    0 total, 0 compressed, 0 errors, 0 status msgs
             0 dropped, 0 buffer copies, 0 buffer failures
    Sent:    0 total, 0 compressed, 0 status msgs, 0 not predicted
             0 bytes saved, 0 bytes sent
    Connect: 16 rx slots, 16 tx slots,
             0 misses, 0 collisions, 0 negative cache hits, 16 free contexts

R1#

Generate some TCP traffic by connecting from R1 to R2 via Telnet.

R1#telnet 172.16.12.2
Trying 172.16.12.2 ... Open


User Access Verification

Password: cisco
R2>enable
Password: cisco
R2#exit

[Connection to 172.16.12.2 closed by foreign host]
R1#

Verify that the TCP traffic was compressed.

R1#show ip tcp header-compression
TCP/IP header compression statistics:
  Interface Serial1/0 (compression on, VJ)
    Rcvd:    24 total, 23 compressed, 0 errors, 0 status msgs
             0 dropped, 0 buffer copies, 0 buffer failures
    Sent:    35 total, 34 compressed, 0 status msgs, 0 not predicted
             1199 bytes saved, 249 bytes sent
             5.81 efficiency improvement factor
    Connect: 16 rx slots, 16 tx slots,
             1 misses, 0 collisions, 0 negative cache hits, 16 free contexts
             97% hit ratio, five minute miss rate 0 misses/sec, 0 max

R1#

R2#show ip tcp header-compression
TCP/IP header compression statistics:
  Interface Serial1/0 (compression on, VJ)
    Rcvd:    35 total, 34 compressed, 0 errors, 0 status msgs
             0 dropped, 0 buffer copies, 0 buffer failures
    Sent:    24 total, 23 compressed, 0 status msgs, 0 not predicted
             769 bytes saved, 293 bytes sent
             3.62 efficiency improvement factor
    Connect: 16 rx slots, 16 tx slots,
             1 misses, 0 collisions, 0 negative cache hits, 16 free contexts
             95% hit ratio, five minute miss rate 0 misses/sec, 0 max

R2#


Final Configurations:
R1:
hostname R1
!
interface Serial1/0
 ip address 172.16.12.1 255.255.255.0
 ip tcp header-compression
 clock rate 64000
 no shutdown
!
end

R2:
hostname R2
!
enable secret 5 $1$wG0y$Hr2fnzW6vgTBb2JaqgYJ5.
!
interface Serial1/0
 ip address 172.16.12.2 255.255.255.0
 ip tcp header-compression
 no shutdown
!
line vty 0 4
 password cisco
 logging synchronous
 login
!
end


Reference:
Cisco Networking Academy
http://www.cisco.com/web/learning/netacad/index.html

CCNP Version 5.0: Optimizing Converged Cisco Networks
Student Lab Manual


最初發表 / 最後更新: 2009.04.11 / 2018.06.14

0 comments:

張貼留言