Published 6月 12, 2018 by with 0 comment

CCNP-BCMSN-v5.0 Lab Case Study 1: VLANs, VTP and Inter-VLAN Routing



!!!I used real Cisco 3550 switch *4  and a router to do this lab. I did not use Dynamips to do this lab.!!!


Instructions
Plan, design, and implement the International Travel Agency switched network as shown in the diagram and described below. Implement the design on the lab set of switches. Verify that all configurations are operational and functioning
according to the guidelines given.


Scenario
You will need to configure a group of switches for the International Travel Agency. It has two distribution switches, DLS1 and DLS2, and two access layer switches, which are ALS1 and ALS2. You will have to design the addressing
scheme to use here. The address space you can use is the 172.16.0.0/16 range. You may subnet it any way you want, although it is recommended for simplicity purposes to use /24 subnets.

Basic Configuration:
All Switches:
enable
configure terminal
!
no ip domain lookup
!
interface vlan 1
 no shutdown
!
line console 0
 logging synchronous
 exec-timeout 0 0
!
hostname

Router:
enable
configure terminal
!
no ip domain lookup
!
line console 0
 logging synchronous
 exec-timeout 0 0
!
hostname R1


‧ Disable the links between the access layer switches.

DLS1(config)#interface range fastEthernet 0/7 - 12
DLS1(config-if-range)#shutdown

DLS2(config)#interface range fastEthernet 0/7 - 12
DLS2(config-if-range)#shutdown

ALS1(config)#interface range fastEthernet 0/7 - 10
ALS1(config-if-range)#shutdown

ALS2(config)#interface range fastEthernet 0/7 - 10
ALS2(config-if-range)#shutdown


‧ Place all switches in the VTP domain CISCO. Make DLS1 the VTP server and all other switches VTP clients.

DLS1(config)#vtp domain CISCO
DLS1(config)#vtp mode server

DLS2(config)#vtp domain CISCO
DLS2(config)#vtp mode client

ALS1(config)#vtp domain CISCO
ALS1(config)#vtp mode client

ALS2(config)#vtp domain CISCO
ALS2(config)#vtp mode client


‧ Create the VLANs shown in the VLAN table and assign the names given. For subnet planning, allocate a subnet for each VLAN.
DLS1(config)#vlan 10
DLS1(config-vlan)#name Red
DLS1(config-vlan)#exit
DLS1(config)#vlan 20
DLS1(config-vlan)#name Blue
DLS1(config-vlan)#exit
DLS1(config)#vlan 30
DLS1(config-vlan)#name Orange
DLS1(config-vlan)#exit
DLS1(config)#vlan 40
DLS1(config-vlan)#name Green
DLS1(config-vlan)#exit


‧ Make DLS1 the primary spanning-tree root for all VLANs. Make DLS2 the backup root.

DLS1(config)#spanning-tree vlan 1,10,20,30,40,1002-1005 root primary

DLS2(config)#spanning-tree vlan 1,10,20,30,40,1002-1005 root secondary


‧ Make F0/12 between DLS1 and DLS2 a layer 3 link and assign a subnet to it.

DLS1(config)#interface fastEthernet 0/12
DLS1(config-if)#no switchport
DLS1(config-if)#ip address 172.16.60.10 255.255.255.0
DLS1(config-if)#no shutdown

DLS2(config)#interface fastEthernet 0/12
DLS2(config-if)#no switchport
DLS2(config-if)#ip address 172.16.60.20 255.255.255.0
DLS2(config-if)#no shutdown


‧ Create a loopback interface on DLS1 and assign a subnet to it.

DLS1(config)#interface loopback 0
DLS1(config-if)#ip address 172.16.50.10 255.255.255.0


‧ Make F0/11 between DLS1 and DLS2 an ISL trunk link.

DLS1(config)#interface fastEthernet 0/11
DLS1(config-if)#switchport trunk encapsulation isl
DLS1(config-if)#switchport mode trunk
DLS1(config-if)#no shutdown

DLS2(config)#interface fastEthernet 0/11
DLS2(config-if)#switchport trunk encapsulation isl
DLS2(config-if)#switchport mode trunk
DLS2(config-if)#no shutdown


‧ Configure all other trunk links using 802.1q.

ALL SWITCH:
ALL SWITCH(config)#interface range fastEthernet 0/7 - 10
ALL SWITCH(config-if-range)#switchport trunk encapsulation dot1q
ALL SWITCH(config-if-range)#switchport mode trunk
ALL SWITCH(config-if-range)#no shutdown

‧ Make sure that all inter-switch links are statically set as trunks.

ALS2#show vlan brief

VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Fa0/1, Fa0/2, Fa0/3, Fa0/4
                                                Fa0/5, Fa0/6, Fa0/11, Fa0/12
                                                Fa0/13, Fa0/14, Fa0/15, Fa0/16
                                                Fa0/17, Fa0/18, Fa0/19, Fa0/20
                                                Fa0/21, Fa0/22, Fa0/23, Fa0/24
                                                Gi0/1, Gi0/2
10   Red                              active  
20   Blue                             active  
30   Orange                           active  
40   Green                            active  
1002 fddi-default                     act/unsup
1003 token-ring-default               act/unsup
1004 fddinet-default                  act/unsup
1005 trnet-default                    act/unsup
ALS2#


‧ The links from DLS1 to each access switch must be bound together in an EtherChannel.

DLS1(config)#interface range fastEthernet 0/7 - 8
DLS1(config-if-range)#channel-group 3 mode desirable
DLS1(config-if)#exit
DLS1(config)#interface port-channel 3
DLS1(config-if)#switchport trunk encapsulation dot1q
DLS1(config-if)#switchport mode trunk

DLS1(config)#interface range fastEthernet 0/9 - 10
DLS1(config-if-range)#channel-group 4 mode desirable
DLS1(config-if)#exit
DLS1(config)#interface port-channel 4
DLS1(config-if)#switchport trunk encapsulation dot1q
DLS1(config-if)#switchport mode trunk

DLS2(config)#interface range fastEthernet 0/7 - 8
DLS2(config-if-range)#channel-group 4 mode desirable
DLS2(config-if-range)#exit
DLS2(config)#interface port-channel 4
DLS2(config-if)#switchport trunk encapsulation dot1q
DLS2(config-if)#switchport mode trunk

DLS2(config)#interface range fastEthernet 0/9 - 10
DLS2(config-if-range)#channel-group 3 mode desirable
DLS2(config-if-range)#exit
DLS2(config)#interface port-channel 3
DLS2(config-if)#switchport trunk encapsulation dot1q
DLS2(config-if)#switchport mode trunk

ALS1(config)#interface range fastEthernet 0/7 - 8
ALS1(config-if-range)#channel-group 1 mode desirable
ALS1(config-if-range)#exit
ALS1(config)#interface port-channel 1
ALS1(config-if)#switchport trunk encapsulation dot1q
ALS1(config-if)#switchport mode trunk

ALS1(config)#interface range fastEthernet 0/9 - 10
ALS1(config-if-range)#channel-group 2 mode desirable
ALS1(config-if-range)#exit
ALS1(config)#interface port-channel 2
ALS1(config-if)#switchport trunk encapsulation dot1q
ALS1(config-if)#switchport mode trunk

ALS2(config)#interface range fastEthernet 0/7 - 8
ALS2(config-if-range)#channel-group 2 mode desirable
ALS2(config-if-range)#exit
ALS2(config)#interface port-channel 2
ALS2(config-if)#switchport trunk encapsulation dot1q
ALS2(config-if)#switchport mode trunk

ALS2(config)#interface range fastEthernet 0/9 - 10
ALS2(config-if-range)#channel-group 1 mode desirable
ALS2(config-if-range)#exit
ALS2(config)#interface port-channel 1
ALS2(config-if)#switchport trunk encapsulation dot1q
ALS2(config-if)#switchport mode trunk


‧ Enable portfast on all access ports.

ALL SWITCH:
ALL SWITCH(config)#spanning-tree portfast default

‧ Put F0/15 through F0/17 on ALS1 and ALS2 in VLAN 10. Place F0/18 and F0/19 on ALS1 and ALS2 in VLAN 20. Place F0/20 on ALS1 and ALS2 in VLAN 30.

ALS1(config)#interface range fastEthernet 0/15 - 17
ALS1(config-if-range)#switchport access vlan 10
ALS1(config-if-range)#switchport mode access

ALS2(config)#interface range fastEthernet 0/15 - 17
ALS2(config-if-range)#switchport access vlan 10
ALS2(config-if-range)#switchport mode access

ALS1(config)#interface range fastEthernet 0/18 - 19
ALS1(config-if-range)#switchport access vlan 20
ALS1(config-if-range)#switchport mode access

ALS2(config)#interface range fastEthernet 0/18 - 19
ALS2(config-if-range)#switchport access vlan 20
ALS2(config-if-range)#switchport mode access

ALS1(config)#interface fastEthernet 0/20
ALS1(config-if)#switchport access vlan 30
ALS1(config-if)#switchport mode access

ALS2(config)#interface fastEthernet 0/20
ALS2(config-if)#switchport access vlan 30
ALS2(config-if)#switchport mode access


‧ Create an 802.1q trunk link between R1 and ALS2. Allow only VLANs 10 and 40 to pass through the trunk.

ALS2(config)#interface fastEthernet 0/1
ALS2(config-if)#switchport trunk encapsulation dot1q
ALS2(config-if)#switchport mode trunk
ALS2(config-if)#switchport trunk allowed vlan 10,40

R1(config)#interface ethernet 0/0
R1(config-if)#no shutdown

R1(config)#interface ethernet 0/0.10
R1(config-subif)#encapsulation dot1Q 10

R1(config)#interface ethernet 0/0.40
R1(config-subif)#encapsulation dot1Q 40


‧ Give R1 subinterfaces in VLANs 10 and 40.

R1(config)#interface ethernet 0/0.10
R1(config-subif)#ip address 172.16.10.50 255.255.255.0

R1(config)#interface ethernet 0/0.40
R1(config-subif)#ip address 172.16.40.50 255.255.255.0


‧ Create an SVI interface on DLS1 in VLANs 20, 30 and 40. Create an SVI interface on DLS2 in VLAN 10, an SVI interface on ALS1 in VLAN 30, and an SVI interface on ALS2 in VLAN 40.

DLS1(config)#interface vlan 20
DLS1(config-if)#ip address 172.16.20.10 255.255.255.0
DLS1(config-if)#no shutdown

DLS1(config)#interface vlan 30
DLS1(config-if)#ip address 172.16.30.10 255.255.255.0
DLS1(config-if)#no shutdown

DLS1(config)#interface vlan 40                  
DLS1(config-if)#ip address 172.16.40.10 255.255.255.0
DLS1(config-if)#no shutdown

DLS2(config)#interface vlan 10
DLS2(config-if)#ip address 172.16.10.20 255.255.255.0
DLS2(config-if)#no shutdown

ALS1(config)#interface vlan 30
ALS1(config-if)#ip address 172.16.30.30 255.255.255.0
ALS1(config-if)#no shutdown

ALS2(config)#interface vlan 40
ALS2(config-if)#ip address 172.16.40.40 255.255.255.0
ALS2(config-if)#no shutdown

‧ Enable IP routing on DLS1. On R1 and DLS1, configure EIGRP for the whole major network (172.16.0.0/16) and disable automatic summarization.

DLS1(config)#ip routing
DLS1(config)#router eigrp 1
DLS1(config-router)#no auto-summary
DLS1(config-router)#network 172.16.0.0

R1(config)#router eigrp 1
R1(config-router)#no auto-summary
R1(config-router)#network 172.16.0.0


Test:
DLS1#ping 172.16.10.20

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.10.20, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/4/4 ms
DLS1#
DLS1#ping 172.16.30.30

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.30.30, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/3/4 ms
DLS1#
DLS1#ping 172.16.40.40

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.40.40, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/4/4 ms
DLS1#
DLS1#ping 172.16.10.50

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.10.50, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/4/4 ms
DLS1#
DLS1#ping 172.16.40.50

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.40.50, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/4/4 ms
DLS1#
DLS1#ping 172.16.60.20

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.60.20, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/3/4 ms
DLS1#

DLS2#ping 172.16.50.10

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.50.10, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/3/4 ms
DLS2#

ALS1#ping 172.16.50.10

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.50.10, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/4/4 ms
ALS1#

ALS2#ping 172.16.50.10

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.50.10, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/4/4 ms
ALS2#

R1#ping 172.16.50.10

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.50.10, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/4/4 ms
R1#


Final Configurations
DLS1:
hostname DLS1
!
ip routing
!
no ip domain-lookup
!
spanning-tree portfast default
!
spanning-tree vlan 1,10,20,30,40,1002-1005 priority 24576
!
interface Loopback0
 ip address 172.16.50.10 255.255.255.0
!
interface Port-channel3
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface Port-channel4
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface FastEthernet0/7
 switchport trunk encapsulation dot1q
 switchport mode trunk
 channel-group 3 mode desirable
!
interface FastEthernet0/8
 switchport trunk encapsulation dot1q
 switchport mode trunk
 channel-group 3 mode desirable
!       
interface FastEthernet0/9
 switchport trunk encapsulation dot1q
 switchport mode trunk
 channel-group 4 mode desirable
!
interface FastEthernet0/10
 switchport trunk encapsulation dot1q
 switchport mode trunk
 channel-group 4 mode desirable
!
interface FastEthernet0/11
 switchport trunk encapsulation isl
 switchport mode trunk
!
interface FastEthernet0/12
 no switchport
 ip address 172.16.60.10 255.255.255.0
!
interface Vlan1
 no shutdown
!
interface Vlan20
 ip address 172.16.20.10 255.255.255.0
 no shutdown
!
interface Vlan30
 ip address 172.16.30.10 255.255.255.0
 no shutdown
!      
interface Vlan40
 ip address 172.16.40.10 255.255.255.0
 no shutdown
!
router eigrp 1
 no auto-summary
 network 172.16.0.0
!
line con 0
 exec-timeout 0 0
 logging synchronous
!
end


DLS2:
hostname DLS2
!
no ip domain-lookup
!
spanning-tree portfast default
!
spanning-tree vlan 1,10,20,30,40,1002-1005 priority 28672
!
interface Port-channel4
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface Port-channel3
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface FastEthernet0/7
 switchport trunk encapsulation dot1q
 switchport mode trunk
 channel-group 4 mode desirable
!
interface FastEthernet0/8
 switchport trunk encapsulation dot1q
 switchport mode trunk
 channel-group 4 mode desirable
!
interface FastEthernet0/9
 switchport trunk encapsulation dot1q
 switchport mode trunk
 channel-group 3 mode desirable
!
interface FastEthernet0/10
 switchport trunk encapsulation dot1q
 switchport mode trunk
 channel-group 3 mode desirable
!
interface FastEthernet0/11
 switchport trunk encapsulation isl
 switchport mode trunk
!
interface FastEthernet0/12
 no switchport
 ip address 172.16.60.20 255.255.255.0
!
interface Vlan1
 no shutdown
!
interface Vlan10
 ip address 172.16.10.20 255.255.255.0
 no shutdown
!
line con 0
 exec-timeout 0 0
 logging synchronous
!
end


ASL1:
hostname ALS1
!
no ip domain-lookup
!
spanning-tree portfast default
!
interface Port-channel1
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface Port-channel2
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface FastEthernet0/7
 switchport trunk encapsulation dot1q
 switchport mode trunk
 channel-group 1 mode desirable
!
interface FastEthernet0/8
 switchport trunk encapsulation dot1q
 switchport mode trunk
 channel-group 1 mode desirable
!
interface FastEthernet0/9
 switchport trunk encapsulation dot1q
 switchport mode trunk
 channel-group 2 mode desirable
!
interface FastEthernet0/10
 switchport trunk encapsulation dot1q
 switchport mode trunk
 channel-group 2 mode desirable
!
interface FastEthernet0/15
 switchport access vlan 10
 switchport mode access
!
interface FastEthernet0/16
 switchport access vlan 10
 switchport mode access
!
interface FastEthernet0/17
 switchport access vlan 10
 switchport mode access
!
interface FastEthernet0/18
 switchport access vlan 20
 switchport mode access
!
interface FastEthernet0/19
 switchport access vlan 20
 switchport mode access
!
interface FastEthernet0/20
 switchport access vlan 30
 switchport mode access
!
interface Vlan1
 no shutdown
!
interface Vlan30
 ip address 172.16.30.30 255.255.255.0
 no shutdown
!
line con 0
 exec-timeout 0 0
 logging synchronous
!
end


ALS2:
hostname ALS2
!
no ip domain-lookup
!
spanning-tree portfast default
!
interface Port-channel2
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface Port-channel1
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface FastEthernet0/1
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 10,40
 switchport mode trunk
!
interface FastEthernet0/7
 switchport trunk encapsulation dot1q
 switchport mode trunk
 channel-group 2 mode desirable
!
interface FastEthernet0/8
 switchport trunk encapsulation dot1q
 switchport mode trunk
 channel-group 2 mode desirable
!
interface FastEthernet0/9
 switchport trunk encapsulation dot1q
 switchport mode trunk
 channel-group 1 mode desirable
!
interface FastEthernet0/10
 switchport trunk encapsulation dot1q
 switchport mode trunk
 channel-group 1 mode desirable
!
interface FastEthernet0/15
 switchport access vlan 10
 switchport mode access
!
interface FastEthernet0/16
 switchport access vlan 10
 switchport mode access
!
interface FastEthernet0/17
 switchport access vlan 10
 switchport mode access
!
interface FastEthernet0/18
 switchport access vlan 20
 switchport mode access
!
interface FastEthernet0/19
 switchport access vlan 20
 switchport mode access
!
interface FastEthernet0/20
 switchport access vlan 30
 switchport mode access
!
interface Vlan1
 no shutdown
!
interface Vlan40
 ip address 172.16.40.40 255.255.255.0
 no shutdown
!
line con 0
 exec-timeout 0 0
 logging synchronous
!
end


R1:
hostname R1
!
!
no ip domain lookup
!
interface Ethernet0/0
 no ip address
 no shutdown
!
interface Ethernet0/0.10
 encapsulation dot1Q 10
 ip address 172.16.10.50 255.255.255.0
!
interface Ethernet0/0.40
 encapsulation dot1Q 40
 ip address 172.16.40.50 255.255.255.0
!
router eigrp 1
 network 172.16.0.0
 no auto-summary
!
line con 0
 exec-timeout 0 0
 logging synchronous
!
end


Reference:
Cisco Networking Academy
http://www.cisco.com/web/learning/netacad/index.html

CCNP Version 5.0: Building Multilayer Switched Networks
Student Lab Manual


最初發表 / 最後更新: 2008.10.22 / 2018.06.12

0 comments:

張貼留言