Published 6月 14, 2018 by with 0 comment

CCNP-ONT-v5.0 Lab 3.1: Preparing for QoS Tool (TrafGen) in Dynamips(Linux)


Objective
TrafGen(TGN) is the bulk packet generator tool of Pagent. You can setup TGN in Dynamips while you study QoS lab.

Step 1 Using hex editor to open the "dynamips-0.2.8-RC2-x86.bin" file. For example, I use "UltraEdit" in WINXP.



Step 2 Search > Replace on UltraEdit.


Step 3 Change these values:
From: 91002000000000000000000030300030300030300230
To:   9100200000000000000000005446095857454D300259


From: 1150200000000000
To:   1150200010FFC545


Step 4 Save the "dynamips-0.2.8-RC2-x86.bin" file. You do not need to rename it.


Step 5 To replace the old "dynamips-0.2.8-RC2-x86.bin" file in Linux and then open Dymamips and Dynagen.


Step 6 Enter pagent license key: 407554012371 and study QoS.









Basic Pagent Configurations:
TrafGen# tgn
TrafGen(TGN:OFF,Fa0/0:none)#
fastethernet0/0
add tcp
rate 1000
l2-dest $R1-MAC$
l3-src 172.16.10.4
l3-dest 172.16.20.4
l4-dest 23
length random 16 to 1500
burst on
burst duration off 1000 to 2000
burst duration on 1000 to 3000
add fastethernet0/0 1
l4-dest 80
data ascii 0 GET /index.html HTTP/1.1
add fastethernet0/0 1
l4-dest 21
add fastethernet0/0 1
l4-dest 123
add fastethernet0/0 1
l4-dest 110
add fastethernet0/0 1
l4-dest 25
add fastethernet0/0 1
l4-dest 22
add fastethernet0/0 1
l4-dest 6000
!
end


Advanced Pagent Configurations:

R4(config)#ip cef
R4(config)#ip vrf PAGENT

R4(config-vrf)#interface fastEthernet 0/0
R4(config-if)#speed 100
R4(config-if)#duplex full
R4(config-if)#no shutdown

R4(config-if)#interface fastEthernet 0/0.10
R4(config-subif)#description Interface generating traffic
R4(config-subif)#encapsulation dot1Q 10
R4(config-subif)#ip vrf forwarding PAGENT
R4(config-subif)#ip address 172.16.10.4 255.255.255.0

R4(config-subif)#interface fastEthernet 0/0.20
R4(config-subif)#description capturing traffic
R4(config-subif)#encapsulation dot1Q 20
R4(config-subif)#ip vrf forwarding PAGENT
R4(config-subif)#ip address 172.16.20.4 255.255.255.0

R4(config-subif)#interface fastEthernet 0/1
R4(config-if)#ip address 172.16.14.4 255.255.255.0
R4(config-if)#speed 100
R4(config-if)#duplex full
R4(config-if)#no shutdown

TGN configuration:
fastethernet0/0
add tcp
rate 1000
datalink ios-dependent fastethernet0/0.10
l2-arp-for 172.16.10.1
l3-src 172.16.10.4
l3-dest 172.16.20.4
l4-dest 23
length random 16 to 1500
burst on
burst duration off 1000 to 2000
burst duration on 1000 to 3000
add fastethernet0/0 1
l4-dest 80
data ascii 0 GET /index.html HTTP/1.1
add fastethernet0/0 1
l4-dest 21
add fastethernet0/0 1
l4-dest 123
add fastethernet0/0 1
l4-dest 110
add fastethernet0/0 1
l4-dest 25
add fastethernet0/0 1
l4-dest 22
add fastethernet0/0 1
l4-dest 6000
!
end

TrafGen# tgn start
TrafGen# tgn stop
or
TrafGen# tgn
TrafGen(TGN:OFF,Fa0/0:none)# start
TrafGen(TGN:ON,Fa0/0:none)# stop
TrafGen(TGN:OFF,Fa0/0:none)# end

TrafGen(TGN:OFF,Fa0/0:none)# clear config


NQR is a Pagent tool that allows you to send and then capture packets. It combines TGN (the traffic generation tool you have already been using) and PKTS (a packet capturing tool you have not set up). Configuration of NQR is similar to that of TGN except that you select one interface for generating the packets and another for capturing them.
NQR configuration:
TrafGen# nqr
TrafGen(NQR:OFF,Fa0/0:none)#

Basic NQR Configurations:
fastethernet0/0
add tcp
send 1000
rate 60
length random 200 to 1000
l2-dest $R1_MAC$
l3-src 172.16.10.4
l3-dest 172.16.20.4
l4-dest 23
fastethernet0/1 capture
add clone-of 1
l4-dest 21
add clone-of 1
l4-dest 119
add clone-of 1
l4-dest 22
add clone-of 1
l4-dest 6000

Advanced NQR Configurations::
fastethernet0/0
add tcp
datalink ios-dependent fastethernet0/0.10
l2-arp-for 172.16.10.1
l3-src 172.16.10.4
l3-dest 172.16.20.4
l4-dest 23
fastethernet0/0.20 ios-dependent capture

TrafGen(NQR:OFF,Fa0/0:1/1)# start
TrafGen(NQR:ON,Fa0/0:1/1)# stop
TrafGen(NQR:WAIT,Fa0/0:1/1)#
TrafGen(NQR:OFF,Fa0/0:1/1)#

Verify packet drop and reordering statistics using the command show pkt-seqdrop-stats.
TrafGen(NQR:OFF,Fa0/0:1/1)# show pkt-seq-drop-stats

You can also look at delay and jitter statistics with the commands show delaystats and show jitter-stats respectively.
TrafGen(NQR:OFF,Fa0/0:1/1)# show delay-stats
TrafGen(NQR:OFF,Fa0/0:1/1)# show jitter-stats

!! Thanks Karun for tech support!!


Reference:
pagent key for redqueen's pagent
http://www.ebookee.com.cn/pagent-key-for-redqueen-39-s-pagent_187506.html

Cisco Networking Academy
http://www.cisco.com/web/learning/netacad/index.html

CCNP Version 5.0: Optimizing Converged Cisco Networks
Student Lab Manual


最初發表 / 最後更新: 2009.03.21 / 2018.06.14

0 comments:

張貼留言