Published 6月 14, 2018 by with 0 comment

CCNP-ONT-v5.0 Lab 4.2: Intermediate Queuing Tools


Lab4-2.net file for Dynamips:

##################################################
#
# CCNP Version 5.0: Optimizing Converged Cisco Networks
# Lab 4.2 Intermediate Queuing Tools
# By Happy Peter  http://blog.xuite.net/juilin77/happy
#
##################################################

autostart=false
[localhost:7200]
workingdir = /opt/dynamips/dynagen-0.11.0/UTS/CCNP4/lab4-2/workingconfig/

[[2621]]
 # Specify 2621 IOS image on Linux here:
 image = /opt/dynamips/images/C2600-TS.BIN
 ram = 128
 # Choose an idlepc value from the below
 idlepc = 0x803f37cc
 mmap = true
 ghostios = true
 confreg = 0x2102

[[3725]]
# Specify 3725 IOS image on Linux here:
 image = /opt/dynamips/images/c3725-ad.bin
 ram = 256
 idlepc = 0x60bf8d58
 mmap = true
 ghostios = true
 confreg = 0x2102

###########################
#
# Define router instances 1
#
###########################

 [[Router R1]]
  model = 3725
  console = 2001
  slot1 = NM-4T
  s1/0 = R2 s1/0

 [[Router R2]]
  model = 3725
  console = 2002
  slot1 = NM-4T
  s1/1 = R3 s1/1

 [[Router R3]]
  model = 3725
  console = 2003
  slot1 = NM-4T

 [[Router TGN]]
  # tgn: 407554012371
  model = 2621
  console = 2004
  f0/0 = R1 f0/0
  f0/1 = R3 f0/0



Learning Objectives
‧ Configure and verify custom queuing
‧ Configure and verify priority queuing


Preparation:

TGN(config)#interface fastEthernet 0/0
TGN(config-if)#ip address 172.16.10.4 255.255.255.0
TGN(config-if)#no shutdown

TGN(config)#interface fastEthernet 0/1
TGN(config-if)#ip address 172.16.20.4 255.255.255.0
TGN(config-if)#no shutdown

TGN to start generating traffic.
TGN#tgn

Loading these configurations:
fastethernet0/0
add tcp
rate 1000
l2-dest $R1 F0/0 MAC$
l3-src 172.16.10.4
l3-dest 172.16.20.4
l4-dest 23
length random 16 to 1500
burst on
burst duration off 1000 to 2000
burst duration on 1000 to 3000
add fastethernet0/0 1
l4-dest 80
data ascii 0 GET /index.html HTTP/1.1
add fastethernet0/0 1
l4-dest 21
add fastethernet0/0 1
l4-dest 123
add fastethernet0/0 1
l4-dest 110
add fastethernet0/0 1
l4-dest 25
add fastethernet0/0 1
l4-dest 22
add fastethernet0/0 1
l4-dest 6000
!
end

TGN#tgn start


Step 1: Configure the Physical Interfaces

R1(config)#interface fastEthernet 0/0
R1(config-if)#ip address 172.16.10.1 255.255.255.0
R1(config-if)#no shutdown

R1(config)#interface serial 1/0
R1(config-if)#ip address 172.16.12.1 255.255.255.0
R1(config-if)#bandwidth 800
R1(config-if)#clock rate 806400
R1(config-if)#no shutdown

R2(config)#interface serial 1/0
R2(config-if)#ip address 172.16.12.2 255.255.255.0
R2(config-if)#bandwidth 800
R2(config-if)#no shutdown

R2(config)#interface serial 1/1
R2(config-if)#ip address 172.16.23.2 255.255.255.0
R2(config-if)#bandwidth 128
R2(config-if)#clock rate 128000
R2(config-if)#no shutdown

R3(config)#interface fastEthernet 0/0
R3(config-if)#ip address 172.16.20.3 255.255.255.0
R3(config-if)#no shutdown

R3(config)#interface serial 1/1
R3(config-if)#ip address 172.16.23.3 255.255.255.0
R3(config-if)#bandwidth 128
R3(config-if)#no shutdown


Step 2: Configure EIGRP AS 1
R1(config)#router eigrp 1
R1(config-router)#network 172.16.0.0 
R1(config-router)#no auto-summary

R2(config)#router eigrp 1
R2(config-router)#network 172.16.0.0
R2(config-router)#no auto-summary

R3(config)#router eigrp 1
R3(config-router)#network 172.16.0.0
R3(config-router)#no auto-summary


Step 3: Configure Custom Queuing
Custom queuing (CQ) is an egress queuing tool that allows you to classify traffic into various queues based on the types of information that can be selected by an access list. In this lab, you will configure R1 to use custom queuing as the queuing method on the serial link facing R2.
Create an extended access control list (ACL) to select traffic with an IP Precedence of 6.
R1(config)#access-list 101 permit ip any any precedence internet

Apply this ACL to CQ classification by issuing the queue-list queue-list-number protocol ip queue-number list access-list-number command.
R1(config)#queue-list 7 protocol ip 1 list 101

Classify SSH (TCP port 22) and telnet into queue 2, NTP traffic (TCP port 123) into queue 3, and XWindows (TCP port 6000) and HTTP into queue 4. Do not place any other traffic into queues yet.
R1(config)#queue-list 7 protocol ip 2 tcp 22
R1(config)#queue-list 7 protocol ip 2 tcp telnet
R1(config)#queue-list 7 protocol ip 3 tcp 123
R1(config)#queue-list 7 protocol ip 4 tcp 6000
R1(config)#queue-list 7 protocol ip 4 tcp www

The TrafGen router also spoofs POP3 (TCP port 110) and SMTP (TCP port 25) traffic to 172.16.20.4. This traffic is not caught by any of the classification tools on the queues you have created, so assign unclassified traffic to queue 5.
R1(config)#queue-list 7 default 5

Now that you have classified packets into queues, you can adjust the parameters of queues. Reduce the queue size of queue 1 to 10 packets from the default 20 packets.
R1(config)#queue-list 7 queue 1 limit 10

Since your default queue, Queue 5, will probably have more traffic than other queues, raise its byte count to 3000, which is double the default of 1500.
R1(config)#queue-list 7 queue 5 byte-count 3000

The last step of configuring CQ is to apply it to an interface.
R1(config)#interface serial 1/0
R1(config-if)#custom-queue-list 7

You can verify the queuing configuration on a router using the show queueing command.
R1#show queueing
Current fair queue configuration:

  Interface           Discard    Dynamic  Reserved  Link    Priority
                      threshold  queues   queues    queues  queues
  Serial1/1           64         256      0         8       1  
  Serial1/2           64         256      0         8       1  
  Serial1/3           64         256      0         8       1  

Current DLCI priority queue configuration:
Current priority queue configuration:
Current custom queue configuration:

List   Queue  Args
7      5      default
7      1      protocol ip          list 101
7      2      protocol ip          tcp port 22
7      2      protocol ip          tcp port telnet
7      3      protocol ip          tcp port 123
7      4      protocol ip          tcp port 6000
7      4      protocol ip          tcp port www
7      1      limit 10
7      5      byte-count 3000
Current random-detect configuration:
Current per-SID queue configuration:
R1#

The output of show interfaces changes, as well, to reflect the new queuing strategy for an interface.
R1#show interfaces serial 1/0
Serial1/0 is up, line protocol is up
  Hardware is M4T
  Internet address is 172.16.12.1/24
  MTU 1500 bytes, BW 800 Kbit/sec, DLY 20000 usec,
     reliability 255/255, txload 202/255, rxload 1/255
  Encapsulation HDLC, crc 16, loopback not set
  Keepalive set (10 sec)
  Restart-Delay is 0 secs
  CRC checking enabled
  Last input 00:00:04, output 00:00:00, output hang never
  Last clearing of "show interface" counters 00:03:19
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 268467
  Queueing strategy: custom-list 7
  Output queues: (queue #: size/max/drops)
     0: 0/20/0 1: 0/10/0 2: 20/20/68768 3: 20/20/32491 4: 20/20/68883
     5: 20/20/98326 6: 0/20/0 7: 0/20/0 8: 0/20/0 9: 0/20/0
     10: 0/20/0 11: 0/20/0 12: 0/20/0 13: 0/20/0 14: 0/20/0
     15: 0/20/0 16: 0/20/0
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 935000 bits/sec, 168 packets/sec
     66 packets input, 4456 bytes, 0 no buffer
     Received 24 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
     38645 packets output, 29559557 bytes, 0 underruns
     0 output errors, 0 collisions, 0 interface resets
     0 output buffer failures, 0 output buffers swapped out
     0 carrier transitions     DCD=up  DSR=up  DTR=up  RTS=up  CTS=up

R1#

R1#show queue serial 1/0 5
Output queue for Serial1/0 is 20/20

Packet 1, linktype: ip, length: 171, flags: 0x88
  source: 172.16.10.4, destination: 172.16.20.4, id: 0x0000, ttl: 59,
  TOS: 0 prot: 6, source port 0, destination port 110
    data: 0x0000 0x006E 0x0000 0x0000 0x0000 0x0000 0x5000
          0x0000 0x693E 0x0000 0x0001 0x0203 0x0405 0x0607

Packet 2, linktype: ip, length: 633, flags: 0x88
  source: 172.16.10.4, destination: 172.16.20.4, id: 0x0000, ttl: 59,
  TOS: 0 prot: 6, source port 0, destination port 21
    data: 0x0000 0x0015 0x0000 0x0000 0x0000 0x0000 0x5000
          0x0000 0xE730 0x0000 0x0001 0x0203 0x0405 0x0607

Packet 3, linktype: ip, length: 445, flags: 0x88
  source: 172.16.10.4, destination: 172.16.20.4, id: 0x0000, ttl: 59,
  TOS: 0 prot: 6, source port 0, destination port 110
    data: 0x0000 0x006E 0x0000 0x0000 0x0000 0x0000 0x5000
          0x0000 0xDB28 0x0000 0x0001 0x0203 0x0405 0x0607


R1#debug custom-queue
Custom output queueing debugging is on
R1#
*Mar  1 02:25:32.307: CQ: Serial1/0 output (Pk size/Q: 1488/4) Q # was 4 now 5
*Mar  1 02:25:32.307: CQ: Serial1/0 output (Pk size/Q: 1058/5) Q # was 5 now 5
*Mar  1 02:25:32.319: CQ: Serial1/0 output (Pk size/Q: 634/5) Q # was 5 now 5
*Mar  1 02:25:32.319: CQ: Serial1/0 output (Pk size/Q: 455/5) Q # was 5 now 5
*Mar  1 02:25:32.327: CQ: Serial1/0 output (Pk size/Q: 1204/5) Q # was 5 now 6
*Mar  1 02:25:32.327: CQ: Serial1/0 output (Pk size/Q: 1027/2) Q # was 6 now 2
*Mar  1 02:25:32.339: CQ: Serial1/0 output (Pk size/Q: 176/2) Q # was 2 now 2
*Mar  1 02:25:32.339: CQ: Serial1/0 output (Pk size/Q: 1094/2) Q # was 2 now 3


Step 4: Configure Priority Queuing
Priority queuing (PQ) is an IOS queuing method that allows you to classify traffic into various queues the same way that CQ does. However, PQ implements a strict priority queuing policy. Rather than many queues that are serviced in a round-robin fashion, there are 4 queues with different priorities—high, medium, normal, and low.
Configure R2 to use priority queuing as the queuing method on the serial link facing R3.
Using the same extended access list you used in Step 3, select traffic with IP Precedence of 6 for the high-priority queue.
R2(config)#access-list 101 permit ip any any precedence internet
R2(config)#priority-list 5 protocol ip high list 101

Classify SSH (TCP port 22) and TrafGen-generated telnet into medium-priority queue, NTP traffic (TCP port 123) into the normal-priority queue. Do not place any other traffic into queues yet.
R2(config)#priority-list 5 protocol ip medium tcp 22
R2(config)#priority-list 5 protocol ip medium tcp 23
R2(config)#priority-list 5 protocol ip medium tcp 123

Instead of explicitly assigning XWindows and HTTP traffic to the low-priority queue, simply assign the remainder of all traffic to that queue by selecting it as the default queue.
R2(config)#priority-list 5 default low

The default queue sizes are 20, 40, 60, and 80 for high, medium, normal, and low priorities respectively.
For this lab, increase the low queue size to 100.
R2(config)#priority-list 5 queue-limit 20 40 60 100

Now that the priority list is configured, apply it to an interface.
R2(config)#interface serial 1/1
R2(config-if)#priority-group 5

R2#show queueing
Current fair queue configuration:

  Interface           Discard    Dynamic  Reserved  Link    Priority
                      threshold  queues   queues    queues  queues
  Serial1/0           64         256      0         8       1  
  Serial1/2           64         256      0         8       1  
  Serial1/3           64         256      0         8       1  

Current DLCI priority queue configuration:
Current priority queue configuration:

List   Queue  Args
5      low    default
5      high   protocol ip          list 101
5      medium protocol ip          tcp port 22
5      medium protocol ip          tcp port telnet
5      medium protocol ip          tcp port 123
5      low    limit 100
Current custom queue configuration:
Current random-detect configuration:
Current per-SID queue configuration:
R2#

R2#show interfaces serial 1/1
Serial1/1 is up, line protocol is up
  Hardware is M4T
  Internet address is 172.16.23.2/24
  MTU 1500 bytes, BW 128 Kbit/sec, DLY 20000 usec,
     reliability 255/255, txload 250/255, rxload 1/255
  Encapsulation HDLC, crc 16, loopback not set
  Keepalive set (10 sec)
  Restart-Delay is 0 secs
  CRC checking enabled
  Last input 00:00:01, output 00:00:00, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 141199
  Queueing strategy: priority-list 5
  Output queue (queue priority: size/max/drops):
     high: 0/20/0, medium: 1/40/56, normal: 0/60/110674, low: 99/100/30469
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 716000 bits/sec, 118 packets/sec
     2663 packets input, 173534 bytes, 0 no buffer
     Received 974 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
     309395 packets output, 225542437 bytes, 0 underruns
     0 output errors, 0 collisions, 5 interface resets
     0 output buffer failures, 0 output buffers swapped out
     4 carrier transitions     DCD=up  DSR=up  DTR=up  RTS=up  CTS=up

R2#

R2#show queue serial 1/1 3 
Output queue for Serial1/1 is 99/100

Packet 1, linktype: ip, length: 814, flags: 0x88
  source: 172.16.10.4, destination: 172.16.20.4, id: 0x0000, ttl: 58,
  TOS: 0 prot: 6, source port 0, destination port 80
    data: 0x0000 0x0050 0x0000 0x0000 0x0000 0x0000 0x5000
          0x0000 0xD493 0x0000 0x4745 0x5420 0x2F69 0x6E64

Packet 2, linktype: ip, length: 771, flags: 0x88
  source: 172.16.10.4, destination: 172.16.20.4, id: 0x0000, ttl: 58,
  TOS: 0 prot: 6, source port 0, destination port 80
    data: 0x0000 0x0050 0x0000 0x0000 0x0000 0x0000 0x5000
          0x0000 0x4B08 0x0000 0x4745 0x5420 0x2F69 0x6E64

Packet 3, linktype: ip, length: 1020, flags: 0x88
  source: 172.16.10.4, destination: 172.16.20.4, id: 0x0000, ttl: 58,
  TOS: 0 prot: 6, source port 0, destination port 80
    data: 0x0000 0x0050 0x0000 0x0000 0x0000 0x0000 0x5000
          0x0000 0x7803 0x0000 0x4745 0x5420 0x2F69 0x6E64


Final Configurations:
R1:
hostname R1
!
!
no ip domain lookup
!
interface FastEthernet0/0
 ip address 172.16.10.1 255.255.255.0
 no shutdown
!
interface Serial1/0
 bandwidth 800
 ip address 172.16.12.1 255.255.255.0
 custom-queue-list 7
 clock rate 806400
 no shutdown
!
router eigrp 1
 network 172.16.0.0
 no auto-summary
!
access-list 101 permit ip any any precedence internet
queue-list 7 protocol ip 1 list 101
queue-list 7 protocol ip 2 tcp 22
queue-list 7 protocol ip 2 tcp telnet
queue-list 7 protocol ip 3 tcp 123
queue-list 7 protocol ip 4 tcp 6000
queue-list 7 protocol ip 4 tcp www
queue-list 7 default 5
queue-list 7 queue 1 limit 10
queue-list 7 queue 5 byte-count 3000
!
line con 0
 logging synchronous
!
end

R2:
hostname R2
!
no ip domain lookup
!
interface Serial1/0
 bandwidth 800
 ip address 172.16.12.2 255.255.255.0
 no shutdown
!
interface Serial1/1
 bandwidth 128
 ip address 172.16.23.2 255.255.255.0
 priority-group 5
 clock rate 128000
 no shutdown
!
router eigrp 1
 network 172.16.0.0
 no auto-summary
!
access-list 101 permit ip any any precedence internet
priority-list 5 protocol ip high list 101
priority-list 5 protocol ip medium tcp 22
priority-list 5 protocol ip medium tcp telnet
priority-list 5 protocol ip medium tcp 123
priority-list 5 default low
priority-list 5 queue-limit 20 40 60 100
!
line con 0
 logging synchronous
!
end

R3:
hostname R3
!
no ip domain lookup
!
interface FastEthernet0/0
 ip address 172.16.20.3 255.255.255.0
 no shutdown
!
interface Serial1/1
 bandwidth 128
 ip address 172.16.23.3 255.255.255.0
 no shutdown
!
router eigrp 1
 network 172.16.0.0
 no auto-summary
!
line con 0
 logging synchronous
!
end


Reference:
Cisco Networking Academy
http://www.cisco.com/web/learning/netacad/index.html

CCNP Version 5.0: Optimizing Converged Cisco Networks
Student Lab Manual


最初發表 / 最後更新: 2009.03.22 / 2018.06.14

0 comments:

張貼留言