Published 6月 11, 2018 by with 0 comment

CCNP-ISCW-v5.0 Lab 4-1: Configuring Frame Mode MPLS


Lab4-1.net file for Dynamips:

##################################################
#
# CCNP Version 5.0: Implementing Secure Converged Wide-Area Networks
# Lab 4.1 Configuring Frame Mode MPLS
# By Happy Peter  http://blog.xuite.net/juilin77/happy
#
##################################################

autostart=false
[localhost:7200]
workingdir = /opt/dynamips/dynagen-0.10.1/UTS/CCNP2/Lab4-1/workingconfig

[[3640]]
#  Specify 3640 IOS image on Windows here:
#  image = C:\Program Files\Dynamips\images\c3640-jk9o3s-mz.123-14.T7.extracted.bin
#  Specify 3640 IOS image on Linux here:
 image = /opt/dynamips/images/c3640-jk.bin
 ram = 128
 disk0 = 0
 disk1 = 0
 # Choose an idlepc value from the below
 idlepc = 0x605ac7b8
 mmap = true
 ghostios = true
 confreg = 0x2102

###########################
#
# Define router instances 1
#
###########################
 
 [[Router R1]]
  model = 3640
  console = 2001
  slot0 = NM-1FE-TX

 [[Router R2]]
  model = 3640
  console = 2002
  slot0 = NM-1FE-TX
  slot1 = NM-4T
  f0/0 = R1 f0/0
  s1/0 = R3 s0/0

 [[Router R3]]
  model = 3640
  console = 2003
  slot0 = NM-4T

Objective:
‧ Configure EIGRP on a router
‧ Configure Label Distribution Protocol on a router
‧ Change the size of the Maximum Transmission Unit (MTU)
‧ Verify MPLS behavior


Scenario:
In this lab, you will configure a simple Enhanced Interior Gateway Routing Protocol (EIGRP) network to route IP packets. You will run Multiprotocol Label Switching (MPLS) over the IP internetwork to fast-switch Layer 2 frames.


Basic Configuration:
enable
configure terminal
!
no ip domain lookup
!
line console 0
 logging synchronous
 exec-timeout 0 0
!
host R*


Step 1: Configure Addressing
R1:
interface Loopback0
 ip address 172.16.1.1 255.255.255.0
!       
interface fastEthernet 0/0
 ip address 172.16.12.1 255.255.255.0
 no shutdown

R2:
interface fastEthernet 0/0
 ip address 172.16.12.2 255.255.255.0
 no shutdown
!
interface Serial1/0
 ip address 172.16.23.2 255.255.255.0
 clock rate 64000
 no shutdown

R3:
interface Loopback0
 ip address 172.16.3.1 255.255.255.0
!             
interface Serial0/0
 ip address 172.16.23.3 255.255.255.0
 no shutdown


Step 2: Configure EIGRP AS 1
R1 & R2 & R3
router eigrp 1
 network 172.16.0.0
 no auto-summary


Step 3: Observe CEF Operation
R1:
show ip cef
show ip cef non-recursive

CEF should be enabled by default. If CEF is not enabled,
R1 & R2 & R3:
ip cef


Step 4: Enable MPLS on All Physical Interfaces
R1:
interface FastEthernet0/0
 mpls ip

R2:
interface FastEthernet0/0
 mpls ip
!
interface Serial1/0
 mpls ip

R3:
interface Serial1/0
 mpls ip


Step 5: Verify MPLS Configuration
R1-3:
show mpls interfaces
show mpls ldp discovery
show mpls ldp neighbor
show mpls ldp bindings
R1#show mpls ldp bindings
  tib entry: 172.16.1.0/24, rev 6
        local binding:  tag: imp-null
        remote binding: tsr: 172.16.23.2:0, tag: 16
  tib entry: 172.16.3.0/24, rev 8
        local binding:  tag: 17
        remote binding: tsr: 172.16.23.2:0, tag: 17
  tib entry: 172.16.12.0/24, rev 4
        local binding:  tag: imp-null
        remote binding: tsr: 172.16.23.2:0, tag: imp-null
  tib entry: 172.16.23.0/24, rev 2
        local binding:  tag: 16
        remote binding: tsr: 172.16.23.2:0, tag: imp-null


R1#traceroute 172.16.3.1

Type escape sequence to abort.
Tracing the route to 172.16.3.1

  1 172.16.12.2 [MPLS: Label 17 Exp 0] 4 msec 24 msec 8 msec
  2 172.16.23.3 8 msec *  8 msec


Step 6: Change MPLS MTU
R1-2:
show mpls interfaces fastEthernet 0/0 detail
Interface FastEthernet0/0:
        IP labeling enabled (ldp):
          Interface config
        LSP Tunnel labeling not enabled
        BGP tagging not enabled
        Tagging operational
        Fast Switching Vectors:
          IP to MPLS Fast Switching Vector
          MPLS Turbo Vector
        MTU = 1500

R1-2:
interface fastEthernet 0/0
 mpls mtu 1508


Final Configurations
R1:
hostname R1
!
ip cef
!
no ip domain lookup
!
interface Loopback0
 ip address 172.16.1.1 255.255.255.0
!       
interface FastEthernet0/0
 ip address 172.16.12.1 255.255.255.0
 mpls ip
 mpls mtu 1508
 no shutdown
!
router eigrp 1
 network 172.16.0.0
 no auto-summary
!
line con 0
 exec-timeout 0 0
 logging synchronous
!
end

R2:
hostname R2
!
ip cef
!
no ip domain lookup
!
interface FastEthernet0/0
 ip address 172.16.12.2 255.255.255.0
 mpls ip
 mpls mtu 1508
 no shutdown
!
interface Serial1/0
 ip address 172.16.23.2 255.255.255.0
 mpls ip
 clock rate 64000
 no shutdown
!
router eigrp 1
 network 172.16.0.0
 no auto-summary
!
line con 0
 exec-timeout 0 0
 logging synchronous
!
end

R3:
hostname R3
!
ip cef
!
no ip domain lookup
!
interface Loopback0
 ip address 172.16.3.1 255.255.255.0
!       
interface Serial0/0
 ip address 172.16.23.3 255.255.255.0
 mpls ip
 no shutdown
!
router eigrp 1
 network 172.16.0.0
 no auto-summary
!
line con 0
 exec-timeout 0 0
 logging synchronous
!
end


Reference:
Cisco Networking Academy
http://www.cisco.com/web/learning/netacad/index.html

CCNP Version 5.0: Implementing Secure Converged Wide-Area Networks
Student Lab Manual


最初發表 / 最後更新: 2008.09.30 / 2018.06.11

0 comments:

張貼留言