Lab3-2.net file for Dynamips:
##################################################
#
# CCNP Version 5.0: Implementing Secure Converged Wide-Area Networks
# Lab 3.2 Configuring a Basic GRE Tunnel
#
##################################################
autostart=false
[localhost:7200]
workingdir = /opt/dynamips/dynagen-0.10.1/UTS/CCNP2/Lab3-2/workingconfig
[[3640]]
# Specify 3640 IOS image on Windows here:
# image = C:\Program Files\Dynamips\images\c3640-jk9o3s-mz.123-14.T7.extracted.bin
# Specify 3640 IOS image on Linux here:
image = /opt/dynamips/images/c3640-jk.bin
ram = 128
disk0 = 0
disk1 = 0
# Choose an idlepc value from the below
idlepc = 0x605ac7b8
mmap = true
ghostios = true
confreg = 0x2102
###########################
#
# Define router instances 1
#
###########################
[[Router R1]]
model = 3640
console = 2001
slot0 = NM-4T
[[Router R2]]
model = 3640
console = 2002
slot0 = NM-4T
S0/0 = R1 S0/0
S0/1 = R3 S0/1
[[Router R3]]
model = 3640
console = 2003
slot0 = NM-4T
Objective:
‧ Configure a GRE tunnel
‧ Configure EIGRP on a router
‧ Configure and test routing over the tunnel interfaces
Basic Configuration:
enable
configure terminal
!
no ip domain lookup
!
line console 0
logging synchronous
exec-timeout 0 0
!
host R*
Step 1: Configure Loopbacks and Physical Interfaces
R1:
interface Loopback0
ip address 172.16.1.1 255.255.255.0
!
interface Serial0/0
ip address 192.168.12.1 255.255.255.0
clock rate 64000
no shutdown
end
R2:
interface Serial0/0
ip address 192.168.12.2 255.255.255.0
no shutdown
!
interface Serial0/1
ip address 192.168.23.2 255.255.255.0
clock rate 64000
no shutdown
R3:
interface Loopback0
ip address 172.16.3.1 255.255.255.0
!
interface Serial0/1
ip address 192.168.23.3 255.255.255.0
no shutdown
Step 2: Configure EIGRP AS 1
R1 & R2 & R3:
router eigrp 1
network 192.168.0.0 0.0.255.255
no auto-summary
!!!Verify!!!
R1#show ip route eigrp 1
D 192.168.23.0/24 [90/2681856] via 192.168.12.2, 00:00:39, Serial0/0
R3#show ip route eigrp 1
D 192.168.12.0/24 [90/2681856] via 192.168.23.2, 00:01:19, Serial0/1
Step 3: Configure a GRE Tunnel
R1:
interface Tunnel0
ip address 172.16.13.1 255.255.255.0
tunnel source Serial0/0
tunnel destination 192.168.23.3
R3:
interface Tunnel0
ip address 172.16.13.3 255.255.255.0
tunnel source Serial0/1
tunnel destination 192.168.12.1
R1#ping 172.16.13.3
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.13.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/10/16 ms
R3#ping 172.16.13.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.13.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/8/12 ms
Step 4: Routing EIGRP AS 2 over the Tunnel
R1 & R3:
router eigrp 2
network 172.16.0.0
no auto-summary
!!!Verify!!!
R1#show ip route eigrp 2
172.16.0.0/24 is subnetted, 3 subnets
D 172.16.3.0 [90/297372416] via 172.16.13.3, 00:01:50, Tunnel0
R3#show ip route eigrp 2
172.16.0.0/24 is subnetted, 3 subnets
D 172.16.1.0 [90/297372416] via 172.16.13.1, 00:02:21, Tunnel0
R1#ping 172.16.3.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.3.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/12/20 ms
R2#ping 172.16.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.1.1, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
R2#ping 172.16.3.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.3.1, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
R3#ping 172.16.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/13/36 ms
Final Configurations
R1:
hostname R1
!
no ip domain lookup
!
interface Loopback0
ip address 172.16.1.1 255.255.255.0
!
interface Tunnel0
ip address 172.16.13.1 255.255.255.0
tunnel source Serial0/0
tunnel destination 192.168.23.3
!
interface Serial0/0
ip address 192.168.12.1 255.255.255.0
clock rate 64000
no shutdown
!
router eigrp 1
network 192.168.0.0 0.0.255.255
no auto-summary
!
router eigrp 2
network 172.16.0.0
no auto-summary
!
line con 0
exec-timeout 0 0
logging synchronous
!
end
R2:
hostname R2
!
no ip domain lookup
!
interface Serial0/0
ip address 192.168.12.2 255.255.255.0
no shutdown
!
interface Serial0/1
ip address 192.168.23.2 255.255.255.0
clock rate 64000
no shutdown
!
router eigrp 1
network 192.168.0.0 0.0.255.255
no auto-summary
!
line con 0
exec-timeout 0 0
logging synchronous
!
end
R3:
hostname R3
!
no ip domain lookup
!
interface Loopback0
ip address 172.16.3.1 255.255.255.0
!
interface Tunnel0
ip address 172.16.13.3 255.255.255.0
tunnel source Serial0/1
tunnel destination 192.168.12.1
!
interface Serial0/1
ip address 192.168.23.3 255.255.255.0
no shutdown
!
router eigrp 1
network 192.168.0.0 0.0.255.255
no auto-summary
!
router eigrp 2
network 172.16.0.0
no auto-summary
!
line con 0
exec-timeout 0 0
logging synchronous
!
end
Reference:
Cisco Networking Academy
http://www.cisco.com/web/learning/netacad/index.html
CCNP Version 5.0: Implementing Secure Converged Wide-Area Networks
Student Lab Manual
最初發表 / 最後更新: 2008.09.14 / 2018.06.11
0 comments:
張貼留言