Published 6月 15, 2018 by with 0 comment

JNCIP-SP Lab: Study Guide Chapter 2 Case Study


In this Lab, I use Olive to finish the JNCIP study guide chapter 2 case study Lab.
I use one Olive and runing logical-system R1-7 to simulate Router 1-7
So Router 1 is the logical-system r1.

Before we start lab, we need to setup some default configuration.
root@JNCIP# set interfaces em1 vlan-tagging 
root@JNCIP# set interfaces em2 vlan-tagging   
root@JNCIP# set interfaces em3 vlan-tagging   
root@JNCIP# set interfaces em4 vlan-tagging   
root@JNCIP# set interfaces em5 vlan-tagging   
root@JNCIP# set interfaces em6 vlan-tagging   
root@JNCIP# set interfaces em7 vlan-tagging  
root@JNCIP# commit


Requirements
R1:
em1.12        VL12        10.0.4.5/30        Only accept frames sent from r2’s fe-0/0/3 MAC address (Olive do not support)
em1.13        VL13        10.0.4.14/30    VLAN tagging
em1.120        VL120        10.0.5.1/24        VRRP group 1, VIP 10.0.5.200, master when link to r3 is up, authenticate with plain-text password jnx.
Lo0            unit1        10.0.6.1/32        -

R2:
em2.12        VL12        10.0.4.6/30        Only accept frames sent from r1’s fe-0/0/2 MAC address (Olive do not support)
em2.23        VL23        10.0.4.2/30        -
em2.24        VL24        10.0.4.10/30    Half-duplex
em2.120        VL120        10.0.5.2/24        VRRP backup for r1   
Lo0            unit2        10.0.6.2/32        -

R3:
em3.13        VL13        10.0.4.13/30    -
em3.23        VL23        10.0.4.1/30        -   
em3.34        VL34        10.0.2.5/30        --Frame realy--!! Skip it !!
em3.35        VL35        10.0.2.2/30        --ATM--!! Skip it !!
Lo0            unit3        10.0.6.3/32        -

R4:
em4.24        VL24        10.0.4.9/30        Disable flow control
em4.34        VL34        10.0.2.6/30        -
em4.45        VL45        10.0.2.10/30    --SDH--!! Skip it
Lo0            unit4        10.0.6.4/32        -

R5:
em5.35        VL35        10.0.2.1/30        --ATM--!! Skip it !!
em5.45        VL45        10.0.2.9/30        --SDH--!! Skip it
em5.56        VL56        10.0.8.6/30        -
em5.57        VL57        10.0.8.9/30        -
Lo0            unit5        10.0.6.5/32        -

R6:
em6.56        VL56        10.0.8.5/30        -
em6.67        VL67        10.0.8.1/30        Device MTU = 4000
Lo0            unit6        10.0.6.6/32        -

R7:
em7.57        VL57        10.0.8.10/30    -
em7.67        VL67        10.0.8.2/30        -
Lo0            unit7        10.0.6.7/32        -


2. R1(logical-system r1) interfaces setting.
set logical-systems r1 interfaces em1 unit 12 description "Connect to r2 em2.12"
set logical-systems r1 interfaces em1 unit 12 vlan-id 12
set logical-systems r1 interfaces em1 unit 12 family inet address 10.0.4.5/30

set logical-systems r1 interfaces em1 unit 13 description "Connect to r3 em3.13"
set logical-systems r1 interfaces em1 unit 13 vlan-id 13
set logical-systems r1 interfaces em1 unit 13 family inet address 10.0.4.14/30

set logical-systems r1 interfaces em1 unit 120 description "Connect to r2 em2.120"
set logical-systems r1 interfaces em1 unit 120 vlan-id 120
set logical-systems r1 interfaces em1 unit 120 family inet address 10.0.5.1/24

set logical-systems r1 interfaces lo0 unit 1 family inet address 10.0.6.1/32

VRRP setting (Olive do not support multicast packet "VRRP:224.0.0.18")
set logical-systems r1 interfaces em1 unit 120 family inet address 10.0.5.1/24 vrrp-group 1 virtual-address 10.0.5.200
set logical-systems r1 interfaces em1 unit 120 family inet address 10.0.5.1/24 vrrp-group 1 authentication-type simple
set logical-systems r1 interfaces em1 unit 120 family inet address 10.0.5.1/24 vrrp-group 1 authentication-key jnx
set logical-systems r1 interfaces em1 unit 120 family inet address 10.0.5.1/24 vrrp-group 1 track interface em1.13 priority-cost 30

Check command:
root@JNCIP# run show vrrp summary logical-system r1

Source-filtering setting (Olive do not support this command)
set interfaces interface-name source-address-filter {mac-address}


2. R2(logical-system r2) interfaces setting.
set logical-systems r2 interfaces em2 unit 12 description "Connect to r1 em1.12"
set logical-systems r2 interfaces em2 unit 12 vlan-id 12
set logical-systems r2 interfaces em2 unit 12 family inet address 10.0.4.6/30

set logical-systems r2 interfaces em2 unit 23 description "Connect to r3 em3.23"
set logical-systems r2 interfaces em2 unit 23 vlan-id 23
set logical-systems r2 interfaces em2 unit 23 family inet address 10.0.4.2/30

set logical-systems r2 interfaces em2 unit 24 description "Connect to r4 em4.24"
set logical-systems r2 interfaces em2 unit 24 vlan-id 24
set logical-systems r2 interfaces em2 unit 24 family inet address 10.0.4.10/30

set logical-systems r2 interfaces em2 unit 120 description "Connect to r1 em1.120"
set logical-systems r2 interfaces em2 unit 120 vlan-id 120
set logical-systems r2 interfaces em2 unit 120 family inet address 10.0.5.2/24

set logical-systems r2 interfaces lo0 unit 2 family inet address 10.0.6.2/32

VRRP (Olive do not support multicast packet "VRRP:224.0.0.18")
set logical-systems r2 interfaces em2 unit 120 family inet address 10.0.5.2/24 vrrp-group 1 virtual-address 10.0.5.200
set logical-systems r2 interfaces em2 unit 120 family inet address 10.0.5.2/24 vrrp-group 1 priority 80
set logical-systems r2 interfaces em2 unit 120 family inet address 10.0.5.2/24 vrrp-group 1 authentication-type simple
set logical-systems r2 interfaces em2 unit 120 family inet address 10.0.5.2/24 vrrp-group 1 authentication-key jnx

Check command:
root@JNCIP# run show vrrp summary logical-system r2

Setting logical-systems r2 interfaces em2 Half-duplex (This command do no support under the logical-systems level.)
set interfaces em2 link-mode

source-filtering setting (Olive do not support this command)
set interfaces interface-name source-address-filter {mac-address}


3. R3(logical-system r3) interfaces setting.
set logical-systems r3 interfaces em3 unit 13 description "Connecto to r1 em1.13"
set logical-systems r3 interfaces em3 unit 13 vlan-id 13
set logical-systems r3 interfaces em3 unit 13 family inet address 10.0.4.13/30

set logical-systems r3 interfaces em3 unit 23 description "Connecto to r2 em2.23"
set logical-systems r3 interfaces em3 unit 23 vlan-id 23
set logical-systems r3 interfaces em3 unit 23 family inet address 10.0.4.1/30

set logical-systems r3 interfaces em3 unit 34 description "Connecto to r4 em4.34"
set logical-systems r3 interfaces em3 unit 34 vlan-id 34
set logical-systems r3 interfaces em3 unit 34 family inet address 10.0.2.5/30

set logical-systems r3 interfaces em3 unit 35 description "Connecto to r5 em5.35"
set logical-systems r3 interfaces em3 unit 35 vlan-id 35
set logical-systems r3 interfaces em3 unit 35 family inet address 10.0.2.2/30

set logical-systems r3 interfaces lo0 unit 3 family inet address 10.0.6.3/32

Frame realy setting(Olive do not support it)


4. R4(logical-system r4) interfaces setting.
set logical-systems r4 interfaces em4 unit 24 description "Connect to r2 em2.24"
set logical-systems r4 interfaces em4 unit 24 vlan-id 24
set logical-systems r4 interfaces em4 unit 24 family inet address 10.0.4.9/30

set logical-systems r4 interfaces em4 unit 34 description "Connect to r3 em3.34"
set logical-systems r4 interfaces em4 unit 34 vlan-id 34
set logical-systems r4 interfaces em4 unit 34 family inet address 10.0.2.6/30

set logical-systems r4 interfaces em4 unit 45 description "Connect to r5 em5.45"
set logical-systems r4 interfaces em4 unit 45 vlan-id 45
set logical-systems r4 interfaces em4 unit 45 family inet address 10.0.2.10/30

set logical-systems r4 interfaces lo0 unit 4 family inet address 10.0.6.4/32

Disable flow control setting (Olive do not support this command)
set interfaces interface-name fastether-options no-flow-control


5. R5(logical-system r5) interfaces setting.
set logical-systems r5 interfaces em5 unit 35 description "Connect to r3 em3.35"
set logical-systems r5 interfaces em5 unit 35 vlan-id 35
set logical-systems r5 interfaces em5 unit 35 family inet address 10.0.2.1/30

set logical-systems r5 interfaces em5 unit 45 description "Connect to r4 em4.45"
set logical-systems r5 interfaces em5 unit 45 vlan-id 45
set logical-systems r5 interfaces em5 unit 45 family inet address 10.0.2.9/30

set logical-systems r5 interfaces em5 unit 56 description "Connect to r6 em6.56"
set logical-systems r5 interfaces em5 unit 56 vlan-id 56
set logical-systems r5 interfaces em5 unit 56 family inet address 10.0.8.6/30

set logical-systems r5 interfaces em5 unit 57 description "Connect to r7 em7.57"
set logical-systems r5 interfaces em5 unit 57 vlan-id 57
set logical-systems r5 interfaces em5 unit 57 family inet address 10.0.8.9/30

set logical-systems r5 interfaces lo0 unit 5 family inet address 10.0.6.5/32


6. R6(logical-system r6) interfaces setting.
set logical-systems r6 interfaces em6 unit 56 description "Connect to r5 em5.56"
set logical-systems r6 interfaces em6 unit 56 vlan-id 56
set logical-systems r6 interfaces em6 unit 56 family inet address 10.0.8.5/30

set logical-systems r6 interfaces em6 unit 67 description "Connect to r7 em7.67"
set logical-systems r6 interfaces em6 unit 67 vlan-id 67
set logical-systems r6 interfaces em6 unit 67 family inet address 10.0.8.1/30

set logical-systems r6 interfaces lo0 unit 6 family inet address 10.0.6.6/32

Device MTU = 4000(This command do no support under the logical-systems level.)
root@JNCIP# set interfaces em6 mtu 


7. R7(logical-system r7) interfaces setting.
set logical-systems r7 interfaces em7 unit 57 description "Connect to r5 em5.57"
set logical-systems r7 interfaces em7 unit 57 vlan-id 57
set logical-systems r7 interfaces em7 unit 57 family inet address 10.0.8.10/30
set logical-systems r7 interfaces em7 unit 67 description "Connect to r6 em6.67"
set logical-systems r7 interfaces em7 unit 67 vlan-id 67
set logical-systems r7 interfaces em7 unit 67 family inet address 10.0.8.2/30
set logical-systems r7 interfaces lo0 unit 7 family inet address 10.0.6.7/32


8. ping Check:
root@JNCIP# run ping 10.0.x.x logical-system rx

Example:
root@JNCIP# run ping 10.0.5.2 logical-system r1                      
PING 10.0.5.2 (10.0.5.2): 56 data bytes
64 bytes from 10.0.5.2: icmp_seq=0 ttl=64 time=0.292 ms
^C
--- 10.0.5.2 ping statistics ---
1 packets transmitted, 1 packets received, 0% packet loss
round-trip min/avg/max/stddev = 0.292/0.292/0.292/0.000 ms


Final configuration:
root@JNCIP# show | display set | no-more
set version 12.1R1.9
set system host-name JNCIP
set system time-zone Asia/Taipei
set system authentication-order radius
set system ports auxiliary type vt100
set system root-authentication encrypted-password "$1$9xaCfeIA$DoMiHW7akhvyMpAHebr/R0"
set system radius-server 10.0.200.2 secret "$9$-DbYoDi.z39JG39ApREdbs"
set system login class NOC permissions view
set system login user lab uid 2000
set system login user lab class super-user
set system login user lab authentication encrypted-password "$1$q0M9ehlx$9XZkXwUuPJK1bVFie2FCS."
set system login user noc uid 2001
set system login user noc class NOC
set system login user noc authentication encrypted-password "$1$nutuTWm9$j40sAjOFPTImr7tm/6/pE1"
set system static-host-mapping proctor inet 10.0.200.1
set system services ssh root-login deny
set system services ssh protocol-version v2
set system services telnet
set system syslog user * any emergency
set system syslog host 10.0.200.2 interactive-commands any
set system syslog file messages any notice
set system syslog file messages authorization info
set system syslog file interactive-commands interactive-commands any
set system syslog file r1-cli interactive-commands any
set system syslog file r1-cli archive files 4
set system ntp boot-server 10.0.1.102
set system ntp authentication-key 200 type md5
set system ntp authentication-key 200 value "$9$PTF/uORlK8CtK8X7sYfTz"
set system ntp broadcast-client
set system ntp trusted-key 200
set logical-systems r1 interfaces em1 unit 12 description "Connect to r2 em2.12"
set logical-systems r1 interfaces em1 unit 12 vlan-id 12
set logical-systems r1 interfaces em1 unit 12 family inet address 10.0.4.5/30
set logical-systems r1 interfaces em1 unit 13 description "Connect to r3 em3.13"
set logical-systems r1 interfaces em1 unit 13 vlan-id 13
set logical-systems r1 interfaces em1 unit 13 family inet address 10.0.4.14/30
set logical-systems r1 interfaces em1 unit 120 description "Connect to r2 em2.120"
set logical-systems r1 interfaces em1 unit 120 vlan-id 120
set logical-systems r1 interfaces em1 unit 120 family inet address 10.0.5.1/24 vrrp-group 1 virtual-address 10.0.5.200
set logical-systems r1 interfaces em1 unit 120 family inet address 10.0.5.1/24 vrrp-group 1 authentication-type simple
set logical-systems r1 interfaces em1 unit 120 family inet address 10.0.5.1/24 vrrp-group 1 authentication-key "$9$y-8eMXaJDjqf"
set logical-systems r1 interfaces em1 unit 120 family inet address 10.0.5.1/24 vrrp-group 1 track interface em1.13 priority-cost 30
set logical-systems r1 interfaces lo0 unit 1 family inet address 10.0.6.1/32
set logical-systems r2 interfaces em2 unit 12 description "Connect to r1 em1.12"
set logical-systems r2 interfaces em2 unit 12 vlan-id 12
set logical-systems r2 interfaces em2 unit 12 family inet address 10.0.4.6/30
set logical-systems r2 interfaces em2 unit 23 description "Connect to r3 em3.23"
set logical-systems r2 interfaces em2 unit 23 vlan-id 23
set logical-systems r2 interfaces em2 unit 23 family inet address 10.0.4.2/30
set logical-systems r2 interfaces em2 unit 24 description "Connect to r4 em4.24"
set logical-systems r2 interfaces em2 unit 24 vlan-id 24
set logical-systems r2 interfaces em2 unit 24 family inet address 10.0.4.10/30
set logical-systems r2 interfaces em2 unit 120 description "Connect to r1 em1.120"
set logical-systems r2 interfaces em2 unit 120 vlan-id 120
set logical-systems r2 interfaces em2 unit 120 family inet address 10.0.5.2/24 vrrp-group 1 virtual-address 10.0.5.200
set logical-systems r2 interfaces em2 unit 120 family inet address 10.0.5.2/24 vrrp-group 1 priority 80
set logical-systems r2 interfaces em2 unit 120 family inet address 10.0.5.2/24 vrrp-group 1 authentication-type simple
set logical-systems r2 interfaces em2 unit 120 family inet address 10.0.5.2/24 vrrp-group 1 authentication-key "$9$w.2oGzF/9pB"
set logical-systems r2 interfaces lo0 unit 2 family inet address 10.0.6.2/32
set logical-systems r3 interfaces em3 unit 13 description "Connecto to r1 em1.13"
set logical-systems r3 interfaces em3 unit 13 vlan-id 13
set logical-systems r3 interfaces em3 unit 13 family inet address 10.0.4.13/30
set logical-systems r3 interfaces em3 unit 23 description "Connecto to r2 em2.23"
set logical-systems r3 interfaces em3 unit 23 vlan-id 23
set logical-systems r3 interfaces em3 unit 23 family inet address 10.0.4.1/30
set logical-systems r3 interfaces em3 unit 34 description "Connecto to r4 em4.34"
set logical-systems r3 interfaces em3 unit 34 vlan-id 34
set logical-systems r3 interfaces em3 unit 34 family inet address 10.0.2.5/30
set logical-systems r3 interfaces em3 unit 35 description "Connecto to r5 em5.35"
set logical-systems r3 interfaces em3 unit 35 vlan-id 35
set logical-systems r3 interfaces em3 unit 35 family inet address 10.0.2.2/30
set logical-systems r3 interfaces lo0 unit 3 family inet address 10.0.6.3/32
set logical-systems r4 interfaces em4 unit 24 description "Connect to r2 em2.24"
set logical-systems r4 interfaces em4 unit 24 vlan-id 24
set logical-systems r4 interfaces em4 unit 24 family inet address 10.0.4.9/30
set logical-systems r4 interfaces em4 unit 34 description "Connect to r3 em3.34"
set logical-systems r4 interfaces em4 unit 34 vlan-id 34
set logical-systems r4 interfaces em4 unit 34 family inet address 10.0.2.6/30
set logical-systems r4 interfaces em4 unit 45 description "Connect to r5 em5.45"
set logical-systems r4 interfaces em4 unit 45 vlan-id 45
set logical-systems r4 interfaces em4 unit 45 family inet address 10.0.2.10/30
set logical-systems r4 interfaces lo0 unit 4 family inet address 10.0.6.4/32
set logical-systems r5 interfaces em5 unit 35 description "Connect to r3 em3.35"
set logical-systems r5 interfaces em5 unit 35 vlan-id 35
set logical-systems r5 interfaces em5 unit 35 family inet address 10.0.2.1/30
set logical-systems r5 interfaces em5 unit 45 description "Connect to r4 em4.45"
set logical-systems r5 interfaces em5 unit 45 vlan-id 45
set logical-systems r5 interfaces em5 unit 45 family inet address 10.0.2.9/30
set logical-systems r5 interfaces em5 unit 56 description "Connect to r6 em6.56"
set logical-systems r5 interfaces em5 unit 56 vlan-id 56
set logical-systems r5 interfaces em5 unit 56 family inet address 10.0.8.6/30
set logical-systems r5 interfaces em5 unit 57 description "Connect to r7 em7.57"
set logical-systems r5 interfaces em5 unit 57 vlan-id 57
set logical-systems r5 interfaces em5 unit 57 family inet address 10.0.8.9/30
set logical-systems r5 interfaces lo0 unit 5 family inet address 10.0.6.5/32
set logical-systems r6 interfaces em6 unit 56 description "Connect to r5 em5.56"
set logical-systems r6 interfaces em6 unit 56 vlan-id 56
set logical-systems r6 interfaces em6 unit 56 family inet address 10.0.8.5/30
set logical-systems r6 interfaces em6 unit 67 description "Connect to r7 em7.67"
set logical-systems r6 interfaces em6 unit 67 vlan-id 67
set logical-systems r6 interfaces em6 unit 67 family inet address 10.0.8.1/30
set logical-systems r6 interfaces lo0 unit 6 family inet address 10.0.6.6/32
set logical-systems r7 interfaces em7 unit 57 description "Connect to r5 em5.57"
set logical-systems r7 interfaces em7 unit 57 vlan-id 57
set logical-systems r7 interfaces em7 unit 57 family inet address 10.0.8.10/30
set logical-systems r7 interfaces em7 unit 67 description "Connect to r6 em6.67"
set logical-systems r7 interfaces em7 unit 67 vlan-id 67
set logical-systems r7 interfaces em7 unit 67 family inet address 10.0.8.2/30
set logical-systems r7 interfaces lo0 unit 7 family inet address 10.0.6.7/32
set chassis alarm management-ethernet link-down ignore
set interfaces em0 unit 0 family inet address 10.0.1.1/24
set interfaces em1 vlan-tagging
set interfaces em2 vlan-tagging
set interfaces em3 vlan-tagging
set interfaces em4 vlan-tagging
set interfaces em5 vlan-tagging
set interfaces em6 vlan-tagging
set interfaces em7 vlan-tagging
set snmp interface em0.0
set snmp community public authorization read-only
set snmp community private authorization read-write
set snmp trap-group FOO version v1
set snmp trap-group FOO categories authentication
set snmp trap-group FOO targets 10.0.200.2
set routing-options static route 10.0.200.0/24 next-hop 10.0.1.102
set routing-options static route 10.0.200.0/24 no-readvertise

[edit]
root@JNCIP#


Reference:
Juniper Networks Certified Internet Professional Study Guide
Chapter 2 Case Study (p.129)

最初發表 / 最後更新: 2014.05.17 / 2018.06.15

0 comments:

張貼留言