Published 6月 12, 2018 by with 0 comment

CCNP-BCMSN-v5.0 Lab 4-2: Inter-VLAN Routing with an Internal Route Processor and Monitoring CEF Functions



!!!I used real Cisco 3550 switch *4 to do this lab. I did not use Dynamips to do this lab.!!!

Objective:
This lab routes between VLANs using a 3560 switch with an internal route
processor using Cisco Express Forwarding (CEF).

Scenario:
After VTP and trunking have been configured for the switches, Switched
Virtual Interfaces (SVI) are used on the distribution layer switch to
route between these VLANs, giving full connectivity to the internal network.

Basic Configuration:
DLS1 & ALS1-2:
enable
configure terminal
!
no ip domain lookup
!
line console 0
 logging synchronous
 exec-timeout 0 0
!
hostname


Step 1
Start by deleting the vlan.dat file, erasing the startup config, and reloading all your switches.
All Switches:
Clearing all Switches


Step 2
Configure the hostname, password, and telnet access on each switch.
DLS1(config)#hostname DLS1
DLS1(config)#enable secret cisco
DLS1(config)#line vty 0 15
DLS1(config-line)#password cisco
DLS1(config-line)#login
DLS1(config-line)#logging synchronous

ALS1(config)#hostname ALS1
ALS1(config)#enable secret cisco
ALS1(config)#line vty 0 15
ALS1(config-line)#password cisco
ALS1(config-line)#login
ALS1(config-line)#logging synchronous

ALS2(config)#hostname ALS2
ALS2(config)#enable secret cisco
ALS2(config)#line vty 0 15
ALS2(config-line)#password cisco
ALS2(config-line)#login
ALS2(config-line)#logging synchronous

Configure management IP addresses on VLAN 1 for all three switches
according to the diagram.
DLS1(config)#interface vlan 1
DLS1(config-if)#ip address 172.16.1.1 255.255.255.0
DLS1(config-if)#no shutdown

ALS1(config)#interface vlan 1
ALS1(config-if)#ip address 172.16.1.101 255.255.255.0
ALS1(config-if)#no shutdown

ALS2(config)#interface vlan 1
ALS2(config-if)#ip address 172.16.1.102 255.255.255.0
ALS2(config-if)#no shutdown

Configure default gateways on the access layer switches.
ALS1(config)#ip default-gateway 172.16.1.1

ALS2(config)#ip default-gateway 172.16.1.1


Step 3
Configure trunks and EtherChannels between switches.
DLS1(config)#interface range fastEthernet 0/7 - 8
DLS1(config-if-range)#switchport trunk encapsulation dot1q
DLS1(config-if-range)#switchport mode trunk
DLS1(config-if-range)#channel-group 1 mode desirable

DLS1(config)#interface range fastEthernet 0/9 - 10
DLS1(config-if-range)#switchport trunk encapsulation dot1q
DLS1(config-if-range)#switchport mode trunk
DLS1(config-if-range)#channel-group 2 mode desirable

ALS1(config)#interface range fastEthernet 0/7 - 8
ALS1(config-if-range)#switchport trunk encapsulation dot1q
ALS1(config-if-range)#switchport mode trunk
ALS1(config-if-range)#channel-group 1 mode desirable

ALS1(config)#interface range fastEthernet 0/11 - 12
ALS1(config-if-range)#switchport trunk encapsulation dot1q
ALS1(config-if-range)#switchport mode trunk              
ALS1(config-if-range)#channel-group 2 mode desirable      

ALS2(config)#interface range fastEthernet 0/9 - 10
ALS2(config-if-range)#switchport trunk encapsulation dot1q
ALS2(config-if-range)#switchport mode trunk
ALS2(config-if-range)#channel-group 1 mode desirable


ALS2(config)#interface range fastEthernet 0/11 - 12
ALS2(config-if-range)#switchport trunk encapsulation dot1q
ALS2(config-if-range)#switchport mode trunk
ALS2(config-if-range)#channel-group 2 mode desirable

DLS1#show interfaces trunk

Port        Mode             Encapsulation  Status        Native vlan
Po1         on               802.1q         trunking      1
Po2         on               802.1q         trunking      1

Port        Vlans allowed on trunk
Po1         1-4094
Po2         1-4094

Port        Vlans allowed and active in management domain
Po1         1
Po2         1

Port        Vlans in spanning tree forwarding state and not pruned
Po1         1
Po2         1
DLS1#
DLS1#show etherchannel summary
Flags:  D - down        P - bundled in port-channel
        I - stand-alone s - suspended
        H - Hot-standby (LACP only)
        R - Layer3      S - Layer2
        U - in use      f - failed to allocate aggregator

        M - not in use, minimum links not met
        u - unsuitable for bundling
        w - waiting to be aggregated
        d - default port


Number of channel-groups in use: 2
Number of aggregators:           2

Group  Port-channel  Protocol    Ports
------+-------------+-----------+-----------------------------------------------
1      Po1(SU)         PAgP      Fa0/7(P)    Fa0/8(P)  
2      Po2(SU)         PAgP      Fa0/9(P)    Fa0/10(P) 

DLS1#


Step 4
Change the VTP mode of ALS1 and ALS2 to client.
ALS1(config)#vtp mode client

ALS2(config)#vtp mode client

ALS1#show vtp status
VTP Version                     : running VTP1 (VTP2 capable)
Configuration Revision          : 0
Maximum VLANs supported locally : 1005
Number of existing VLANs        : 5
VTP Operating Mode              : Client
VTP Domain Name                 :
VTP Pruning Mode                : Disabled
VTP V2 Mode                     : Disabled
VTP Traps Generation            : Disabled
MD5 digest                      : 0x57 0xCD 0x40 0x65 0x63 0x59 0x47 0xBD
Configuration last modified by 0.0.0.0 at 0-0-00 00:00:00
ALS1#


Step 5
Create the VTP domain on DLS1 and create VLANS 100 and 200 for the
domain.
DLS1(config)#vtp domain SWPOD
DLS1(config)#vlan 100
DLS1(config-vlan)#name Finance
DLS1(config-vlan)#exit
DLS1(config)#vlan 200
DLS1(config-vlan)#name Engineering


Step 6
Configure the host ports for the appropriate VLANs according to the diagram.
ALS1(config)#interface fastEthernet 0/6
ALS1(config-if)#switchport access vlan 100
ALS1(config-if)#switchport mode access

ALS2(config)#interface fastEthernet 0/6
ALS2(config-if)#switchport access vlan 200
ALS2(config-if)#switchport mode access


Step 7
Create the Layer 3 VLAN interfaces to route between VLANs using the
interface vlan vlan-id command.
DLS1(config)#interface vlan 100
DLS1(config-if)#ip address 172.16.100.1 255.255.255.0
DLS1(config-if)#no shutdown

DLS1(config)#interface vlan 200
DLS1(config-if)#ip address 172.16.200.1 255.255.255.0
DLS1(config-if)#no shutdown

DLS1(config)#ip routing


Step 8
CEF is enabled by default on the 3550 switch.
DLS1#show ip cef summary
IPv4 CEF is enabled and running
VRF Default:
 19 prefixes (19/0 fwd/non-fwd)
 Table id 0
 Database epoch:        0 (19 entries at this epoch)

DLS1#

DLS1#show ip cef detail
DLS1#show ip interface vlan 100


Final Configurations
DLS1:
hostname DLS1
!
enable secret 5 $1$m8.P$KNho4tlgbJUx7amwPdOOa/
!
ip routing
!
no ip domain-lookup
!
interface Port-channel1
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface Port-channel2
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface FastEthernet0/7
 switchport trunk encapsulation dot1q
 switchport mode trunk
 channel-group 1 mode desirable
!
interface FastEthernet0/8
 switchport trunk encapsulation dot1q
 switchport mode trunk
 channel-group 1 mode desirable
!
interface FastEthernet0/9
 switchport trunk encapsulation dot1q
 switchport mode trunk
 channel-group 2 mode desirable
!       
interface FastEthernet0/10
 switchport trunk encapsulation dot1q
 switchport mode trunk
 channel-group 2 mode desirable
!
interface Vlan1
 ip address 172.16.1.1 255.255.255.0
 no shutdown
!
interface Vlan100
 ip address 172.16.100.1 255.255.255.0
 no shutdown
!
interface Vlan200
 ip address 172.16.200.1 255.255.255.0
 no shutdown
!
line con 0
 exec-timeout 0 0
 logging synchronous
line vty 0 4
 password cisco
 logging synchronous
 login
line vty 5 15
 password cisco
 logging synchronous
 login
!
end


ASL1:
hostname ALS1
!
enable secret 5 $1$GPpO$CJ9eHrozPRUjdfpOvGiwK.
!
no ip domain-lookup
!
interface Port-channel1
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface Port-channel2
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface FastEthernet0/6
 switchport access vlan 100
 switchport mode access
!
interface FastEthernet0/7
 switchport trunk encapsulation dot1q
 switchport mode trunk
 channel-group 1 mode desirable
!
interface FastEthernet0/8
 switchport trunk encapsulation dot1q
 switchport mode trunk
 channel-group 1 mode desirable
!
interface FastEthernet0/11
 switchport trunk encapsulation dot1q
 switchport mode trunk
 channel-group 2 mode desirable
!
interface FastEthernet0/12
 switchport trunk encapsulation dot1q
 switchport mode trunk
 channel-group 2 mode desirable
!
interface Vlan1
 ip address 172.16.1.101 255.255.255.0
 no shutdown
!
ip default-gateway 172.16.1.1
!
line con 0
 exec-timeout 0 0
 logging synchronous
line vty 0 4
 password cisco
 logging synchronous
 login
line vty 5 15
 password cisco
 logging synchronous
 login
!
end


ALS2:
hostname ALS2
!
enable secret 5 $1$Ysb4$Y3hSA9p1dri0i2dgaJyOv1
!
no ip domain-lookup
!
interface Port-channel1
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface Port-channel2
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface FastEthernet0/6
 switchport access vlan 200
 switchport mode access
!
interface FastEthernet0/9
 switchport trunk encapsulation dot1q
 switchport mode trunk
 channel-group 1 mode desirable
!
interface FastEthernet0/10
 switchport trunk encapsulation dot1q
 switchport mode trunk
 channel-group 1 mode desirable
!
interface FastEthernet0/11
 switchport trunk encapsulation dot1q
 switchport mode trunk
 channel-group 2 mode desirable
!
interface FastEthernet0/12
 switchport trunk encapsulation dot1q
 switchport mode trunk
 channel-group 2 mode desirable
!
interface Vlan1
 ip address 172.16.1.102 255.255.255.0
 no shutdown
!
ip default-gateway 172.16.1.1
!
line con 0
 exec-timeout 0 0
 logging synchronous
line vty 0 4
 password cisco
 logging synchronous
 login
line vty 5 15
 password cisco
 logging synchronous
 login
!
end


Reference:
Cisco Networking Academy
http://www.cisco.com/web/learning/netacad/index.html

CCNP Version 5.0: Building Multilayer Switched Networks
Student Lab Manual


最初發表 / 最後更新: 2008.10.11 / 2018.06.12

0 comments:

張貼留言