Published 6月 14, 2018 by with 0 comment

CCNP-ONT-v5.0 Lab 5.1: AutoQoS


Lab5-1.net file for Dynamips:

##################################################
#
# CCNP Version 5.0: Optimizing Converged Cisco Networks
# Lab 5.1 AutoQoS
# By Happy Peter  http://blog.xuite.net/juilin77/happy
#
##################################################

autostart=false
[localhost:7200]
workingdir = /opt/dynamips/dynagen-0.11.0/UTS/CCNP4/lab5-1/workingconfig/

[[2621]]
 # Specify 2621 IOS image on Linux here:
 image = /opt/dynamips/images/C2600-TS.BIN
 ram = 128
 # Choose an idlepc value from the below
 idlepc = 0x803f37cc
 mmap = true
 ghostios = true
 confreg = 0x2102

[[3725]]
# Specify 3725 IOS image on Linux here:
 image = /opt/dynamips/images/c3725-ad.bin
 ram = 256
 idlepc = 0x60bf8d58
 mmap = true
 ghostios = true
 confreg = 0x2102

###########################
#
# Define router instances 1
#
###########################

 [[Router R1]]
  model = 3725
  console = 2001
  slot1 = NM-4T
  s1/0 = R2 s1/0

 [[Router R2]]
  model = 3725
  console = 2002
  slot1 = NM-4T
  s1/1 = R3 s1/1

 [[Router R3]]
  model = 3725
  console = 2003
  slot1 = NM-4T

 [[Router TGN]]
  # tgn: 407554012371
  model = 2621
  console = 2004
  f0/0 = R1 f0/0
  f0/1 = R3 f0/0



Learning Objectives
‧ Configure AutoQoS Discovery
‧ Configure AutoQoS
‧ Verify AutoQoS behavior


Preparation:
http://blog.xuite.net/juilin77/happy/22909880

TGN(config)#interface fastEthernet 0/0
TGN(config-if)#ip address 172.16.10.4 255.255.255.0
TGN(config-if)#no shutdown

TGN(config)#interface fastEthernet 0/1
TGN(config-if)#ip address 172.16.20.4 255.255.255.0
TGN(config-if)#no shutdown

TGN to start generating traffic.
TGN#tgn

Loading Basic Pagent Configurations::
fastethernet0/0
add tcp
rate 1000
l2-dest $R1 F0/0 MAC$
l3-src 172.16.10.4
l3-dest 172.16.20.4
l4-dest 23
length random 16 to 1500
burst on
burst duration off 1000 to 2000
burst duration on 1000 to 3000
add fastethernet0/0 1
l4-dest 80
data ascii 0 GET /index.html HTTP/1.1
add fastethernet0/0 1
l4-dest 21
add fastethernet0/0 1
l4-dest 123
add fastethernet0/0 1
l4-dest 110
add fastethernet0/0 1
l4-dest 25
add fastethernet0/0 1
l4-dest 22
add fastethernet0/0 1
l4-dest 6000
!
end

TGN#tgn start


Step 1: Configure the Physical Interfaces

R1(config)#interface fastEthernet 0/0
R1(config-if)#ip address 172.16.10.1 255.255.255.0
R1(config-if)#no shutdown

R1(config)#interface serial 1/0
R1(config-if)#ip address 172.16.12.1 255.255.255.0
R1(config-if)#bandwidth 800
R1(config-if)#clock rate 806400
R1(config-if)#no shutdown

R2(config)#interface serial 1/0
R2(config-if)#ip address 172.16.12.2 255.255.255.0
R2(config-if)#bandwidth 800
R2(config-if)#no shutdown

R2(config)#interface serial 1/1
R2(config-if)#ip address 172.16.23.2 255.255.255.0
R2(config-if)#bandwidth 128
R2(config-if)#clock rate 128000
R2(config-if)#no shutdown

R3(config)#interface fastEthernet 0/0
R3(config-if)#ip address 172.16.20.3 255.255.255.0
R3(config-if)#no shutdown

R3(config)#interface serial 1/1
R3(config-if)#ip address 172.16.23.3 255.255.255.0
R3(config-if)#bandwidth 128
R3(config-if)#no shutdown


Step 2: Configure EIGRP AS 1
R1(config)#router eigrp 1
R1(config-router)#network 172.16.0.0 
R1(config-router)#no auto-summary

R2(config)#router eigrp 1
R2(config-router)#network 172.16.0.0
R2(config-router)#no auto-summary

R3(config)#router eigrp 1
R3(config-router)#network 172.16.0.0
R3(config-router)#no auto-summary


Step 3: Configure AutoQoS
Configure AutoQoS on R1’s Serial 1/0 interface so that the application can observe traffic passing through R1 toward R2.

R1(config)#interface serial 1/0
R1(config-if)#auto discovery qos

Let auto discovery run for a few minutes, and then peruse the traffic profile and suggested policy using the show auto discovery qos command.

R1#show auto discovery qos
Serial1/0           
 AutoQoS Discovery enabled for applications
 Discovery up time: 2 minutes, 51 seconds
 AutoQoS Class information:
 Class Voice:
  No data found.
 Class Interactive Video:
  No data found.
 Class Signaling:
  No data found.
 Class Streaming Video:
  No data found.
 Class Transactional:
  Recommended Minimum Bandwidth: 3445 Kbps/430% (AverageRate)
  Detected applications and data:
  Application/       AverageRate        PeakRate           Total           
  Protocol           (kbps/%)           (kbps/%)           (bytes)         
  -----------        -----------        --------           ------------    
  xwindows           1167/145           1606/200           24954154        
  telnet             1150/143           1449/181           24599539        
  ssh                1128/141           1360/170           24115985        
 Class Bulk:
  Recommended Minimum Bandwidth: 3343 Kbps/417% (AverageRate)
  Detected applications and data:
  Application/       AverageRate        PeakRate           Total           
  Protocol           (kbps/%)           (kbps/%)           (bytes)         
  -----------        -----------        --------           ------------    
  ftp                1155/144           1586/198           24709180        
  pop3               1119/139           1483/185           23924218        
  smtp               1069/133           1404/175           22867850        
 Class Scavenger:
  No data found.
 Class Management:
  No data found.
 Class Routing:
  Recommended Minimum Bandwidth: 0 Kbps/0% (AverageRate)
  Detected applications and data:
  Application/       AverageRate        PeakRate           Total           
  Protocol           (kbps/%)           (kbps/%)           (bytes)         
  -----------        -----------        --------           ------------    
  eigrp              0/0                0/0                2528            
 Class Best Effort:
  Current Bandwidth Estimation: 2222 Kbps/277% (AverageRate)
  Detected applications and data:
  Application/       AverageRate        PeakRate           Total           
  Protocol           (kbps/%)           (kbps/%)           (bytes)         
  -----------        -----------        --------           ------------    
  http               1120/140           1327/165           23958819        
  ntp                1102/137           1478/184           23564993        

Suggested AutoQoS Policy for the current uptime:
 !
 class-map match-any AutoQoS-Transactional-Se1/0
  match protocol xwindows
  match protocol telnet
  match protocol ssh
 !
 class-map match-any AutoQoS-Bulk-Se1/0
  match protocol ftp
  match protocol pop3
  match protocol smtp
 !
 policy-map AutoQoS-Policy-Se1/0
  class AutoQoS-Transactional-Se1/0
   bandwidth remaining percent 50
   random-detect dscp-based
   set dscp af21
  class AutoQoS-Bulk-Se1/0
   bandwidth remaining percent 48
   random-detect dscp-based
   set dscp af11
  class class-default
   fair-queue
R1#

Issue the auto qos command in interface configuration mode to implement the current AutoQoS-recommended configuration.

R1(config)#interface serial 1/0
R1(config-if)#auto qos

R1#show auto qos
 !
 policy-map AutoQoS-Policy-Se1/0
  class AutoQoS-Transactional-Se1/0
   bandwidth remaining percent 50
   random-detect dscp-based
   set dscp af21
  class AutoQoS-Bulk-Se1/0
   bandwidth remaining percent 48
   random-detect dscp-based
   set dscp af11
  class class-default
   fair-queue
 !
 class-map match-any AutoQoS-Transactional-Se1/0
  match protocol xwindows
  match protocol ssh
  match protocol telnet
 !
 class-map match-any AutoQoS-Bulk-Se1/0
  match protocol ftp
  match protocol smtp
  match protocol pop3

Serial1/0 -
 !
 interface Serial1/0
  service-policy output AutoQoS-Policy-Se1/0
R1#

Verify the statistics on the policy map using the show policy-map interface serial 1/0 command.
R1#show policy-map interface serial 1/0


Step 4: Configure AutoQoS with DSCP
In the previous step, you configured AutoQoS with a base configuration that classified traffic based on protocols. The configuration marked the packets with various DSCP values in addition to configuring CBWFQ. AutoQoS in an enterprise deployment can be configured to trust DSCP values from other routers and make QoS decisions based on those values.
Describe the efficiency of enabling AutoQoS on all routers in your network, but not configuring AutoQoS to trust markings from other routers:

R2(config)#interface serial 1/1
R2(config-if)#auto discovery qos trust

Wait a few minutes for auto discovery to capture statistics. Then, use the show auto discovery qos command to view the traffic patterns that AutoQoS has observed.

R2#show auto discovery qos
Serial1/1           
 AutoQoS Discovery enabled for trusted DSCP
 Discovery up time: 1 minutes, 5 seconds
 AutoQoS Class information:
 Class Voice:
  No data found.
 Class Interactive Video:
  No data found.
 Class Signaling:
  No data found.
 Class Streaming Video:
  No data found.
 Class Transactional:
  Recommended Minimum Bandwidth: 570 Kbps/445% (AverageRate)
  Detected DSCPs and data:
  DSCP value         AverageRate        PeakRate           Total           
                     (kbps/%)           (kbps/%)           (bytes)         
  -----------        -----------        --------           ------------    
  18/af21            570/445            651/508            4636046         
 Class Bulk:
  Recommended Minimum Bandwidth: 553 Kbps/432% (AverageRate)
  Detected DSCPs and data:
  DSCP value         AverageRate        PeakRate           Total           
                     (kbps/%)           (kbps/%)           (bytes)         
  -----------        -----------        --------           ------------    
  10/af11            553/432            640/500            4495765         
 Class Scavenger:
  No data found.
 Class Management:
  No data found.
 Class Routing:
  No data found.
 Class Best Effort:
  Current Bandwidth Estimation: 0 Kbps/0% (AverageRate)
  Detected DSCPs and data:
  DSCP value         AverageRate        PeakRate           Total           
                     (kbps/%)           (kbps/%)           (bytes)         
  -----------        -----------        --------           ------------    
  0/default          0/0                3/2                8106            

Suggested AutoQoS Policy for the current uptime:
 !
 class-map match-any AutoQoS-Transactional-Trust
  match ip dscp af21
  match ip dscp af22
  match ip dscp af23
 !      
 class-map match-any AutoQoS-Bulk-Trust
  match ip dscp af11
  match ip dscp af12
  match ip dscp af13
 !
 policy-map AutoQoS-Policy-Se1/1-Trust
  class AutoQoS-Transactional-Trust
   bandwidth remaining percent 50
   random-detect dscp-based
  class AutoQoS-Bulk-Trust
   bandwidth remaining percent 48
   random-detect dscp-based
  class class-default
   fair-queue
R2#

Notice that the output is very similar to the output in the previous step. However, this time, the statistics are based on DSCP values, not individual applications. Enable AutoQoS on the interface.

R2(config)#interface serial 1/1
R2(config-if)#auto qos

R2#show auto qos
 !
 policy-map AutoQoS-Policy-Se1/1-Trust
  class AutoQoS-Transactional-Trust
   bandwidth remaining percent 50
   random-detect dscp-based
  class AutoQoS-Bulk-Trust
   bandwidth remaining percent 48
   random-detect dscp-based
  class class-default
   fair-queue
 !
 class-map match-any AutoQoS-Bulk-Trust
  match ip dscp af11
  match ip dscp af12
  match ip dscp af13
 !
 class-map match-any AutoQoS-Transactional-Trust
  match ip dscp af21
  match ip dscp af22
  match ip dscp af23

Serial1/1 -
 !
 interface Serial1/1
  service-policy output AutoQoS-Policy-Se1/1-Trust
R2#


Final Configurations:
R1:
hostname R1
!
no ip domain lookup
!
policy-map AutoQoS-Policy-Se1/0
 class AutoQoS-Transactional-Se1/0
  bandwidth remaining percent 50
  random-detect dscp-based
  set dscp af21
 class AutoQoS-Bulk-Se1/0
  bandwidth remaining percent 48
  random-detect dscp-based
  set dscp af11
 class class-default
  fair-queue
!
interface FastEthernet0/0
 ip address 172.16.10.1 255.255.255.0
 no shutdown
!
interface Serial1/0
 bandwidth 800
 ip address 172.16.12.1 255.255.255.0
 auto qos
 auto discovery qos
 serial restart-delay 0
 clock rate 806400
 service-policy output AutoQoS-Policy-Se1/0
 no shutdown
!
router eigrp 1
 network 172.16.0.0
 no auto-summary
!
line con 0
 logging synchronous
!
end


R2:
hostname R2
!
no ip domain lookup
!
policy-map AutoQoS-Policy-Se1/1-Trust
 class AutoQoS-Transactional-Trust
  bandwidth remaining percent 50
  random-detect dscp-based
 class AutoQoS-Bulk-Trust
  bandwidth remaining percent 48
  random-detect dscp-based
 class class-default
  fair-queue
!
interface Serial1/0
 bandwidth 800
 ip address 172.16.12.2 255.255.255.0
 no shutdown
!
interface Serial1/1
 bandwidth 128
 ip address 172.16.23.2 255.255.255.0
 auto qos
 auto discovery qos trust
 serial restart-delay 0
 clock rate 128000
 service-policy output AutoQoS-Policy-Se1/1-Trust
 no shutdown
!       
router eigrp 1
 network 172.16.0.0
 no auto-summary
!
line con 0
 logging synchronous
!
end


R3:
hostname R3
!
no ip domain lookup
!
interface FastEthernet0/0
 ip address 172.16.20.3 255.255.255.0
 no shutdown
!
interface Serial1/1
 bandwidth 128
 ip address 172.16.23.3 255.255.255.0
 no shutdown
!
router eigrp 1
 network 172.16.0.0
 no auto-summary
!
line con 0
 logging synchronous
!
end


Reference:
Cisco Networking Academy
http://www.cisco.com/web/learning/netacad/index.html

CCNP Version 5.0: Optimizing Converged Cisco Networks
Student Lab Manual


最初發表 / 最後更新: 2009.05.20 / 2018.06.14

0 comments:

張貼留言