Published 6月 14, 2018 by with 0 comment

CCNP-ONT-v5.0 Lab 4.9: QoS Pre-classify


Lab4-9.net file for Dynamips:

##################################################
#
# CCNP Version 5.0: Optimizing Converged Cisco Networks
# Lab 4.9 QoS Pre-classify
# By Happy Peter  http://blog.xuite.net/juilin77/happy
#
##################################################

autostart=false
[localhost:7200]
workingdir = /opt/dynamips/dynagen-0.11.0/UTS/CCNP4/lab4-9/workingconfig/

[[2621]]
 # Specify 2621 IOS image on Linux here:
 image = /opt/dynamips/images/C2600-TS.BIN
 ram = 128
 # Choose an idlepc value from the below
 idlepc = 0x803f37cc
 mmap = true
 ghostios = true
 confreg = 0x2102

[[3725]]
# Specify 3725 IOS image on Linux here:
 image = /opt/dynamips/images/c3725-ad.bin
 ram = 256
 idlepc = 0x60bf8d58
 mmap = true
 ghostios = true
 confreg = 0x2102

###########################
#
# Define router instances 1
#
###########################

 [[Router R1]]
  model = 3725
  console = 2001
  slot1 = NM-4T
  s1/0 = R2 s1/0

 [[Router R2]]
  model = 3725
  console = 2002
  slot1 = NM-4T
  s1/1 = R3 s1/1

 [[Router R3]]
  model = 3725
  console = 2003
  slot1 = NM-4T

 [[Router TGN]]
  # tgn: 407554012371
  model = 2621
  console = 2004
  f0/0 = R1 f0/0
  f0/1 = R3 f0/0



Learning Objectives
‧ Configure a GRE tunnel
‧ Configure QoS pre-classify
‧ Verify QoS pre-classify operation


Preparation:

TGN(config)#interface fastEthernet 0/0
TGN(config-if)#ip address 172.16.10.4 255.255.255.0
TGN(config-if)#no shutdown

TGN(config)#interface fastEthernet 0/1
TGN(config-if)#ip address 172.16.20.4 255.255.255.0
TGN(config-if)#no shutdown

TGN to start generating traffic.
TGN#tgn

Loading these configurations:
fastethernet0/0
add tcp
rate 1000
l2-dest $R1 F0/0 MAC$
l3-src 172.16.10.4
l3-dest 172.16.20.4
l4-dest 23
length random 16 to 1500
burst on
burst duration off 1000 to 2000
burst duration on 1000 to 3000
add fastethernet0/0 1
l4-dest 80
data ascii 0 GET /index.html HTTP/1.1
add fastethernet0/0 1
l4-dest 21
add fastethernet0/0 1
l4-dest 123
add fastethernet0/0 1
l4-dest 110
add fastethernet0/0 1
l4-dest 25
add fastethernet0/0 1
l4-dest 22
add fastethernet0/0 1
l4-dest 6000
!
end

TGN#tgn start


Step 1: Configure the Physical Interfaces

R1(config)#interface fastEthernet 0/0
R1(config-if)#ip address 172.16.10.1 255.255.255.0
R1(config-if)#speed 100
R1(config-if)#duplex full
R1(config-if)#no shutdown

R1(config)#interface serial 1/0
R1(config-if)#ip address 192.168.12.1 255.255.255.0
R1(config-if)#bandwidth 800
R1(config-if)#clock rate 806400
R1(config-if)#no shutdown

R2(config)#interface serial 1/0
R2(config-if)#ip address 192.168.12.2 255.255.255.0
R2(config-if)#bandwidth 800
R2(config-if)#no shutdown

R2(config)#interface serial 1/1
R2(config-if)#ip address 192.168.23.2 255.255.255.0
R2(config-if)#bandwidth 128
R2(config-if)#clock rate 128000
R2(config-if)#no shutdown

R3(config)#interface fastEthernet 0/0
R3(config-if)#ip address 172.16.20.3 255.255.255.0
R3(config-if)#no shutdown

R3(config)#interface serial 1/1
R3(config-if)#ip address 192.168.23.3 255.255.255.0
R3(config-if)#bandwidth 128
R3(config-if)#no shutdown

Issue the show interfaces serial 1/0 | include Queueing command on R1 to verify that the queuing strategy is WFQ.

R1#show interfaces serial 1/0 | include Queueing
  Queueing strategy: weighted fair
R1#


Step 2: Configure Static Routing
Configure R1 and R3 with default routes towards R2.

R1(config)#ip route 0.0.0.0 0.0.0.0 192.168.12.2

R3(config)#ip route 0.0.0.0 0.0.0.0 192.168.23.2


Step 3: Configure the GRE Tunnel
Your company currently maintains a GRE tunnel through the ISP router R2 terminating at R1 and R3. Create the tunnel interfaces on both R1 and R3 and use the addresses in the 192.168.0.0/16 address range as the endpoints of the tunnel. Use IP addresses in the 172.16.23.0/24 subnet as the addressing for the tunnel interfaces themselves. R2 does not need to have routing information for the network addresses you use in your private network (172.16.0.0/16).

R1(config)#interface tunnel 0
R1(config-if)#tunnel source serial 1/0
R1(config-if)#tunnel destination 192.168.23.3
R1(config-if)#ip address 172.16.13.1 255.255.255.0

R3(config)#interface tunnel 0
R3(config-if)#tunnel source serial 1/1
R3(config-if)#tunnel destination 192.168.12.1
R3(config-if)#ip address 172.16.13.3 255.255.255.0
R3(config-if)#no shutdown

R1#ping 172.16.13.3

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.13.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 44/62/84 ms
R1#

R3#ping 172.16.13.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.13.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 40/59/84 ms
R3#


Step 4: Configure Routing
Configure routing between R1 and R3 using Enhanced Interior Gateway Routing Protocol (EIGRP). Include the entire 172.16.0.0/16 major network in AS 1 and disable automatic summarization.

R1(config)#router eigrp 1
R1(config-router)#network 172.16.0.0    
R1(config-router)#no auto-summary

R3(config)#router eigrp 1
R3(config-router)#network 172.16.0.0
R3(config-router)#no auto-summary


Step 5: Enable the QoS Pre-classify Feature
On R1, issue the show queue interface command to view the open conversations exiting the Serial 1/0 interface.

R1#show queue serial 1/0
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 527347
  Queueing strategy: weighted fair
  Output queue: 64/1000/64/527347 (size/max total/threshold/drops)
     Conversations  1/10/256 (active/max active/max total)
     Reserved Conversations 0/0 (allocated/max allocated)
     Available Bandwidth 600 kilobits/sec

  (depth/weight/total drops/no-buffer drops/interleaves) 64/32384/169641/0/0
  Conversation 38, linktype: ip, length: 1133
  source: 192.168.12.1, destination: 192.168.23.3, id: 0xF3E1, ttl: 255, prot: 47


R1#

QoS pre-classify allows traffic to be classified by the physical interface’s flow-based queuing strategy before being encapsulated so that the physical interface’s network bandwidth can be fairly distributed amongst distinct tunneled flows, and not only those tunneled flows that will be based on IP Precedence. This ensures that a disproportionate amount of tunneled traffic is not dropped or significantly delayed at the physical interface.
Enable the QoS pre-classify feature by issuing the qos pre-classify command in interface configuration mode for the tunnel interfaces.

R1(config)#interface tunnel 0
R1(config-if)#qos pre-classify

R3(config)#interface tunnel 0
R3(config-if)#qos pre-classify

Now, try looking at the queue contents of the serial interface.

R1#show queue serial 1/0
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 747923
  Queueing strategy: weighted fair
  Output queue: 69/1000/64/747923 (size/max total/threshold/drops)
     Conversations  6/10/256 (active/max active/max total)
     Reserved Conversations 0/0 (allocated/max allocated)
     Available Bandwidth 600 kilobits/sec

  (depth/weight/total drops/no-buffer drops/interleaves) 10/32384/58536/0/0
  Conversation 244, linktype: ip, length: 1222
  source: 172.16.10.4, destination: 172.16.20.4, id: 0x0000, ttl: 59,
  TOS: 0 prot: 6, source port 0, destination port 80

  (depth/weight/total drops/no-buffer drops/interleaves) 15/32384/57296/0/0
  Conversation 31, linktype: ip, length: 452
  source: 172.16.10.4, destination: 172.16.20.4, id: 0x0000, ttl: 59,
  TOS: 0 prot: 6, source port 0, destination port 123

  (depth/weight/total drops/no-buffer drops/interleaves) 12/32384/58094/0/0
  Conversation 185, linktype: ip, length: 420
  source: 172.16.10.4, destination: 172.16.20.4, id: 0x0000, ttl: 59,
  TOS: 0 prot: 6, source port 0, destination port 21

  (depth/weight/total drops/no-buffer drops/interleaves) 14/32384/57753/0/0
  Conversation 189, linktype: ip, length: 911
  source: 172.16.10.4, destination: 172.16.20.4, id: 0x0000, ttl: 59,
  TOS: 0 prot: 6, source port 0, destination port 25

  (depth/weight/total drops/no-buffer drops/interleaves) 13/32384/59958/0/0
  Conversation 187, linktype: ip, length: 595
  source: 172.16.10.4, destination: 172.16.20.4, id: 0x0000, ttl: 59,
  TOS: 0 prot: 6, source port 0, destination port 23

  (depth/weight/total drops/no-buffer drops/interleaves) 6/32384/174/0/0
  Conversation 164, linktype: ip, length: 1504
  source: 172.16.10.4, destination: 172.16.20.4, id: 0x0000, ttl: 59,
  TOS: 0 prot: 6, source port 0, destination port 21


R1#


Final Configurations:
hostname R1
!
!
no ip domain lookup
!
interface Tunnel0
 ip address 172.16.13.1 255.255.255.0
 qos pre-classify
 tunnel source Serial1/0
 tunnel destination 192.168.23.3
!
interface FastEthernet0/0
 ip address 172.16.10.1 255.255.255.0
 speed 100
 full-duplex
 no shutdown
!
interface Serial1/0
 bandwidth 800
 ip address 192.168.12.1 255.255.255.0
 clock rate 806400
 no shutdown
!
router eigrp 1
 network 172.16.0.0
 no auto-summary
!
ip route 0.0.0.0 0.0.0.0 192.168.12.2
!
line con 0
 logging synchronous
!
end


R2:
hostname R2
!
!
no ip domain lookup
!
interface Serial1/0
 bandwidth 800
 ip address 192.168.12.2 255.255.255.0
 no shutdown
!
interface Serial1/1
 bandwidth 128
 ip address 192.168.23.2 255.255.255.0
 clock rate 128000
 no shutdown
!
line con 0
 logging synchronous
!
end


R3:
hostname R3
!
!
no ip domain lookup
!
interface Tunnel0
 ip address 172.16.13.3 255.255.255.0
 qos pre-classify
 tunnel source Serial1/1
 tunnel destination 192.168.12.1
!
interface FastEthernet0/0
 ip address 172.16.20.3 255.255.255.0
 speed 100
 full-duplex
 no shutdown
!
interface Serial1/1
 bandwidth 128
 ip address 192.168.23.3 255.255.255.0
 no shutdown
!
router eigrp 1
 network 172.16.0.0
 no auto-summary
!
ip route 0.0.0.0 0.0.0.0 192.168.23.2
!
line con 0
 logging synchronous
!
end


Reference:
Cisco Networking Academy
http://www.cisco.com/web/learning/netacad/index.html

CCNP Version 5.0: Optimizing Converged Cisco Networks
Student Lab Manual


最初發表 / 最後更新: 2009.04.30 / 2018.06.14

0 comments:

張貼留言