Published 6月 14, 2018 by with 0 comment

CCNP-ONT-v5.0 Lab 4.7: WAN QoS Tools


Lab4-7.net file for Dynamips:

##################################################
#
# CCNP Version 5.0: Optimizing Converged Cisco Networks
# Lab 4.7 WAN QoS Tools
# By Happy Peter  http://blog.xuite.net/juilin77/happy
#
##################################################

autostart=false
[localhost:7200]
workingdir = /opt/dynamips/dynagen-0.11.0/UTS/CCNP4/lab4-7/workingconfig/

[[3725]]
# Specify 3725 IOS image on Linux here:
 image = /opt/dynamips/images/c3725-ad.bin
 ram = 256
 idlepc = 0x60bf8d58
 mmap = true
 ghostios = true
 confreg = 0x2102

###########################
#
# Define router instances 1
#
###########################

 [[Router R1]]
  model = 3725
  console = 2001

 [[Router R2]]
  model = 3725
  console = 2002
  slot1 = NM-4T

 [[Router R3]]
  model = 3725
  console = 2003
  slot1 = NM-4T
  s1/0 = R2 s1/0
  s1/1 = R4 s1/1
  s1/2 = R4 s1/2

 [[Router R4]]
  model = 3725
  console = 2004
  slot1 = NM-4T

 [[Router SW1]]
  model = 3725
  console = 2005
  slot1 = NM-16ESW
  f1/1 = R1 f0/0
  f1/2 = R1 f0/1
  f1/3 = R2 f0/0
  f1/7 = R4 f0/0
  f1/8 = R4 f0/1



Learning Objectives
‧ Configure Multilink PPP
‧ Configure Multilink PPP Link Fragmentation and Interleaving
‧ Configure Generic Traffic Shaping
‧ Configure Committed Access Rate policing

!!!! This lab use 3725 router*4, because Dymanips 2620 tgn router do not support ppp multilink. !!!!

Preparation:

ALS1:
ALS1(config)#no ip routing
ALS1(config)#no ip domain lookup
ALS1(config)#line console 0
ALS1(config-line)#logging synchronous

ALS1#vlan database
ALS1(vlan)#vlan 10 name VL10
ALS1(vlan)#vlan 20 name VL20
ALS1(vlan)#vlan 30 name VL30
ALS1(vlan)#apply
ALS1(vlan)#exit

ALS1(config)#interface fastEthernet 1/1
ALS1(config-if)#description To_R1F0/0
ALS1(config-if)#switchport mode access
ALS1(config-if)#switchport access vlan 10

ALS1(config)#interface fastEthernet 1/2
ALS1(config-if)#description To_R1F0/1   
ALS1(config-if)#switchport mode access  
ALS1(config-if)#switchport access vlan 30

ALS1(config)#interface fastEthernet 1/3
ALS1(config-if)#description To_R2F0/0   
ALS1(config-if)#switchport mode access  
ALS1(config-if)#switchport access vlan 20

ALS1(config)#interface fastEthernet 1/7
ALS1(config-if)#description To_TGNF0/0  
ALS1(config-if)#switchport mode trunk
ALS1(config-if)#switchport trunk encapsulation dot1q

ALS1(config)#interface fastEthernet 1/8         
ALS1(config-if)#description To_TGNF0/1             
ALS1(config-if)#switchport mode access             
ALS1(config-if)#switchport access vlan 30

R4:
R4(config)#ip cef
R4(config)#ip vrf PAGENT

R4(config-vrf)#interface fastEthernet 0/0
R4(config-if)#speed 100
R4(config-if)#duplex full
R4(config-if)#no shutdown

R4(config-if)#interface fastEthernet 0/0.10
R4(config-subif)#description Interface generating traffic
R4(config-subif)#encapsulation dot1Q 10
R4(config-subif)#ip vrf forwarding PAGENT
R4(config-subif)#ip address 172.16.10.4 255.255.255.0

R4(config-subif)#interface fastEthernet 0/0.20
R4(config-subif)#description capturing traffic
R4(config-subif)#encapsulation dot1Q 20
R4(config-subif)#ip vrf forwarding PAGENT
R4(config-subif)#ip address 172.16.20.4 255.255.255.0

R4(config-subif)#interface fastEthernet 0/1
R4(config-if)#ip address 172.16.14.4 255.255.255.0
R4(config-if)#speed 100
R4(config-if)#duplex full
R4(config-if)#no shutdown


Step 1: Configure the Physical Interfaces
Set the clock rate on the serial link between R2 and R3 to 64 kbps and use the no shutdown command on all interfaces. Set the informational bandwidth parameter appropriately on the R2-R3 serial interfaces.

R1(config)#interface fastEthernet 0/0
R1(config-if)#ip address 172.16.10.1 255.255.255.0
R1(config-if)#speed 100
R1(config-if)#duplex full
R1(config-if)#no shutdown

R1(config)#interface fastEthernet 0/1
R1(config-if)#ip address 172.16.14.1 255.255.255.0
R1(config-if)#speed 100
R1(config-if)#duplex full
R1(config-if)#no shutdown

R2(config)#interface fastEthernet 0/0
R2(config-if)#ip address 172.16.20.2 255.255.255.0
R2(config-if)#speed 100
R2(config-if)#duplex full
R2(config-if)#no shutdown

R2(config)#interface serial 1/0
R2(config-if)#ip address 172.16.23.2 255.255.255.0
R2(config-if)#clock rate 64000
R2(config-if)#bandwidth 64
R2(config-if)#no shutdown

R3(config)#interface serial 1/0
R3(config-if)#ip address 172.16.23.3 255.255.255.0    
R3(config-if)#bandwidth 64
R3(config-if)#no shutdown


Step 2: Configure Multilink PPP
For this lab, use multilink PPP to aggregate the two serial links between R3 and R4. They will be set up to be 64 kbps links individually, but their multilink logical connection will be 128 kbps.

R3(config)#interface serial 1/1
R3(config-if)#encapsulation ppp
R3(config-if)#ppp multilink
R3(config-if)#ppp multilink group 1
R3(config-if)#clock rate 64000
R3(config-if)#bandwidth 64
R3(config-if)#no shutdown

R3(config)#interface serial 1/2
R3(config-if)#encapsulation ppp
R3(config-if)#ppp multilink
R3(config-if)#ppp multilink group 1
R3(config-if)#clock rate 64000
R3(config-if)#bandwidth 64
R3(config-if)#no shutdown

R4(config)#interface serial 1/1
R4(config-if)#encapsulation ppp
R4(config-if)#ppp multilink
R4(config-if)#ppp multilink group 1
R4(config-if)#bandwidth 64
R4(config-if)#no shutdown

R4(config)#interface serial 1/2
R4(config-if)#encapsulation ppp
R4(config-if)#ppp multilink
R4(config-if)#ppp multilink group 1
R4(config-if)#bandwidth 64
R4(config-if)#no shutdown

Issue the interface multilink number command in global configuration mode to enter configuration mode for the multilink interface.

R3(config)#interface multilink 1
R3(config-if)#ip address 172.16.34.3 255.255.255.0

R4(config)#interface multilink 1
R4(config-if)#ip address 172.16.34.4 255.255.255.0

Verify that you can ping across the link. If not, troubleshoot.

R3#ping 172.16.34.4

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.34.4, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/8/16 ms

R4#ping 172.16.34.3

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.34.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/8/12 ms

To look at PPP multilink statistics, use the PPP-specific command show ppp multilink. The bandwidth shown in this output is the sum of the individual link bandwidths.

R3#show ppp multilink

Multilink1
  Bundle name: R4
  Remote Endpoint Discriminator: [1] R4
  Local Endpoint Discriminator: [1] R3
  Bundle up for 00:01:57, total bandwidth 128, load 1/255
  Receive buffer limit 24000 bytes, frag timeout 1500 ms
    0/0 fragments/bytes in reassembly list
    0 lost fragments, 0 reordered
    0/0 discarded fragments/bytes, 0 lost received
    0x1E received sequence, 0x1D sent sequence
  Member links: 2 active, 0 inactive (max not set, min not set)
    Se1/1, since 00:01:58
    Se1/2, since 00:01:58
No inactive multilink interfaces
R3#

R4#show ppp multilink

Multilink1
  Bundle name: R3
  Remote Endpoint Discriminator: [1] R3
  Local Endpoint Discriminator: [1] R4
  Bundle up for 00:02:17, total bandwidth 128, load 1/255
  Receive buffer limit 24000 bytes, frag timeout 1500 ms
    0/0 fragments/bytes in reassembly list
    0 lost fragments, 13 reordered
    0/0 discarded fragments/bytes, 0 lost received
    0x1F received sequence, 0x20 sent sequence
  Member links: 2 active, 0 inactive (max not set, min not set)
    Se1/1, since 00:02:17
    Se1/2, since 00:02:17
No inactive multilink interfaces
R4#

R3#show interfaces multilink 1
Multilink1 is up, line protocol is up
  Hardware is multilink group interface
  Internet address is 172.16.34.3/24
  MTU 1500 bytes, BW 128 Kbit/sec, DLY 100000 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation PPP, LCP Open, multilink Open
  Open: IPCP, CDPCP, loopback not set
  Keepalive set (10 sec)
  DTR is pulsed for 2 seconds on reset
  Last input 00:00:51, output never, output hang never
  Last clearing of "show interface" counters 00:03:37
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     19 packets input, 2472 bytes, 0 no buffer
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
     20 packets output, 2654 bytes, 0 underruns
     0 output errors, 0 collisions, 1 interface resets
     0 output buffer failures, 0 output buffers swapped out
     0 carrier transitions
R3#

R4#show interfaces multilink 1
Multilink1 is up, line protocol is up
  Hardware is multilink group interface
  Internet address is 172.16.34.4/24
  MTU 1500 bytes, BW 128 Kbit/sec, DLY 100000 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation PPP, LCP Open, multilink Open
  Open: IPCP, CDPCP, loopback not set
  Keepalive set (10 sec)
  DTR is pulsed for 2 seconds on reset
  Last input 00:00:14, output never, output hang never
  Last clearing of "show interface" counters 00:03:24
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     21 packets input, 2772 bytes, 0 no buffer
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
     21 packets output, 3068 bytes, 0 underruns
     0 output errors, 0 collisions, 1 interface resets
     0 output buffer failures, 0 output buffers swapped out
     0 carrier transitions
R4#


Step 3: Configure Multilink PPP LFI
Shut down the multilink interface to prevent link flapping while you configure LFI. Next, change the queuing strategy on the multilink interface from FIFO to weighted fair queuing (WFQ) with the fair-queue command in interface configuration mode. Set the interleaving fragment delay with the ppp multilink fragment delay milliseconds command. Reduce the maximum delay to 15 ms from the default 30 ms. This delay setting controls the maximum size to which packets must be fragmented, attempting to avoid negative results in delay-sensitive applications.
Enable MLPPP interleaving with the ppp multilink interleave command. Finally, bring the interface back up.

R3(config)#interface multilink 1
R3(config-if)#shutdown
R3(config-if)#fair-queue
R3(config-if)#ppp multilink fragment delay 15
R3(config-if)#ppp multilink interleave
R3(config-if)#no shutdown

R4(config)#interface multilink 1
R4(config-if)#shutdown
R4(config-if)#fair-queue
R4(config-if)#ppp multilink fragment delay 15
R4(config-if)#ppp multilink interleave
R4(config-if)#no shutdown

Issue the show ppp multilink command to view the LFI configuration.

R3#show ppp multilink

Multilink1
  Bundle name: R4
  Remote Endpoint Discriminator: [1] R4
  Local Endpoint Discriminator: [1] R3
  Bundle up for 00:00:50, total bandwidth 128, load 1/255
  Receive buffer limit 24000 bytes, frag timeout 1500 ms
  Interleaving enabled
    0/0 fragments/bytes in reassembly list
    0 lost fragments, 0 reordered
    0/0 discarded fragments/bytes, 0 lost received
    0x6 received sequence, 0x8 sent sequence
  Member links: 2 active, 0 inactive (max not set, min not set)
    Se1/1, since 00:00:51, 120 weight, 112 frag size
    Se1/2, since 00:00:51, 120 weight, 112 frag size
No inactive multilink interfaces
R3#

R4#show ppp multilink

Multilink1
  Bundle name: R3
  Remote Endpoint Discriminator: [1] R3
  Local Endpoint Discriminator: [1] R4
  Bundle up for 00:01:44, total bandwidth 128, load 1/255
  Receive buffer limit 24000 bytes, frag timeout 1500 ms
  Interleaving enabled
    0/0 fragments/bytes in reassembly list
    1 lost fragments, 3 reordered
    0/0 discarded fragments/bytes, 0 lost received
    0xB received sequence, 0xA sent sequence
  Member links: 2 active, 0 inactive (max not set, min not set)
    Se1/1, since 00:01:45, 120 weight, 112 frag size
    Se1/2, since 00:01:45, 120 weight, 112 frag size
No inactive multilink interfaces
R4#


Step 4: Configure Routing
Establish adjacencies for routing with Open Shortest Path First (OSPF). Include all connected subnets within the 172.16.0.0/16 major network for all four routers.

R1(config)#router ospf 1
R1(config-router)#network 172.16.0.0 0.0.255.255 area 0

R2(config)#router ospf 1
R2(config-router)#network 172.16.0.0 0.0.255.255 area 0

R3(config)#router ospf 1
R3(config-router)#network 172.16.0.0 0.0.255.255 area 0

R4(config)#router ospf 1
R4(config-router)#network 172.16.0.0 0.0.255.255 area 0


Step 5: Configure Generic Traffic Shaping
Imagine that R3 is owned by an ISP. You have added another 64 kbps serial link from R3 to R4 to the multilink group. However, according to your traffic contract, the ISP is only responsible to forward traffic from you at a committed information rate (CIR) of 128 kbps over this PPP multilink interface. Any excess traffic may be dropped by the ISP without warning.
Understanding that your excess traffic may be dropped, you wish to minimize the effect any policing in the provider network by configuring traffic shaping at the exit to your network, R4’s multilink PPP interface.
Configure traffic shaping on R4’s multilink interface towards R3 and shape the flow of traffic to a rate of 128 kbps. Issue the traffic-shape rate rate command in interface configuration mode. Set the rate argument to 128 kbps. The traffic will be buffered in software by the traffic-shaping.

R4(config)#interface multilink 1
R4(config-if)#traffic-shape rate 128000

R4#show traffic-shape

Interface   Mu1
       Access Target    Byte   Sustain   Excess    Interval  Increment Adapt
VC     List   Rate      Limit  bits/int  bits/int  (ms)      (bytes)   Active
-             128000    1984   7936      7936      62        992       - 
R4#

R4#show traffic-shape statistics
                  Acc. Queue Packets   Bytes     Packets   Bytes     Shaping
I/F               List Depth                     Delayed   Delayed   Active
Mu1                     0     9         1216      0         0         no
R4#


Step 6: Configure Committed Access Rate Policing
Set R3’s Serial 1/0 interface to police egress traffic to 56 kbps with a normal burst size of 1500 bytes and a maximum burst size of 4000 bytes. Issue the rate-limit direction bps normal-burst maxmium-burst conform-action action exceed-action action command. When packets conform to the policy, send them by using the continue keyword. When packets do not, drop them.
This command may cause the Open Shortest Path First (OSPF) adjacency between R2 and R3 to "flap" (go down and then back up) periodically, because some of the OSPF hello packets get dropped through CAR, despite WFQ on the interface.

R3(config)#interface serial 1/0
R3(config-if)#rate-limit output 56000 1500 4000 conform-action continue exceed-action drop

Verify with the command show interfaces rate-limit.

R3#show interfaces rate-limit
Serial1/0
  Output
    matches: all traffic
      params:  56000 bps, 1500 limit, 4000 extended limit
      conformed 7 packets, 588 bytes; action: continue
      exceeded 0 packets, 0 bytes; action: drop
      last packet: 5168ms ago, current burst: 0 bytes
      last cleared 00:01:05 ago, conformed 0 bps, exceeded 0 bps
R3#


Final Configurations:
R1:
hostname R1
!
!
no ip domain lookup
!
interface FastEthernet0/0
 ip address 172.16.10.1 255.255.255.0
 speed 100
 full-duplex
 no shutdown
!
interface FastEthernet0/1
 ip address 172.16.14.1 255.255.255.0
 speed 100
 full-duplex
 no shutdown
!
router ospf 1
 network 172.16.0.0 0.0.255.255 area 0
!       
line con 0
 logging synchronous
!
end


R2:
hostname R2
!
!
no ip domain lookup
!
interface FastEthernet0/0
 ip address 172.16.20.2 255.255.255.0
 speed 100
 full-duplex
 no shutdown
!
interface Serial1/0
 bandwidth 64
 ip address 172.16.23.2 255.255.255.0
 clock rate 64000
 no shutdown
!
router ospf 1
 network 172.16.0.0 0.0.255.255 area 0
!
line con 0
 logging synchronous
!
end


R3:
hostname R3
!
no ip domain lookup
!
interface Multilink1
 ip address 172.16.34.3 255.255.255.0
 fair-queue
 ppp multilink
 ppp multilink interleave
 ppp multilink group 1
 ppp multilink fragment delay 15
!
interface Serial1/0
 bandwidth 64
 ip address 172.16.23.3 255.255.255.0
 rate-limit output 56000 1500 4000 conform-action continue exceed-action drop
 no shutdown
!
interface Serial1/1
 bandwidth 64
 no ip address
 encapsulation ppp
 serial restart-delay 0
 clock rate 64000
 ppp multilink
 ppp multilink group 1
 no shutdown
!
interface Serial1/2
 bandwidth 64
 no ip address
 encapsulation ppp
 serial restart-delay 0
 clock rate 64000
 ppp multilink
 ppp multilink group 1
 no shutdown
!
router ospf 1
 network 172.16.0.0 0.0.255.255 area 0
!
line con 0
 logging synchronous
!
end


R4:
hostname R4
!
ip cef
!
ip vrf PAGENT
!
no ip domain lookup
!
interface Multilink1
 ip address 172.16.34.4 255.255.255.0
 fair-queue
 traffic-shape rate 128000 7936 7936 1000
 ppp multilink
 ppp multilink interleave
 ppp multilink group 1
 ppp multilink fragment delay 15
!
interface FastEthernet0/0
 no ip address
 speed 100
 full-duplex
 no shutdown
!
interface FastEthernet0/0.10
 description Interface generating traffic
 encapsulation dot1Q 10
 ip vrf forwarding PAGENT
 ip address 172.16.10.4 255.255.255.0
!
interface FastEthernet0/0.20
 description capturing traffic
 encapsulation dot1Q 20
 ip vrf forwarding PAGENT
 ip address 172.16.20.4 255.255.255.0
!
interface FastEthernet0/1
 ip address 172.16.14.4 255.255.255.0
 speed 100
 full-duplex
 no shutdown
!
interface Serial1/1
 bandwidth 64
 no ip address
 encapsulation ppp
 serial restart-delay 0
 ppp multilink
 ppp multilink group 1
 no shutdown
!
interface Serial1/2
 bandwidth 64
 no ip address
 encapsulation ppp
 serial restart-delay 0
 ppp multilink
 ppp multilink group 1
 no shutdown
!
router ospf 1
 network 172.16.0.0 0.0.255.255 area 0
!
line con 0
 logging synchronous
!
end


Reference:
Cisco Networking Academy
http://www.cisco.com/web/learning/netacad/index.html

CCNP Version 5.0: Optimizing Converged Cisco Networks
Student Lab Manual


最初發表 / 最後更新: 2009.04.30 / 2018.06.14

0 comments:

張貼留言