Published 6月 14, 2018 by with 0 comment

CCNP-ONT-v5.0 Lab 4.1: Default Queuing Tools


Lab4-1.net file for Dynamips:

##################################################
#
# CCNP Version 5.0: Optimizing Converged Cisco Networks
# For Lab 4.1 Default Queuing Tools
# By Happy Peter  http://blog.xuite.net/juilin77/happy
#
##################################################

autostart=false
[localhost:7200]
workingdir = /opt/dynamips/dynagen-0.11.0/UTS/CCNP4/lab4-1/workingconfig/

[[2621]]
 # Specify 2621 IOS image on Linux here:
 image = /opt/dynamips/images/C2600-TS.BIN
 ram = 128
 # Choose an idlepc value from the below
 idlepc = 0x803f37cc
 mmap = true
 ghostios = true
 confreg = 0x2102

[[3725]]
# Specify 3725 IOS image on Linux here:
 image = /opt/dynamips/images/c3725-ad.bin
 ram = 256
 idlepc = 0x60bf8d58
 mmap = true
 ghostios = true
 confreg = 0x2102

###########################
#
# Define router instances 1
#
###########################

 [[Router R1]]
  model = 3725
  console = 2001
  slot1 = NM-4T
  s1/0 = R2 s1/0

 [[Router R2]]
  model = 3725
  console = 2002
  slot1 = NM-4T

 [[Router TGN]]
  # tgn: 407554012371
  model = 2621
  console = 2003
  F0/0 = R1 F0/0
  F0/1 = R2 F0/0



Learning Objectives
‧ Verify interface queuing configuration
‧ Observe statistics over multiple software queues
‧ Consider differences between FIFO and WFQ
‧ Change interface queuing types


Preparation:

TGN(config)#interface fastEthernet 0/0
TGN(config-if)#ip address 172.16.10.4 255.255.255.0
TGN(config-if)#no shutdown

TGN(config)#interface fastEthernet 0/1
TGN(config-if)#ip address 172.16.20.4 255.255.255.0
TGN(config-if)#no shutdown

TGN to start generating traffic.
TGN#tgn

Loading these configurations:
fastethernet0/0
add tcp
rate 1000
l2-dest c200.28d1.0000
l3-src 172.16.10.4
l3-dest 172.16.20.4
l4-dest 23
length random 16 to 1500
burst on
burst duration off 1000 to 2000
burst duration on 1000 to 3000
add fastethernet0/0 1
l4-dest 80
data ascii 0 GET /index.html HTTP/1.1
add fastethernet0/0 1
l4-dest 21
add fastethernet0/0 1
l4-dest 123
add fastethernet0/0 1
l4-dest 110
add fastethernet0/0 1
l4-dest 25
add fastethernet0/0 1
l4-dest 22
add fastethernet0/0 1
l4-dest 6000
!
end

TGN#tgn start


Step 1: Configure Addressing
R1(config)#interface fastEthernet 0/0
R1(config-if)#ip address 172.16.10.1 255.255.255.0
R1(config-if)#no shutdown

R1(config)#interface serial 1/0
R1(config-if)#ip address 172.16.12.1 255.255.255.0
R1(config-if)#clock rate 806400
R1(config-if)#no shutdown

R2(config)#interface fastEthernet 0/0
R2(config-if)#ip address 172.16.20.2 255.255.255.0
R2(config-if)#no shutdown

R2(config)#interface serial 1/0
R2(config-if)#ip address 172.16.12.2 255.255.255.0
R2(config-if)#no shutdown


The bandwidth command assigns an informational value that will not be used at the physical layer, but will be communicated to and used by upper-layer protocols.

If you were to enable weighted fair queuing (WFQ) on a Fast Ethernet interface, you would find that the following bandwidth information would be shown.
R1(config)#interface fastEthernet 0/0
R1(config-if)#fair-queue

R1#show interfaces fastEthernet 0/0

R1(config)#interface fastEthernet 0/0
R1(config-if)#no fair-queue

You can use the max-reserved-bandwidth command. The percent argument specifies the maximum percentage of the total interface bandwidth that can be used. (default is 75)
R1(config-if)#max-reserved-bandwidth 75

Configure the bandwidth parameter on the serial interface to match the access rate of the interface.
R1(config)#interface serial 1/0
R1(config-if)#bandwidth 800

R2(config)#interface serial 1/0
R2(config-if)#bandwidth 800


Step 2: Configure EIGRP AS 1
R1(config)#router eigrp 1
R1(config-router)#network 172.16.0.0
R1(config-router)#no auto-summary

R2(config)#router eigrp 1
R2(config-router)#network 172.16.0.0
R2(config-router)#no auto-summary


Step 3: Contrast Interface Queuing Strategies
Congestion management features can help smaller packets sneak ahead of larger ones, as in WFQ, but if the queues are always packed, the result is that packets that are forwarded are forwarded with greater delays and the packets
that are not forwarded are dropped.

R1#show interfaces serial 1/0
Serial1/0 is up, line protocol is up
  Hardware is M4T
  Internet address is 172.16.12.1/24
  MTU 1500 bytes, BW 800 Kbit/sec, DLY 20000 usec,
     reliability 255/255, txload 63/255, rxload 1/255
  Encapsulation HDLC, crc 16, loopback not set
  Keepalive set (10 sec)
  Restart-Delay is 0 secs
  CRC checking enabled
  Last input 00:00:00, output 00:00:00, output hang never
  Last clearing of "show interface" counters 00:17:05
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 1617672
  Queueing strategy: weighted fair
  Output queue: 69/1000/64/1617672 (size/max total/threshold/drops)
     Conversations  7/9/256 (active/max active/max total)
     Reserved Conversations 0/0 (allocated/max allocated)
     Available Bandwidth 600 kilobits/sec
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 1003000 bits/sec, 227 packets/sec
     344 packets input, 22540 bytes, 0 no buffer
     Received 121 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
     233725 packets output, 107246852 bytes, 0 underruns
     0 output errors, 0 collisions, 0 interface resets
     0 output buffer failures, 0 output buffers swapped out
     0 carrier transitions     DCD=up  DSR=up  DTR=up  RTS=up  CTS=up


R2#show interfaces fastEthernet 0/0
FastEthernet0/0 is up, line protocol is up
  Hardware is Gt96k FE, address is c201.28d1.0000 (bia c201.28d1.0000)
  Internet address is 172.16.20.2/24
  MTU 1500 bytes, BW 10000 Kbit/sec, DLY 1000 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  Full-duplex, 100Mb/s, 100BaseTX/FX
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input 00:00:58, output 00:00:04, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 7494625
  Queueing strategy: fifo
  Output queue: 40/40 (size/max)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 11000 bits/sec, 7 packets/sec
     172 packets input, 60081 bytes
     Received 171 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 watchdog
     0 input packets with dribble condition detected
     48050 packets output, 27803711 bytes, 0 underruns
     0 output errors, 0 collisions, 586 interface resets
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier
     0 output buffer failures, 0 output buffers swapped out


Step 4: Verify and Change Queuing Modes
The reason you achieve successful results though bulk traffic is also traversing the link is that WFQ provisions traffic on

a per-flow basis.
R1#ping 172.16.12.2 repeat 100

Type escape sequence to abort.
Sending 100, 100-byte ICMP Echos to 172.16.12.2, timeout is 2 seconds:
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
Success rate is 100 percent (100/100), round-trip min/avg/max = 20/34/64 ms

R1#show interfaces serial 1/0
Serial1/0 is up, line protocol is up
  Hardware is M4T
  Internet address is 172.16.12.1/24
  MTU 1500 bytes, BW 800 Kbit/sec, DLY 20000 usec,
     reliability 255/255, txload 250/255, rxload 1/255
  Encapsulation HDLC, crc 16, loopback not set
  Keepalive set (10 sec)
  Restart-Delay is 0 secs
  CRC checking enabled
  Last input 00:00:01, output 00:00:00, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 2571299
  Queueing strategy: weighted fair
  Output queue: 70/1000/64/2571299 (size/max total/threshold/drops)
     Conversations  7/9/256 (active/max active/max total)
     Reserved Conversations 0/0 (allocated/max allocated)
     Available Bandwidth 600 kilobits/sec
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 785000 bits/sec, 204 packets/sec
     963 packets input, 68371 bytes, 0 no buffer
     Received 466 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
     369298 packets output, 169413086 bytes, 0 underruns
     0 output errors, 0 collisions, 4 interface resets
     0 output buffer failures, 0 output buffers swapped out
     5 carrier transitions     DCD=up  DSR=up  DTR=up  RTS=up  CTS=up

One of these is the show queueing command, which gives an overview of different interfaces queuing strategies.
R1#show queueing
Current fair queue configuration:

  Interface           Discard    Dynamic  Reserved  Link    Priority
                      threshold  queues   queues    queues  queues
  Serial1/0           64         256      0         8       1  
  Serial1/1           64         256      0         8       1  
  Serial1/2           64         256      0         8       1  
  Serial1/3           64         256      0         8       1  

Current DLCI priority queue configuration:
Current priority queue configuration:
Current custom queue configuration:
Current random-detect configuration:
Current per-SID queue configuration:
R1#

The show queue interface command displays detailed information about individual queues for an interface.
R1#show queue serial 1/0
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 1857036
  Queueing strategy: weighted fair
  Output queue: 69/1000/64/1857036 (size/max total/threshold/drops)
     Conversations  8/9/256 (active/max active/max total)
     Reserved Conversations 0/0 (allocated/max allocated)
     Available Bandwidth 600 kilobits/sec

  (depth/weight/total drops/no-buffer drops/interleaves) 4/32384/230085/0/0
  Conversation 186, linktype: ip, length: 1107
  source: 172.16.10.4, destination: 172.16.20.4, id: 0x0000, ttl: 59,
  TOS: 0 prot: 6, source port 0, destination port 22

  (depth/weight/total drops/no-buffer drops/interleaves) 9/32384/238011/0/0
  Conversation 189, linktype: ip, length: 64
  source: 172.16.10.4, destination: 172.16.20.4, id: 0x0000, ttl: 59,
  TOS: 0 prot: 6, source port 0, destination port 25

  (depth/weight/total drops/no-buffer drops/interleaves) 4/32384/236049/0/0
  Conversation 185, linktype: ip, length: 131
  source: 172.16.10.4, destination: 172.16.20.4, id: 0x0000, ttl: 59,
  TOS: 0 prot: 6, source port 0, destination port 21

  (depth/weight/total drops/no-buffer drops/interleaves) 10/32384/224309/0/0
  Conversation 43, linktype: ip, length: 714
  source: 172.16.10.4, destination: 172.16.20.4, id: 0x0000, ttl: 59,
  TOS: 0 prot: 6, source port 0, destination port 6000

  (depth/weight/total drops/no-buffer drops/interleaves) 11/32384/235744/0/0
  Conversation 244, linktype: ip, length: 421
  source: 172.16.10.4, destination: 172.16.20.4, id: 0x0000, ttl: 59,
  TOS: 0 prot: 6, source port 0, destination port 80

  (depth/weight/total drops/no-buffer drops/interleaves) 10/32384/231703/0/0
  Conversation 187, linktype: ip, length: 1488
  source: 172.16.10.4, destination: 172.16.20.4, id: 0x0000, ttl: 59,
  TOS: 0 prot: 6, source port 0, destination port 23

  (depth/weight/total drops/no-buffer drops/interleaves) 8/32384/233364/0/0
  Conversation 31, linktype: ip, length: 1015
  source: 172.16.10.4, destination: 172.16.20.4, id: 0x0000, ttl: 59,
  TOS: 0 prot: 6, source port 0, destination port 123

  (depth/weight/total drops/no-buffer drops/interleaves) 13/32384/229691/0/0
  Conversation 18, linktype: ip, length: 1055
  source: 172.16.10.4, destination: 172.16.20.4, id: 0x0000, ttl: 59,
  TOS: 0 prot: 6, source port 0, destination port 110
        

R1#

Now, change the queuing strategy of the serial interface to FIFO by disabling fair queuing on the interface.
R1(config)#interface serial 1/0
R1(config-if)#no fair-queue

First, clear the interface counters. Then, verify the change with the show interfaces command.
R1#clear counters

After 5 minuntes
R1#show interfaces serial 1/0
R1#ping 172.16.12.2 repeat 20  <---ping be="" br="" but="" can="" dynamips="" fail="" it.="" not="" should="" show="">R1#show interfaces serial 1/0 summary

You may modify the size of the output hold queue using the hold-queue depth out command to provision a number of packets.
R1(config)#interface serial 1/0
R1(config-if)#hold-queue 1000 out


Step 5: Modify Default Queuing Settings
On the serial interface, make the queue size 256 packets each (queue sizes must be an exponent of 2), and have 32 queues available for dynamic allocation.
R1(config)#interface serial 1/0
R1(config-if)#fair-queue 256 32

R1#show interfaces serial 1/0
R1#show queueing

Since you have limited the number of dynamic conversation queues that can be created to 32, ICMP traffic will not get allocated a dynamic queue when it needs it. Thus, some packets will be dropped.
R1#ping 172.16.12.2 repeat 20

Type escape sequence to abort.
Sending 20, 100-byte ICMP Echos to 172.16.12.2, timeout is 2 seconds:
..!!!!..!..!.!!!!!..
Success rate is 55 percent (11/20), round-trip min/avg/max = 24/422/1444 ms
R1#


Reference:
Cisco Networking Academy
http://www.cisco.com/web/learning/netacad/index.html

CCNP Version 5.0: Optimizing Converged Cisco Networks
Student Lab Manual


最初發表 / 最後更新: 2009.03.22 / 2018.06.14

0 comments:

張貼留言